aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-01-18 18:28:16 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-01-18 18:28:16 +0800
commit94e6176582957bead6dcfab025b7985bcc2c9c34 (patch)
treef14ebfb3c85d0d98b880026618e6e9def2259cb5 /devel
parentf6692c0096a5b7c74888debc5c7b08da62b9901e (diff)
downloadfreebsd-ports-gnome-94e6176582957bead6dcfab025b7985bcc2c9c34.tar.gz
freebsd-ports-gnome-94e6176582957bead6dcfab025b7985bcc2c9c34.tar.zst
freebsd-ports-gnome-94e6176582957bead6dcfab025b7985bcc2c9c34.zip
- Add p5-Types-Core 0.1.4
Types::Core provides syntax symplifier for type checking. It allows easy, non-quoted usage of types as literals, and allows the standard type names to be used as true/false check routines of references. For the most basic functions, they take either 0 or 1 arguments. If 1 parameter, then they test it to see if the ref is of the given type (blessed or not). If false, undef is returned, of true, the ref, itself is returned. For no args, they return literals of themselves, allowing the named strings to be used as Literals without quotes. WWW: http://search.cpan.org/dist/Types-Core/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Types-Core/Makefile30
-rw-r--r--devel/p5-Types-Core/distinfo2
-rw-r--r--devel/p5-Types-Core/pkg-descr12
-rw-r--r--devel/p5-Types-Core/pkg-plist2
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f51b9c5b42a3..7166c1e046b4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3122,6 +3122,7 @@
SUBDIR += p5-Type-Tie
SUBDIR += p5-Type-Tiny
SUBDIR += p5-Type-Tiny-XS
+ SUBDIR += p5-Types-Core
SUBDIR += p5-Types-Path-Tiny
SUBDIR += p5-Types-Serialiser
SUBDIR += p5-UDCode
diff --git a/devel/p5-Types-Core/Makefile b/devel/p5-Types-Core/Makefile
new file mode 100644
index 000000000000..82e943ebe830
--- /dev/null
+++ b/devel/p5-Types-Core/Makefile
@@ -0,0 +1,30 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Types-Core
+PORTVERSION= 0.1.4
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:LAWALSH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Core types defined as tests and literals
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Xporter>=0.0.7:${PORTSDIR}/devel/p5-Xporter \
+ p5-mem>=0.4.3:${PORTSDIR}/devel/p5-mem
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.82:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Types-Core/distinfo b/devel/p5-Types-Core/distinfo
new file mode 100644
index 000000000000..efdb9da9cb9b
--- /dev/null
+++ b/devel/p5-Types-Core/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Types-Core-0.1.4.tar.gz) = ec21ebd3c992fdf0283c455f8d3428851706198f33d90f2576212be5fd7b3061
+SIZE (Types-Core-0.1.4.tar.gz) = 14199
diff --git a/devel/p5-Types-Core/pkg-descr b/devel/p5-Types-Core/pkg-descr
new file mode 100644
index 000000000000..cd9b3933645e
--- /dev/null
+++ b/devel/p5-Types-Core/pkg-descr
@@ -0,0 +1,12 @@
+Types::Core provides syntax symplifier for type checking. It allows easy,
+non-quoted usage of types as literals, and allows the standard type names to be
+used as true/false check routines of references.
+
+For the most basic functions, they take either 0 or 1 arguments. If 1 parameter,
+then they test it to see if the ref is of the given type (blessed or not). If
+false, undef is returned, of true, the ref, itself is returned.
+
+For no args, they return literals of themselves, allowing the named strings to
+be used as Literals without quotes.
+
+WWW: http://search.cpan.org/dist/Types-Core/
diff --git a/devel/p5-Types-Core/pkg-plist b/devel/p5-Types-Core/pkg-plist
new file mode 100644
index 000000000000..102aada67c53
--- /dev/null
+++ b/devel/p5-Types-Core/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Types/Core.pm
+%%PERL5_MAN3%%/Types::Core.3.gz