aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-03 17:49:21 +0800
committermiwi <miwi@FreeBSD.org>2007-02-03 17:49:21 +0800
commit952275c0fb6de94e6f81b2aed66f86335318b41e (patch)
tree76365783b0af92eae83c259e786e896a0e1a8eb0 /devel
parentbde74743a6977dd72258b45457669b5317cceeb2 (diff)
downloadfreebsd-ports-gnome-952275c0fb6de94e6f81b2aed66f86335318b41e.tar.gz
freebsd-ports-gnome-952275c0fb6de94e6f81b2aed66f86335318b41e.tar.zst
freebsd-ports-gnome-952275c0fb6de94e6f81b2aed66f86335318b41e.zip
- Update to 0.6.1
PR: 108612 Submitted by: Marcus von Appen <mva@sysfault.org> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/guichan/Makefile15
-rw-r--r--devel/guichan/distinfo6
-rw-r--r--devel/guichan/pkg-plist12
3 files changed, 11 insertions, 22 deletions
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
index 6f5d3afdbada..d912fc44a00c 100644
--- a/devel/guichan/Makefile
+++ b/devel/guichan/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= guichan
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.1
CATEGORIES= devel games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= mva@sysfault.org
COMMENT= A small, efficient C++ GUI library designed for games
@@ -25,8 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
OPTIONS= SDL "Enable SDL support" On \
ALLEGRO "Enable Allegro support" Off \
- GL "Enable OpenGL support" On \
- GLUT "Enable Glut support" Off
+ GL "Enable OpenGL support" On
.include <bsd.port.pre.mk>
@@ -57,13 +55,4 @@ CONFIGURE_ARGS+=--disable-opengl
PLIST_SUB+= GL="@comment "
.endif
-.if defined(WITH_GLUT)
-CONFIGURE_ARGS+=--enable-glut
-LIB_DEPENDS+= glut.4:${PORTSDIR}/graphics/libglut
-PLIST_SUB+= GLUT=""
-.else
-CONFIGURE_ARGS+=--disable-glut
-PLIST_SUB+= GLUT="@comment "
-.endif
-
.include <bsd.port.post.mk>
diff --git a/devel/guichan/distinfo b/devel/guichan/distinfo
index 54a0d40b07ca..7aa4cefe8dbc 100644
--- a/devel/guichan/distinfo
+++ b/devel/guichan/distinfo
@@ -1,3 +1,3 @@
-MD5 (guichan-0.5.0-src.tar.gz) = c9fcbcb360105247da06afc5c643e664
-SHA256 (guichan-0.5.0-src.tar.gz) = cdc44871704b3954d9a16d75c81e2f23aa4ee32e745138aa3edcbd104fdf0bff
-SIZE (guichan-0.5.0-src.tar.gz) = 1492575
+MD5 (guichan-0.6.1.tar.gz) = 830145f71ad4ce4c91e09808fec68c8a
+SHA256 (guichan-0.6.1.tar.gz) = ea4151d0f4e24baee918ec29ecc458aefe465e9caf94ce0d1f230c3c0f26ef98
+SIZE (guichan-0.6.1.tar.gz) = 488857
diff --git a/devel/guichan/pkg-plist b/devel/guichan/pkg-plist
index aa6120086c47..be8398d17bb5 100644
--- a/devel/guichan/pkg-plist
+++ b/devel/guichan/pkg-plist
@@ -1,10 +1,13 @@
include/guichan.hpp
+include/guichan/actionevent.hpp
include/guichan/actionlistener.hpp
include/guichan/allegro.hpp
include/guichan/basiccontainer.hpp
include/guichan/cliprectangle.hpp
include/guichan/color.hpp
+include/guichan/deathlistener.hpp
include/guichan/defaultfont.hpp
+include/guichan/event.hpp
include/guichan/exception.hpp
include/guichan/focushandler.hpp
include/guichan/font.hpp
@@ -15,10 +18,13 @@ include/guichan/image.hpp
include/guichan/imagefont.hpp
include/guichan/imageloader.hpp
include/guichan/input.hpp
+include/guichan/inputevent.hpp
include/guichan/key.hpp
+include/guichan/keyevent.hpp
include/guichan/keyinput.hpp
include/guichan/keylistener.hpp
include/guichan/listmodel.hpp
+include/guichan/mouseevent.hpp
include/guichan/mouseinput.hpp
include/guichan/mouselistener.hpp
include/guichan/opengl.hpp
@@ -44,7 +50,6 @@ include/guichan/x.hpp
%%ALLEGRO%%include/guichan/allegro/allegroimage.hpp
%%ALLEGRO%%include/guichan/allegro/allegroimageloader.hpp
%%ALLEGRO%%include/guichan/allegro/allegroinput.hpp
-%%GLUT%%include/guichan/glut/glutinput.hpp
%%GL%%include/guichan/opengl/openglgraphics.hpp
%%GL%%include/guichan/opengl/openglimage.hpp
%%GL%%include/guichan/opengl/openglsdlimageloader.hpp
@@ -61,10 +66,6 @@ lib/libguichan.so
%%ALLEGRO%%lib/libguichan_allegro.la
%%ALLEGRO%%lib/libguichan_allegro.so
%%ALLEGRO%%lib/libguichan_allegro.so.0
-%%GLUT%%lib/libguichan_glut.a
-%%GLUT%%lib/libguichan_glut.la
-%%GLUT%%lib/libguichan_glut.so
-%%GLUT%%lib/libguichan_glut.so.0
%%GL%%lib/libguichan_opengl.a
%%GL%%lib/libguichan_opengl.la
%%GL%%lib/libguichan_opengl.so
@@ -74,7 +75,6 @@ lib/libguichan.so
%%SDL%%lib/libguichan_sdl.so
%%SDL%%lib/libguichan_sdl.so.0
%%ALLEGRO%%@dirrm include/guichan/allegro
-%%GLUT%%@dirrm include/guichan/glut
%%GL%%@dirrm include/guichan/opengl
%%SDL%%@dirrm include/guichan/sdl
@dirrm include/guichan/widgets