aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-04-25 04:43:37 +0800
committermarcus <marcus@FreeBSD.org>2005-04-25 04:43:37 +0800
commit9590b4dcdb959d73531bb98a1eb5d3c4a3fd7148 (patch)
tree885b9b89b0c66bdbed43e0704f5f8e484d757097 /devel
parent558e1ada8048246e3a78ae3b56400b2d287214c1 (diff)
downloadfreebsd-ports-gnome-9590b4dcdb959d73531bb98a1eb5d3c4a3fd7148.tar.gz
freebsd-ports-gnome-9590b4dcdb959d73531bb98a1eb5d3c4a3fd7148.tar.zst
freebsd-ports-gnome-9590b4dcdb959d73531bb98a1eb5d3c4a3fd7148.zip
Add a ``tests'' target to run the built-in gamin regression tests.
Discussed with: jylefort
Diffstat (limited to 'devel')
-rw-r--r--devel/gamin/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/gamin/Makefile b/devel/gamin/Makefile
index 0ac62b7b708c..0f41dc558e85 100644
--- a/devel/gamin/Makefile
+++ b/devel/gamin/Makefile
@@ -33,4 +33,9 @@ USE_INC_LIBTOOL_VER=15
post-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
+tests: build
+ @${ECHO_MSG} "===> Running gamin regression tests"
+ @(cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ Makefile ${MAKE_ARGS} tests)
+
.include <bsd.port.mk>