aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2018-09-28 00:55:05 +0800
committerbdrewery <bdrewery@FreeBSD.org>2018-09-28 00:55:05 +0800
commit95abbc9b81cdcd0944a8454b460df6fd7e2931df (patch)
tree24014d7997d73521eddbef300ab9f48c04a094fb /devel
parente728d4898a6f3f28a81a78803cee764d2cdc0d70 (diff)
downloadfreebsd-ports-gnome-95abbc9b81cdcd0944a8454b460df6fd7e2931df.tar.gz
freebsd-ports-gnome-95abbc9b81cdcd0944a8454b460df6fd7e2931df.tar.zst
freebsd-ports-gnome-95abbc9b81cdcd0944a8454b460df6fd7e2931df.zip
- Fix build on powerpc64
PR: 231743 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'devel')
-rw-r--r--devel/gearmand/Makefile4
-rw-r--r--devel/gearmand/files/patch-configure12
-rw-r--r--devel/gearmand/files/patch-libtest_timer.hpp10
3 files changed, 24 insertions, 2 deletions
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 7371f728dc05..74306e5e4e73 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -11,7 +11,6 @@ MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Gearman C Server and Library
BROKEN_sparc64= fails to build: cannot link with boost
-BROKEN_powerpc64= fails to build: checking for the Boost program_options library... no
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
@@ -23,7 +22,8 @@ CONFLICTS= p5-Gearman-Server-1.* gearmand-1.1.*
USERS= gearmand
GROUPS= gearmand
-USES= pathfix gmake perl5 python:build libtool
+USES= compiler:c++11-lang pathfix gmake perl5 python:build libtool
+USE_CXXSTD= c++11
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/gearmand/files/patch-configure b/devel/gearmand/files/patch-configure
index 40f057f73c04..3ce1c9832b43 100644
--- a/devel/gearmand/files/patch-configure
+++ b/devel/gearmand/files/patch-configure
@@ -1,5 +1,17 @@
--- ./configure.orig 2013-07-17 10:46:57.000000000 -0400
+++ ./configure 2013-07-17 10:46:57.000000000 -0400
+@@ -16842,11 +16842,6 @@
+ $as_echo "$boost_cv_lib_version" >&6; }
+ # e.g. "134" for 1_34_1 or "135" for 1_35
+ boost_major_version=`echo "$boost_cv_lib_version" | sed 's/_//;s/_.*//'`
+- case $boost_major_version in #(
+- '' | *[!0-9]*)
+- as_fn_error $? "invalid value: boost_major_version=$boost_major_version" "$LINENO" 5
+- ;;
+- esac
+ fi
+ CPPFLAGS=$boost_save_CPPFLAGS
+
@@ -17972,7 +17972,7 @@
else
diff --git a/devel/gearmand/files/patch-libtest_timer.hpp b/devel/gearmand/files/patch-libtest_timer.hpp
new file mode 100644
index 000000000000..9a8e75a07f97
--- /dev/null
+++ b/devel/gearmand/files/patch-libtest_timer.hpp
@@ -0,0 +1,10 @@
+--- libtest/timer.hpp.orig 2018-09-26 15:24:37 UTC
++++ libtest/timer.hpp
+@@ -39,6 +39,7 @@
+ #include <cstdlib>
+ #include <ctime>
+ #include <iostream>
++#include <stdint.h>
+
+
+ namespace libtest {