aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-17 03:43:09 +0800
committerknu <knu@FreeBSD.org>2002-01-17 03:43:09 +0800
commit9792bc4e8b69fd0c51b871d462a01d1c81eee155 (patch)
treee3a7fb32add72c2753beaa4bd8f38476dfbb5b5c /devel
parent7fc8e9a40d24929868dfa2d2dc88d18c2f25de13 (diff)
downloadfreebsd-ports-gnome-9792bc4e8b69fd0c51b871d462a01d1c81eee155.tar.gz
freebsd-ports-gnome-9792bc4e8b69fd0c51b871d462a01d1c81eee155.tar.zst
freebsd-ports-gnome-9792bc4e8b69fd0c51b871d462a01d1c81eee155.zip
Add mingw-opengl-headers, OpenGL headers from Microsoft(TM) for
Windows development with Mingw. PR: ports/33490 Submitted by: Michal Pasternak <doc@lublin.t1.pl>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mingw-opengl-headers/Makefile36
-rw-r--r--devel/mingw-opengl-headers/distinfo1
-rw-r--r--devel/mingw-opengl-headers/pkg-comment1
-rw-r--r--devel/mingw-opengl-headers/pkg-descr6
-rw-r--r--devel/mingw-opengl-headers/pkg-plist7
6 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1366eff07775..fa0a6e1f0169 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -283,6 +283,7 @@
SUBDIR += mingw-bin-msvcrt
SUBDIR += mingw-binutils
SUBDIR += mingw-gcc
+ SUBDIR += mingw-opengl-headers
SUBDIR += mips-rtems-binutils
SUBDIR += mips-rtems-chill
SUBDIR += mips-rtems-g77
diff --git a/devel/mingw-opengl-headers/Makefile b/devel/mingw-opengl-headers/Makefile
new file mode 100644
index 000000000000..ebb91f0fd601
--- /dev/null
+++ b/devel/mingw-opengl-headers/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: OpenGL headers for Mingw32
+# Date created: 29 Dec 2001
+# Whom: Michal Pasternak <doc@lublin.t1.pl>
+#
+# $FreeBSD$
+
+PORTNAME= opengl
+PORTVERSION= 20011229
+CATEGORIES= devel graphics
+MASTER_SITES= ftp://ftp.microsoft.com/softlib/mslfiles/
+PKGNAMEPREFIX= mingw-
+PKGNAMESUFFIX= -headers
+DISTNAME= opengl95
+EXTRACT_SUFX= .exe
+DIST_SUBDIR= mingw
+
+MAINTAINER= doc@lublin.t1.pl
+
+BUILD_DEPENDS= mingwm10.dll:${PORTSDIR}/devel/mingw-bin-msvcrt
+
+RESTRICTED= "Not sure if we can redistribute it"
+
+USE_ZIP= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/i386-mingw32msvc/include/GL
+ ${LN} -s ${PREFIX}/i386-mingw32msvc/include/GL ${PREFIX}/i386-mingw32msvc/include/gl
+ ${CP} ${WRKSRC}/INCLUDE/GL/GL.H ${PREFIX}/i386-mingw32msvc/include/GL/gl.h
+ ${CP} ${WRKSRC}/INCLUDE/GL/GLAUX.H ${PREFIX}/i386-mingw32msvc/include/GL/glaux.h
+ ${CP} ${WRKSRC}/INCLUDE/GL/GLU.H ${PREFIX}/i386-mingw32msvc/include/GL/glu.h
+ ${CP} ${WRKSRC}/DLL/GLU32.DLL ${PREFIX}/i386-mingw32msvc/lib/glu32.dll
+ ${CP} ${WRKSRC}/DLL/OPENGL32.DLL ${PREFIX}/i386-mingw32msvc/lib/opengl32.dll
+
+.include <bsd.port.mk>
diff --git a/devel/mingw-opengl-headers/distinfo b/devel/mingw-opengl-headers/distinfo
new file mode 100644
index 000000000000..256eb941e06e
--- /dev/null
+++ b/devel/mingw-opengl-headers/distinfo
@@ -0,0 +1 @@
+MD5 (mingw/opengl95.exe) = edb0a9c371be828d2b5d2e90c5c89cb3
diff --git a/devel/mingw-opengl-headers/pkg-comment b/devel/mingw-opengl-headers/pkg-comment
new file mode 100644
index 000000000000..5a1bbd4336ee
--- /dev/null
+++ b/devel/mingw-opengl-headers/pkg-comment
@@ -0,0 +1 @@
+OpenGL headers from Microsoft(TM) for Windows development with Mingw
diff --git a/devel/mingw-opengl-headers/pkg-descr b/devel/mingw-opengl-headers/pkg-descr
new file mode 100644
index 000000000000..ca8ea380e134
--- /dev/null
+++ b/devel/mingw-opengl-headers/pkg-descr
@@ -0,0 +1,6 @@
+Headers and DLLs for OpenGL development, missing in MinGW installation.
+
+Read more about MinGW + OpenGL at
+WWW: http://sites.netscape.net/ptrpck/
+
+-- Michal Pasternak <doc@lublin.t1.pl>
diff --git a/devel/mingw-opengl-headers/pkg-plist b/devel/mingw-opengl-headers/pkg-plist
new file mode 100644
index 000000000000..976fda12cce0
--- /dev/null
+++ b/devel/mingw-opengl-headers/pkg-plist
@@ -0,0 +1,7 @@
+i386-mingw32msvc/include/gl
+i386-mingw32msvc/include/GL/gl.h
+i386-mingw32msvc/include/GL/glaux.h
+i386-mingw32msvc/include/GL/glu.h
+i386-mingw32msvc/lib/glu32.dll
+i386-mingw32msvc/lib/opengl32.dll
+@dirrm i386-mingw32msvc/include/GL