aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2013-09-06 22:10:36 +0800
committerbf <bf@FreeBSD.org>2013-09-06 22:10:36 +0800
commit97d01901f035796e98227e3b6772ab2401438c9c (patch)
tree2aee246211c205145ff81b50c608cc5af5d68091 /devel
parente789fbd8ee332699e9806c7144a8903818eecad6 (diff)
downloadfreebsd-ports-gnome-97d01901f035796e98227e3b6772ab2401438c9c.tar.gz
freebsd-ports-gnome-97d01901f035796e98227e3b6772ab2401438c9c.tar.zst
freebsd-ports-gnome-97d01901f035796e98227e3b6772ab2401438c9c.zip
Update to 1.7.2
Diffstat (limited to 'devel')
-rw-r--r--devel/udis86/Makefile9
-rw-r--r--devel/udis86/distinfo4
-rw-r--r--devel/udis86/files/patch-udcli__udcli.c11
3 files changed, 7 insertions, 17 deletions
diff --git a/devel/udis86/Makefile b/devel/udis86/Makefile
index 7df46436f57c..2b8521a4b2d2 100644
--- a/devel/udis86/Makefile
+++ b/devel/udis86/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= udis86
-PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTVERSION= 1.7.2
CATEGORIES= devel
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME:L}/${PORTNAME:L}/${PORTVERSION:R}
@@ -13,7 +12,7 @@ COMMENT= Minimalistic x86 and x86-64 disassembler library
LICENSE= BSD
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -25,6 +24,8 @@ PORTDOCS= x86
.include <bsd.port.options.mk>
post-patch:
+ @${REINPLACE_CMD} -Ee 's/function ([^#]+).*/\1 ()/' \
+ ${WRKSRC}/tests/difftest.sh.in
.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '\|docdir =|s|/docs/|/doc/|' \
${WRKSRC}/docs/manual/Makefile.in \
@@ -39,7 +40,7 @@ CONFIGURE_ENV+= PYTHON="${PYTHON_CMD}" YASM="${LOCALBASE}/bin/yasm"
USE_PYTHON_BUILD= yes
check regression-test test: build
- @cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} check
+ @cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check
.else
CONFIGURE_ARGS+= --without-yasm
diff --git a/devel/udis86/distinfo b/devel/udis86/distinfo
index 96c149f090bc..85f5cbc9450f 100644
--- a/devel/udis86/distinfo
+++ b/devel/udis86/distinfo
@@ -1,2 +1,2 @@
-SHA256 (udis86-1.7.1.tar.gz) = 1d76cb3af62e262178c36c7704cfe35e87115a0cc4401f9592f4d6c9e2dc0584
-SIZE (udis86-1.7.1.tar.gz) = 442463
+SHA256 (udis86-1.7.2.tar.gz) = 9c52ac626ac6f531e1d6828feaad7e797d0f3cce1e9f34ad4e84627022b3c2f4
+SIZE (udis86-1.7.2.tar.gz) = 445085
diff --git a/devel/udis86/files/patch-udcli__udcli.c b/devel/udis86/files/patch-udcli__udcli.c
deleted file mode 100644
index 129f95eefff0..000000000000
--- a/devel/udis86/files/patch-udcli__udcli.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- udcli/udcli.c.orig 2009-06-23 02:05:47.000000000 -0400
-+++ udcli/udcli.c 2009-06-23 02:06:25.000000000 -0400
-@@ -46,7 +46,7 @@
- " -o <pc> : Set the value of program counter to <pc>. (default = 0)\n"
- " -s <n> : Set the number of bytes to skip before disassembly to <n>.\n"
- " -c <n> : Set the number of bytes to disassemble to <n>.\n"
-- " -x : Set the input mode to whitespace seperated 8-bit numbers in\n"
-+ " -x : Set the input mode to whitespace-separated 8-bit numbers in\n"
- " hexadecimal representation. Example: 0f 01 ae 00\n"
- " -noff : Do not display the offset of instructions.\n"
- " -nohex : Do not display the hexadecimal code of instructions.\n"