aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-06-18 12:52:10 +0800
committerijliao <ijliao@FreeBSD.org>2001-06-18 12:52:10 +0800
commit98aa5e487cd36123f76acd93ac1c79c7e0a78010 (patch)
tree861b14dbb720e1d43d090624532e4d8491b5f325 /devel
parent4bcf9e7cd0d8c377a88a8a9d9ad0ceb1ce7aef89 (diff)
downloadfreebsd-ports-gnome-98aa5e487cd36123f76acd93ac1c79c7e0a78010.tar.gz
freebsd-ports-gnome-98aa5e487cd36123f76acd93ac1c79c7e0a78010.tar.zst
freebsd-ports-gnome-98aa5e487cd36123f76acd93ac1c79c7e0a78010.zip
add libformat
C++ library that supports printf style like format printing
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libformat/Makefile20
-rw-r--r--devel/libformat/distinfo1
-rw-r--r--devel/libformat/pkg-comment1
-rw-r--r--devel/libformat/pkg-descr3
-rw-r--r--devel/libformat/pkg-plist5
6 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6f14922e9567..9240bfa790d6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -191,6 +191,7 @@
SUBDIR += libdsp
SUBDIR += libelf
SUBDIR += libffi
+ SUBDIR += libformat
SUBDIR += libg++
SUBDIR += libgetline
SUBDIR += libgii
diff --git a/devel/libformat/Makefile b/devel/libformat/Makefile
new file mode 100644
index 000000000000..da3e1cd3a3cf
--- /dev/null
+++ b/devel/libformat/Makefile
@@ -0,0 +1,20 @@
+# ex:ts=8
+# New ports collection makefile for: libFormat
+# Date created: Jun 19, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libformat
+PORTVERSION= 0.1.2
+CATEGORIES= devel
+MASTER_SITES= http://members.chello.at/oberzalek/development/
+DISTNAME= Format-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libformat/distinfo b/devel/libformat/distinfo
new file mode 100644
index 000000000000..bc3b76794b78
--- /dev/null
+++ b/devel/libformat/distinfo
@@ -0,0 +1 @@
+MD5 (Format-0.1.2.tar.gz) = a0b90ba8378f8b21e4a2ad02dde738d9
diff --git a/devel/libformat/pkg-comment b/devel/libformat/pkg-comment
new file mode 100644
index 000000000000..ec3a23186005
--- /dev/null
+++ b/devel/libformat/pkg-comment
@@ -0,0 +1 @@
+C++ library that supports printf style like format printing
diff --git a/devel/libformat/pkg-descr b/devel/libformat/pkg-descr
new file mode 100644
index 000000000000..aee3c0b6e657
--- /dev/null
+++ b/devel/libformat/pkg-descr
@@ -0,0 +1,3 @@
+C++ library that supports printf style like format printing
+
+WWW: http://members.chello.at/oberzalek/development/cpp-de.html#format
diff --git a/devel/libformat/pkg-plist b/devel/libformat/pkg-plist
new file mode 100644
index 000000000000..c6f747d3f9ec
--- /dev/null
+++ b/devel/libformat/pkg-plist
@@ -0,0 +1,5 @@
+include/Format.hh
+lib/libFormat.a
+lib/libFormat.la
+lib/libFormat.so
+lib/libFormat.so.0