aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2012-07-21 17:51:21 +0800
committerculot <culot@FreeBSD.org>2012-07-21 17:51:21 +0800
commit98b02ba022fd0df57cb2d5c00a2b5379d5d3ea82 (patch)
tree6eeabed41f612709306f4d61273e65570f96f0b2 /devel
parent7ed0d809f73b713bbea82da4ad3f6f2821ada2d9 (diff)
downloadfreebsd-ports-gnome-98b02ba022fd0df57cb2d5c00a2b5379d5d3ea82.tar.gz
freebsd-ports-gnome-98b02ba022fd0df57cb2d5c00a2b5379d5d3ea82.tar.zst
freebsd-ports-gnome-98b02ba022fd0df57cb2d5c00a2b5379d5d3ea82.zip
Acme::Comment allows multi-line comments which are filtered out.
Unlike the pseudo multi-line comment if (0) {}, the code being commented out need not be syntactically valid. WWW: http://search.cpan.org/dist/Acme-Comment/ PR: ports/169956 Submitted by: Marcello Silva Coutinho <marcellocoutinho@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Acme-Comment/Makefile31
-rw-r--r--devel/p5-Acme-Comment/distinfo2
-rw-r--r--devel/p5-Acme-Comment/pkg-descr5
-rw-r--r--devel/p5-Acme-Comment/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b5ca618fea79..695f9a6f58c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1249,6 +1249,7 @@
SUBDIR += p4web
SUBDIR += p5-AI-Pathfinding-AStar
SUBDIR += p5-AI-Prolog
+ SUBDIR += p5-Acme-Comment
SUBDIR += p5-Acme-Damn
SUBDIR += p5-Acme-MetaSyntactic
SUBDIR += p5-Agent
diff --git a/devel/p5-Acme-Comment/Makefile b/devel/p5-Acme-Comment/Makefile
new file mode 100644
index 000000000000..228032de4c69
--- /dev/null
+++ b/devel/p5-Acme-Comment/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-Acme-Comment
+# Date created: 2012-07-18
+# Whom: Marcello Coutinho <marcellocoutinho@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Acme-Comment
+PORTVERSION= 1.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= marcellocoutinho@gmail.com
+COMMENT= Allow multi-line comments which are filtered out
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= yes
+
+MAN3= Acme::Comment.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Text-Balanced>=1.99:${PORTSDIR}/textproc/p5-Text-Balanced
+RUN_DEPENDS+= p5-Text-Balanced>=1.99:${PORTSDIR}/textproc/p5-Text-Balanced
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Acme-Comment/distinfo b/devel/p5-Acme-Comment/distinfo
new file mode 100644
index 000000000000..2fecc6752f79
--- /dev/null
+++ b/devel/p5-Acme-Comment/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Acme-Comment-1.04.tar.gz) = a52fd985da35475bc077fbd070dbaab0bf26f4243c829846e7130cd04dd0bd6f
+SIZE (Acme-Comment-1.04.tar.gz) = 16423
diff --git a/devel/p5-Acme-Comment/pkg-descr b/devel/p5-Acme-Comment/pkg-descr
new file mode 100644
index 000000000000..3d0bb04ddd4f
--- /dev/null
+++ b/devel/p5-Acme-Comment/pkg-descr
@@ -0,0 +1,5 @@
+Acme::Comment allows multi-line comments which are filtered out.
+Unlike the pseudo multi-line comment if (0) {}, the code being
+commented out need not be syntactically valid.
+
+WWW: http://search.cpan.org/dist/Acme-Comment/
diff --git a/devel/p5-Acme-Comment/pkg-plist b/devel/p5-Acme-Comment/pkg-plist
new file mode 100644
index 000000000000..4d1558dc02ee
--- /dev/null
+++ b/devel/p5-Acme-Comment/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Acme/Comment.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme/Comment/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme/Comment
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme
+@dirrmtry %%SITE_PERL%%/Acme