aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgrembo <grembo@FreeBSD.org>2015-08-07 06:24:58 +0800
committergrembo <grembo@FreeBSD.org>2015-08-07 06:24:58 +0800
commit9c01eda57244f7967926f9d53aef6ea1c762ff97 (patch)
treeb9148faa23cc64e9592082f338ff4749b91a72ca /devel
parent91946517f4824727511e6e17c11116acfbb200a7 (diff)
downloadfreebsd-ports-gnome-9c01eda57244f7967926f9d53aef6ea1c762ff97.tar.gz
freebsd-ports-gnome-9c01eda57244f7967926f9d53aef6ea1c762ff97.tar.zst
freebsd-ports-gnome-9c01eda57244f7967926f9d53aef6ea1c762ff97.zip
Update devel/cdash to 2.2.3 and fix various issues
Differential Revision: https://reviews.freebsd.org/D3310 Reviewed by: bapt (mentor) Approved by: bapt (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/cdash/Makefile20
-rw-r--r--devel/cdash/distinfo4
-rw-r--r--devel/cdash/files/patch-cdash-common.php10
-rw-r--r--devel/cdash/pkg-plist68
4 files changed, 82 insertions, 20 deletions
diff --git a/devel/cdash/Makefile b/devel/cdash/Makefile
index fb4a822cbeb9..106d3c84cab0 100644
--- a/devel/cdash/Makefile
+++ b/devel/cdash/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= cdash
-PORTVERSION= 2.0.2
-PORTREVISION= 2
+PORTVERSION= 2.2.3
CATEGORIES= devel
-MASTER_SITES= http://www.cdash.org/download/
-DISTNAME= CDash-${PORTVERSION}
+MASTER_SITES= http://www.cdash.org/wp-content/uploads/2014/11/
+DISTNAME= CDash-2-2-3
MAINTAINER= ports@FreeBSD.org
COMMENT= Web-based software testing server
@@ -21,10 +20,10 @@ USES= cmake:outsource zip
CMAKE_ARGS+= -DCDASH_DB_NAME:STRING=cdash \
-DCDASH_DB_LOGIN:STRING=cdash \
-DCDASH_DB_TYPE:STRING=${DB_TYPE}
-USE_PHP= curl gd xsl
+USE_PHP= curl gd pdo session xsl zlib
WRKSRC= ${WRKDIR}/${DISTNAME:S/./-/g}
-PLIST_SUB= WWWOWN="${WWWOWN}"
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
SUB_LIST+= DB_TYPE=${DB_TYPE}
@@ -32,19 +31,22 @@ SUB_LIST+= DB_TYPE=${DB_TYPE}
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
-USE_PHP+= mysql
+USE_PHP+= mysql pdo_mysql
DB_TYPE= mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
USES+= pgsql
-USE_PHP+= pgsql
+USE_PHP+= pgsql pdo_pgsql
DB_TYPE= pgsql
.endif
do-install:
+ ${MKDIR} ${WRKSRC}/rss
+ ${CP} ${WRKSRC}/backup/.htaccess ${WRKSRC}/rss/.htaccess
${MKDIR} ${STAGEDIR}${PREFIX}/www/CDash
- ${RM} -f ${WRKSRC}/CMakeLists.txt.orig
+ ${FIND} ${WRKSRC} -name "*.orig" -delete
+ ${MV} ${WRKSRC}/cdash/config.local.php ${WRKSRC}/cdash/config.local.sample.php
cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/www/CDash
.include <bsd.port.mk>
diff --git a/devel/cdash/distinfo b/devel/cdash/distinfo
index 3bf5a1a1ae6c..bad951f4b998 100644
--- a/devel/cdash/distinfo
+++ b/devel/cdash/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CDash-2.0.2.zip) = e50a7d0ad321ba2739d7210dea56c3d06006dc5a0677f2607b71fd2747eb91d1
-SIZE (CDash-2.0.2.zip) = 2394352
+SHA256 (CDash-2-2-3.zip) = 712c8beb7b379d356a27ed3f4829566245da8f53e89ff5fd688ae67b204f285b
+SIZE (CDash-2-2-3.zip) = 2536252
diff --git a/devel/cdash/files/patch-cdash-common.php b/devel/cdash/files/patch-cdash-common.php
new file mode 100644
index 000000000000..d43964320b5e
--- /dev/null
+++ b/devel/cdash/files/patch-cdash-common.php
@@ -0,0 +1,10 @@
+--- cdash/common.php.orig 2015-08-05 14:20:51.000000000 +0000
++++ cdash/common.php 2015-08-05 14:21:39.038187339 +0000
+@@ -20,6 +20,7 @@
+
+ if (PHP_VERSION >= 5) {
+ // Emulate the old xslt library functions
++ libxml_disable_entity_loader(false);
+ function xslt_create() {
+ return new XsltProcessor();
+ }
diff --git a/devel/cdash/pkg-plist b/devel/cdash/pkg-plist
index 2cd114cc7191..f7da093cc433 100644
--- a/devel/cdash/pkg-plist
+++ b/devel/cdash/pkg-plist
@@ -12,6 +12,8 @@ www/CDash/ajax/expectedbuildgroup.php
www/CDash/ajax/expectedinfo.php
www/CDash/ajax/finduserproject.php
www/CDash/ajax/findusers.php
+www/CDash/ajax/getfeed.php
+www/CDash/ajax/getviewcoverage.php
www/CDash/ajax/showbuildhistory.php
www/CDash/ajax/showbuildtimegraph.php
www/CDash/ajax/showbuildupdategraph.php
@@ -33,7 +35,6 @@ www/CDash/api/getversion.php
www/CDash/api/hasfile.php
www/CDash/api/index.php
www/CDash/autoRemoveBuilds.php
-www/CDash/backup.xsl
www/CDash/backup/.htaccess
www/CDash/backup/README.txt
www/CDash/buildOverview.php
@@ -45,9 +46,10 @@ www/CDash/cdash/ChangeLog.txt
www/CDash/cdash/Copyright.txt
www/CDash/cdash/autoremove.php
www/CDash/cdash/bugurl.php
+www/CDash/cdash/cdashmail.php
www/CDash/cdash/clientsubmit.php
www/CDash/cdash/common.php
-www/CDash/cdash/config.local.php
+www/CDash/cdash/config.local.sample.php
www/CDash/cdash/config.php
www/CDash/cdash/createRSS.php
www/CDash/cdash/ctestparser.php
@@ -65,6 +67,8 @@ www/CDash/cdash/processsubmissions.php
www/CDash/cdash/repository.php
www/CDash/cdash/sendemail.php
www/CDash/cdash/version.php
+www/CDash/colorblind.css
+www/CDash/common.css
www/CDash/createProject.php
www/CDash/createProject.xsl
www/CDash/displayImage.php
@@ -72,6 +76,8 @@ www/CDash/editSite.php
www/CDash/editSite.xsl
www/CDash/editUser.php
www/CDash/editUser.xsl
+www/CDash/error.php
+www/CDash/error.xsl
www/CDash/favicon.ico
www/CDash/filterdataFunctions.php
www/CDash/filterdataTemplate.xsl
@@ -83,6 +89,7 @@ www/CDash/headeradminproject.xsl
www/CDash/headerback.xsl
www/CDash/headscripts.xsl
www/CDash/help.html
+www/CDash/htaccess.in
www/CDash/images/Calendar.gif
www/CDash/images/Closed.gif
www/CDash/images/DownBlack.gif
@@ -97,6 +104,9 @@ www/CDash/images/RightBlack.gif
www/CDash/images/activity-level.png
www/CDash/images/advanced.png
www/CDash/images/asc.gif
+www/CDash/images/back_disabled.png
+www/CDash/images/back_enabled.png
+www/CDash/images/back_enabled_hover.png
www/CDash/images/bg.gif
www/CDash/images/bg1.gif
www/CDash/images/bgfo.gif
@@ -121,13 +131,18 @@ www/CDash/images/error.png
www/CDash/images/feed-icon16x16.png
www/CDash/images/filecoverage.png
www/CDash/images/filter.gif
+www/CDash/images/first.png
www/CDash/images/flag.png
www/CDash/images/flaggreen.gif
www/CDash/images/folder.png
+www/CDash/images/forward_disabled.png
+www/CDash/images/forward_enabled.png
+www/CDash/images/forward_enabled_hover.png
www/CDash/images/graph.png
www/CDash/images/help.gif
www/CDash/images/hide.png
www/CDash/images/invite.png
+www/CDash/images/last.png
www/CDash/images/loading.gif
www/CDash/images/logo2.gif
www/CDash/images/mail.png
@@ -143,13 +158,19 @@ www/CDash/images/platform_freebsd.png
www/CDash/images/platform_linux.png
www/CDash/images/platform_mac.png
www/CDash/images/platform_windows.png
+www/CDash/images/prev.png
www/CDash/images/previous.png
www/CDash/images/progressbar.gif
-www/CDash/images/progressbg_green.gif
-www/CDash/images/progressbg_orange.gif
-www/CDash/images/progressbg_red.gif
www/CDash/images/refresh.png
+www/CDash/images/settings.png
www/CDash/images/show.png
+www/CDash/images/smiley-bad.png
+www/CDash/images/smiley-good.png
+www/CDash/images/sort_asc.png
+www/CDash/images/sort_asc_disabled.png
+www/CDash/images/sort_both.png
+www/CDash/images/sort_desc.png
+www/CDash/images/sort_desc_disabled.png
www/CDash/images/star.png
www/CDash/images/subproject.png
www/CDash/images/systemtray.png
@@ -202,6 +223,7 @@ www/CDash/javascript/cdashBuildGroup.js
www/CDash/javascript/cdashClient.js
www/CDash/javascript/cdashCoverageGraph.js
www/CDash/javascript/cdashCreateProject.js
+www/CDash/javascript/cdashFeed.js
www/CDash/javascript/cdashFilters.js
www/CDash/javascript/cdashIndexTable.js
www/CDash/javascript/cdashManageCoverageSorter.js
@@ -215,8 +237,10 @@ www/CDash/javascript/cdashUpgrade.js
www/CDash/javascript/cdashUploadFilesSorter.js
www/CDash/javascript/cdashUser.js
www/CDash/javascript/cdashUserLabels.js
+www/CDash/javascript/cdashViewCoverage.js
www/CDash/javascript/cdashmenu.js
www/CDash/javascript/excanvas.js
+www/CDash/javascript/images/next.png
www/CDash/javascript/images/ui-bg_diagonals-thick_90_eeeeee_40x40.png
www/CDash/javascript/images/ui-bg_flat_15_cd0a0a_40x100.png
www/CDash/javascript/images/ui-bg_glass_100_e4f1fb_1x400.png
@@ -231,16 +255,21 @@ www/CDash/javascript/images/ui-icons_2e83ff_256x240.png
www/CDash/javascript/images/ui-icons_3d80b3_256x240.png
www/CDash/javascript/images/ui-icons_72a7cf_256x240.png
www/CDash/javascript/images/ui-icons_ffffff_256x240.png
+www/CDash/javascript/je_compare-1.0.0.min.js
+www/CDash/javascript/je_compare_style-1.0.0.css
www/CDash/javascript/jqModal.css
www/CDash/javascript/jqModal.js
www/CDash/javascript/jquery-1.6.2.js
www/CDash/javascript/jquery-ui-1.8.16.css
www/CDash/javascript/jquery-ui-1.8.16.min.js
www/CDash/javascript/jquery.cookie.js
+www/CDash/javascript/jquery.dataTables.css
+www/CDash/javascript/jquery.dataTables.min.js
www/CDash/javascript/jquery.flot.min.js
www/CDash/javascript/jquery.flot.pie.js
www/CDash/javascript/jquery.flot.selection.min.js
www/CDash/javascript/jquery.metadata.js
+www/CDash/javascript/jquery.mobile-1.4.0.min.js
www/CDash/javascript/jquery.qtip.min.css
www/CDash/javascript/jquery.qtip.min.js
www/CDash/javascript/jquery.tablesorter.js
@@ -271,6 +300,8 @@ www/CDash/manageClient.php
www/CDash/manageClient.xsl
www/CDash/manageCoverage.php
www/CDash/manageCoverage.xsl
+www/CDash/manageMeasurements.php
+www/CDash/manageMeasurements.xsl
www/CDash/manageProjectRoles.php
www/CDash/manageProjectRoles.xsl
www/CDash/manageSubproject.php
@@ -314,6 +345,7 @@ www/CDash/models/dailyupdatefile.php
www/CDash/models/dynamicanalysis.php
www/CDash/models/dynamicanalysisdefect.php
www/CDash/models/errorlog.php
+www/CDash/models/feed.php
www/CDash/models/image.php
www/CDash/models/label.php
www/CDash/models/labelemail.php
@@ -337,7 +369,9 @@ www/CDash/register.php
www/CDash/register.xsl
www/CDash/removeBuilds.php
www/CDash/removeBuilds.xsl
+www/CDash/robots.txt
www/CDash/router.php
+www/CDash/rss/.htaccess
www/CDash/scheduleSummary.php
www/CDash/scheduleSummary.xsl
www/CDash/scripts/cdash_client_common.ctest
@@ -352,7 +386,7 @@ www/CDash/sql/mysql/cdash-upgrade-1.2-1.4.sql
www/CDash/sql/mysql/cdash-upgrade-1.4-1.6.sql
www/CDash/sql/mysql/cdash-upgrade-1.6-1.8.sql
www/CDash/sql/mysql/cdash-upgrade-1.8-2.0.sql
-www/CDash/sql/mysql/cdash-upgrade-2.0-2.1.sql
+www/CDash/sql/mysql/cdash-upgrade-2.0-2.2.sql
www/CDash/sql/mysql/cdash.sql
www/CDash/sql/mysqlcompat.patch
www/CDash/sql/pgsql/cdash-upgrade-0-0.8.sql
@@ -362,7 +396,7 @@ www/CDash/sql/pgsql/cdash-upgrade-1.2-1.4.sql
www/CDash/sql/pgsql/cdash-upgrade-1.4-1.6.sql
www/CDash/sql/pgsql/cdash-upgrade-1.6-1.8.sql
www/CDash/sql/pgsql/cdash-upgrade-1.8-2.0.sql
-www/CDash/sql/pgsql/cdash-upgrade-2.0-2.1.sql
+www/CDash/sql/pgsql/cdash-upgrade-2.0-2.2.sql
www/CDash/sql/pgsql/cdash.ext.sql
www/CDash/sql/pgsql/cdash.sql
www/CDash/submit.php
@@ -622,7 +656,10 @@ www/CDash/tests/data/smile.gif
www/CDash/tests/data/smile2.gif
www/CDash/tests/kwtest/kw_db.php
www/CDash/tests/kwtest/kw_test_manager.php
+www/CDash/tests/kwtest/kw_unlink.php
www/CDash/tests/kwtest/kw_web_tester.php
+www/CDash/tests/kwtest/simpletest/VERSION
+www/CDash/tests/kwtest/simpletest/arguments.php
www/CDash/tests/kwtest/simpletest/authentication.php
www/CDash/tests/kwtest/simpletest/autorun.php
www/CDash/tests/kwtest/simpletest/browser.php
@@ -644,6 +681,8 @@ www/CDash/tests/kwtest/simpletest/invoker.php
www/CDash/tests/kwtest/simpletest/mock_objects.php
www/CDash/tests/kwtest/simpletest/page.php
www/CDash/tests/kwtest/simpletest/parser.php
+www/CDash/tests/kwtest/simpletest/php_parser.php
+www/CDash/tests/kwtest/simpletest/recorder.php
www/CDash/tests/kwtest/simpletest/reflection_php4.php
www/CDash/tests/kwtest/simpletest/reflection_php5.php
www/CDash/tests/kwtest/simpletest/remote.php
@@ -655,6 +694,7 @@ www/CDash/tests/kwtest/simpletest/simpletest.php
www/CDash/tests/kwtest/simpletest/socket.php
www/CDash/tests/kwtest/simpletest/tag.php
www/CDash/tests/kwtest/simpletest/test_case.php
+www/CDash/tests/kwtest/simpletest/tidy_parser.php
www/CDash/tests/kwtest/simpletest/unit_tester.php
www/CDash/tests/kwtest/simpletest/url.php
www/CDash/tests/kwtest/simpletest/user_agent.php
@@ -812,6 +852,8 @@ www/CDash/viewDynamicAnalysisFile.php
www/CDash/viewDynamicAnalysisFile.xsl
www/CDash/viewErrorLog.php
www/CDash/viewErrorLog.xsl
+www/CDash/viewFeed.php
+www/CDash/viewFeed.xsl
www/CDash/viewFiles.php
www/CDash/viewFiles.xsl
www/CDash/viewIssues.php
@@ -833,6 +875,7 @@ www/CDash/xml_handlers/abstract_handler.php
www/CDash/xml_handlers/build_handler.php
www/CDash/xml_handlers/configure_handler.php
www/CDash/xml_handlers/coverage_handler.php
+www/CDash/xml_handlers/coverage_junit_handler.php
www/CDash/xml_handlers/coverage_log_handler.php
www/CDash/xml_handlers/dynamic_analysis_handler.php
www/CDash/xml_handlers/note_handler.php
@@ -840,7 +883,14 @@ www/CDash/xml_handlers/project_handler.php
www/CDash/xml_handlers/sax_handler.php
www/CDash/xml_handlers/stack.php
www/CDash/xml_handlers/testing_handler.php
+www/CDash/xml_handlers/testing_junit_handler.php
+www/CDash/xml_handlers/testing_nunit_handler.php
www/CDash/xml_handlers/update_handler.php
www/CDash/xml_handlers/upload_handler.php
-@dir(%%WWWOWN%%,,) www/CDash/rss
-@dir(%%WWWOWN%%,,) www/CDash/backup
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
+@dir www/CDash/backup
+@dir www/CDash/rss
+@dir www/CDash/upload
+@owner
+@group