aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2013-11-29 00:08:33 +0800
committerlwhsu <lwhsu@FreeBSD.org>2013-11-29 00:08:33 +0800
commit9c6b67876c87db676b87361e530b86802eb1129d (patch)
tree4758e5abb775d4e05a67a170848b8db8aaf58f06 /devel
parent08360732b457dff04fff6cdd5e515b9c5601b6cb (diff)
downloadfreebsd-ports-gnome-9c6b67876c87db676b87361e530b86802eb1129d.tar.gz
freebsd-ports-gnome-9c6b67876c87db676b87361e530b86802eb1129d.tar.zst
freebsd-ports-gnome-9c6b67876c87db676b87361e530b86802eb1129d.zip
- Support STAGEDIR
Diffstat (limited to 'devel')
-rw-r--r--devel/py-twisted/Makefile1
-rw-r--r--devel/py-twistedCore/Makefile6
-rw-r--r--devel/py-twistedCore/pkg-plist7
-rw-r--r--devel/py-twistedRunner/Makefile1
4 files changed, 8 insertions, 7 deletions
diff --git a/devel/py-twisted/Makefile b/devel/py-twisted/Makefile
index 30185bd9ef11..6f30ae0ec031 100644
--- a/devel/py-twisted/Makefile
+++ b/devel/py-twisted/Makefile
@@ -16,7 +16,6 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/devel/py-twistedCore
NO_BUILD= yes
-NO_STAGE= yes
USE_PYTHON= -2.7
PYDISTUTILS_NOEGGINFO= yes
diff --git a/devel/py-twistedCore/Makefile b/devel/py-twistedCore/Makefile
index e408250c6faf..cbb22fd01fc0 100644
--- a/devel/py-twistedCore/Makefile
+++ b/devel/py-twistedCore/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# Twisted, but the user should feel free to install x11-toolits/py-gnome
# separately if desired.
-NO_STAGE= yes
USE_BZIP2= yes
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
@@ -32,9 +31,6 @@ REINPLACE_ARGS= -i ''
MAN1= manhole.1 pyhtmlizer.1 tap2deb.1 tap2rpm.1 tapconvert.1 trial.1 twistd.1
post-install:
-# permission safeness
- @${CHMOD} -R ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/twisted/
- @${CHMOD} -R a+X ${PYTHONPREFIX_SITELIBDIR}/twisted/
- cd ${WRKSRC}/doc/man/ && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1/
+ cd ${WRKSRC}/doc/man/ && ${INSTALL_MAN} ${MAN1} ${STAGEDIR}${MANPREFIX}/man/man1/
.include <bsd.port.mk>
diff --git a/devel/py-twistedCore/pkg-plist b/devel/py-twistedCore/pkg-plist
index 667d0c1f84c0..ef362e81022e 100644
--- a/devel/py-twistedCore/pkg-plist
+++ b/devel/py-twistedCore/pkg-plist
@@ -5,6 +5,13 @@ bin/tap2rpm
bin/tapconvert
bin/trial
bin/twistd
+man/man1/manhole.1.gz
+man/man1/pyhtmlizer.1.gz
+man/man1/tap2deb.1.gz
+man/man1/tap2rpm.1.gz
+man/man1/tapconvert.1.gz
+man/man1/trial.1.gz
+man/man1/twistd.1.gz
%%PYTHON_SITELIBDIR%%/twisted/__init__.py
%%PYTHON_SITELIBDIR%%/twisted/__init__.pyc
%%PYTHON_SITELIBDIR%%/twisted/__init__.pyo
diff --git a/devel/py-twistedRunner/Makefile b/devel/py-twistedRunner/Makefile
index 9143c3de3f10..bf01f2c4a909 100644
--- a/devel/py-twistedRunner/Makefile
+++ b/devel/py-twistedRunner/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>