aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-06-03 20:08:40 +0800
committergahr <gahr@FreeBSD.org>2013-06-03 20:08:40 +0800
commit9f0d542de1a6dad26ef731f379e3d46a7f148835 (patch)
tree215bce7279d7b4c700cc1ef1761443fd100310d7 /devel
parent531d9dd66edee7e378994fde577b9ef1286845f2 (diff)
downloadfreebsd-ports-gnome-9f0d542de1a6dad26ef731f379e3d46a7f148835.tar.gz
freebsd-ports-gnome-9f0d542de1a6dad26ef731f379e3d46a7f148835.tar.zst
freebsd-ports-gnome-9f0d542de1a6dad26ef731f379e3d46a7f148835.zip
- Fix build on CURRENT [1]
- Fix build with Tcl 8.6 PR: 178050 [1] Submitted by: Pietro Cerutti <gahr@FreeBSD.org> Approved by: maintainer (> 1 month timeout)
Diffstat (limited to 'devel')
-rw-r--r--devel/tclmore/Makefile13
-rw-r--r--devel/tclmore/files/patch-configure17
-rw-r--r--devel/tclmore/files/patch-generic_commands.c20
3 files changed, 38 insertions, 12 deletions
diff --git a/devel/tclmore/Makefile b/devel/tclmore/Makefile
index 6e8102ccde5c..460236c5a319 100644
--- a/devel/tclmore/Makefile
+++ b/devel/tclmore/Makefile
@@ -19,18 +19,11 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_TCL= yes
-USE_TCL_BUILD= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S/_src$//}
INFO= ${PORTNAME}
-CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
+ --enable-threads
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/tclmore/files/patch-configure b/devel/tclmore/files/patch-configure
index 1d7203d7ef2c..12eb9d9723d2 100644
--- a/devel/tclmore/files/patch-configure
+++ b/devel/tclmore/files/patch-configure
@@ -1,5 +1,18 @@
---- configure.orig Fri May 21 20:24:40 2004
-+++ configure Wed Apr 26 10:55:55 2006
+--- configure.orig 2004-05-21 18:24:40.000000000 +0200
++++ configure 2013-04-22 13:44:49.000000000 +0200
+@@ -6702,9 +6702,9 @@
+ # Special check for weird MP-RAS system (uname returns weird
+ # results, and the version is kept in special file).
+
+- if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print }' /etc/.relid'`
+- fi
++# if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
++# system=MP-RAS-`awk '{print $1}' /etc/.relid'`
++# fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+ fi
@@ -7847,11 +7847,12 @@
EXTRA_CFLAGS="-pthread"
LDFLAGS="$LDFLAGS -pthread"
diff --git a/devel/tclmore/files/patch-generic_commands.c b/devel/tclmore/files/patch-generic_commands.c
new file mode 100644
index 000000000000..7bee67a72db6
--- /dev/null
+++ b/devel/tclmore/files/patch-generic_commands.c
@@ -0,0 +1,20 @@
+--- generic/commands.c.orig 2013-06-03 14:05:27.000000000 +0200
++++ generic/commands.c 2013-06-03 14:06:34.000000000 +0200
+@@ -83,7 +83,7 @@
+ return TCL_OK;
+
+ case TCL_ERROR:
+- sprintf(infomsg, "\n (\"do\" body line %d)", frame->interp->errorLine);
++ sprintf(infomsg, "\n (\"do\" body line %d)", Tcl_GetErrorLine(frame->interp));
+ Tcl_AddErrorInfo(frame->interp, infomsg);
+ return TCL_ERROR;
+
+@@ -124,7 +124,7 @@
+ return TCL_OK;
+
+ case TCL_ERROR:
+- sprintf(infomsg, "\n (\"loop\" body line %d)", frame->interp->errorLine);
++ sprintf(infomsg, "\n (\"loop\" body line %d)", Tcl_GetErrorLine(frame->interp));
+ Tcl_AddErrorInfo(frame->interp, infomsg);
+ return TCL_ERROR;
+