aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2019-09-07 07:25:53 +0800
committerdbaio <dbaio@FreeBSD.org>2019-09-07 07:25:53 +0800
commit9fe6b398aa1a5ff5c187a95572120ece90a054fd (patch)
tree5c9660a22ce87e76d469e6d483d6961e449a9b08 /devel
parent9462485af6e07b4d36a9a514231a79ac4ca55cca (diff)
downloadfreebsd-ports-gnome-9fe6b398aa1a5ff5c187a95572120ece90a054fd.tar.gz
freebsd-ports-gnome-9fe6b398aa1a5ff5c187a95572120ece90a054fd.tar.zst
freebsd-ports-gnome-9fe6b398aa1a5ff5c187a95572120ece90a054fd.zip
devel/py-fabric: Update to 2.5.0
Fabric 2 is not at 100% feature parity with 1.x! Some features have been explicitly dropped, but others simply have not been ported over yet, either due to time constraints or because said features need to be re-examined in a modern context. More information at: https://www.fabfile.org/upgrading.html#upgrading https://www.fabfile.org/upgrading.html#upgrade-specifics Changelog: https://www.fabfile.org/changelog.html Reviewed by: koobs (maintainer) Approved by: koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D20683
Diffstat (limited to 'devel')
-rw-r--r--devel/py-fabric/Makefile23
-rw-r--r--devel/py-fabric/distinfo6
-rw-r--r--devel/py-fabric/files/patch-setup.py11
-rw-r--r--devel/py-fabric/pkg-descr12
4 files changed, 21 insertions, 31 deletions
diff --git a/devel/py-fabric/Makefile b/devel/py-fabric/Makefile
index 007971ab3453..9c818f6ca467 100644
--- a/devel/py-fabric/Makefile
+++ b/devel/py-fabric/Makefile
@@ -2,31 +2,34 @@
# $FreeBSD$
PORTNAME= fabric
-PORTVERSION= 1.14.1
+PORTVERSION= 2.5.0
PORTEPOCH= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= Fabric-${DISTVERSION}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Simple, Pythonic remote execution and deployment
+COMMENT= High level SSH command execution
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.10:security/py-paramiko@${PY_FLAVOR} # <3.0
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}fudge>0:devel/py-fudge@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=2.4:security/py-paramiko@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}invoke>=1.1,<2.0:devel/py-invoke@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=1.1:security/py-cryptography@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.2.5:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>=2.0.0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-relaxed>0:devel/py-pytest-relaxed@${PY_FLAVOR}
-USES= python:2.7
+USES= python
USE_PYTHON= distutils concurrent autoplist
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}fabric1
+
NO_ARCH= yes
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v \
- --exclude=test_nested_execution_with_explicit_ports
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs \
+ -k 'not python_dash_m_acts_like_fab'
.include <bsd.port.mk>
diff --git a/devel/py-fabric/distinfo b/devel/py-fabric/distinfo
index da201a341357..0e55b2f698e9 100644
--- a/devel/py-fabric/distinfo
+++ b/devel/py-fabric/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1554010618
-SHA256 (Fabric-1.14.1.tar.gz) = 66097883bb3e5beecacae92b82b2bd489d10a8fd4f06ce1cb27019de2e6d76a8
-SIZE (Fabric-1.14.1.tar.gz) = 220463
+TIMESTAMP = 1565561659
+SHA256 (fabric-2.5.0.tar.gz) = 24842d7d51556adcabd885ac3cf5e1df73fc622a1708bf3667bf5927576cdfa6
+SIZE (fabric-2.5.0.tar.gz) = 161421
diff --git a/devel/py-fabric/files/patch-setup.py b/devel/py-fabric/files/patch-setup.py
deleted file mode 100644
index faaa912c16e5..000000000000
--- a/devel/py-fabric/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2016-05-08 21:11:49 UTC
-+++ setup.py
-@@ -45,7 +45,7 @@ setup(
- url='http://fabfile.org',
- packages=find_packages(),
- test_suite='nose.collector',
-- tests_require=['nose<2.0', 'fudge<1.0', 'jinja2<3.0'],
-+ tests_require=['nose', 'fudge', 'jinja2'],
- install_requires=install_requires,
- entry_points={
- 'console_scripts': [
diff --git a/devel/py-fabric/pkg-descr b/devel/py-fabric/pkg-descr
index 39a31b532253..c61d1414070f 100644
--- a/devel/py-fabric/pkg-descr
+++ b/devel/py-fabric/pkg-descr
@@ -1,10 +1,8 @@
-Fabric is a simple pythonic remote deployment tool.
+Fabric is a high level Python library designed to execute shell commands
+remotely over SSH, yielding useful Python objects in return.
-It is designed to upload files to, and run shell commands on, a number
-of servers in parallel or serially. These commands are grouped in tasks
-(regular python functions) and specified in a 'fabfile.'
-
-This is called remote automation, and the primary use case is deploying
-applications to multiple similar hosts.
+It builds on top of Invoke (subprocess command execution and command-line
+features) and Paramiko (SSH protocol implementation), extending their APIs
+to complement one another and provide additional functionality.
WWW: https://www.fabfile.org