aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-20 05:46:32 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-20 05:46:32 +0800
commita25c86a4aabb7943ed83dc8692077ca08a0ce4fe (patch)
tree47260dad28320946cb3616582ca069e0feaff3d3 /devel
parent921f613bff818ad0052d6ecaba6033a78d83f987 (diff)
downloadfreebsd-ports-gnome-a25c86a4aabb7943ed83dc8692077ca08a0ce4fe.tar.gz
freebsd-ports-gnome-a25c86a4aabb7943ed83dc8692077ca08a0ce4fe.tar.zst
freebsd-ports-gnome-a25c86a4aabb7943ed83dc8692077ca08a0ce4fe.zip
Add py-testrepository 0.0.20
The package provides a database of test results which can be used as part of developer workflow to ensure/check things like: - No commits without having had a test failure, test fixed cycle. - No commits without new tests being added. - What tests have failed since the last commit (to run just a subset). - What tests are currently failing and need work. Test results are inserted using subunit (and thus anything that can output subunit or be converted into a subunit stream can be accepted). WWW: https://launchpad.net/testrepository PR: 228692 Submitted by: Kai <freebsd_ports@k-worx.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-testrepository/Makefile27
-rw-r--r--devel/py-testrepository/distinfo3
-rw-r--r--devel/py-testrepository/pkg-descr12
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2770543d0b32..0cb688d3834e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5054,6 +5054,7 @@
SUBDIR += py-testinfra
SUBDIR += py-testoob
SUBDIR += py-testpath
+ SUBDIR += py-testrepository
SUBDIR += py-testresources
SUBDIR += py-testscenarios
SUBDIR += py-testtools
diff --git a/devel/py-testrepository/Makefile b/devel/py-testrepository/Makefile
new file mode 100644
index 000000000000..a40bd8c33a3c
--- /dev/null
+++ b/devel/py-testrepository/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= testrepository
+DISTVERSION= 0.0.20
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Repository of test results
+
+LICENSE= APACHE20 BSD3CLAUSE
+LICENSE_COMB= dual
+LICENSE_FILE_APACHE20= ${WRKSRC}/Apache-2.0
+LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fixtures>0:devel/py-fixtures@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-subunit>=0.0.18:devel/py-python-subunit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}testtools>=0.9.30:devel/py-testtools@${PY_FLAVOR}
+
+USES= python shebangfix
+USE_PYTHON= distutils concurrent autoplist
+SHEBANG_FILES= testr
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-testrepository/distinfo b/devel/py-testrepository/distinfo
new file mode 100644
index 000000000000..712cc6910265
--- /dev/null
+++ b/devel/py-testrepository/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527335603
+SHA256 (testrepository-0.0.20.tar.gz) = 752449bc98c20253ec4611c40564aea93d435a5bf3ff672208e01cc10e5858eb
+SIZE (testrepository-0.0.20.tar.gz) = 84956
diff --git a/devel/py-testrepository/pkg-descr b/devel/py-testrepository/pkg-descr
new file mode 100644
index 000000000000..b59e3029a68e
--- /dev/null
+++ b/devel/py-testrepository/pkg-descr
@@ -0,0 +1,12 @@
+The package provides a database of test results which can be used as part of
+developer workflow to ensure/check things like:
+
+- No commits without having had a test failure, test fixed cycle.
+- No commits without new tests being added.
+- What tests have failed since the last commit (to run just a subset).
+- What tests are currently failing and need work.
+
+Test results are inserted using subunit (and thus anything that can output
+subunit or be converted into a subunit stream can be accepted).
+
+WWW: https://launchpad.net/testrepository