aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2006-05-01 03:58:53 +0800
committerlbr <lbr@FreeBSD.org>2006-05-01 03:58:53 +0800
commita6f776bc342848351d77a91d46fe043c7e5b5d4c (patch)
treece1f54cc25c61099224d6499ab2e924e934e5a2a /devel
parent75edf8b6801aa4e5ab6fabb054c17e6ab3ed66c2 (diff)
downloadfreebsd-ports-gnome-a6f776bc342848351d77a91d46fe043c7e5b5d4c.tar.gz
freebsd-ports-gnome-a6f776bc342848351d77a91d46fe043c7e5b5d4c.tar.zst
freebsd-ports-gnome-a6f776bc342848351d77a91d46fe043c7e5b5d4c.zip
Add p5-Sub-Exporter, A sophisticated exporter for custom-built routines
Approved by: erwin (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Exporter/Makefile33
-rw-r--r--devel/p5-Sub-Exporter/distinfo3
-rw-r--r--devel/p5-Sub-Exporter/pkg-descr5
-rw-r--r--devel/p5-Sub-Exporter/pkg-plist10
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1d080c16cb79..95f4a02f1511 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1201,6 +1201,7 @@
SUBDIR += p5-String-Random
SUBDIR += p5-String-RexxParse
SUBDIR += p5-String-Similarity
+ SUBDIR += p5-Sub-Exporter
SUBDIR += p5-Sub-Install
SUBDIR += p5-Sub-Installer
SUBDIR += p5-Sub-Name
diff --git a/devel/p5-Sub-Exporter/Makefile b/devel/p5-Sub-Exporter/Makefile
new file mode 100644
index 000000000000..34b2422cdee7
--- /dev/null
+++ b/devel/p5-Sub-Exporter/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: devel/p5-Sub-Exporter
+# Date created: 30 Apr 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Exporter
+PORTVERSION= 0.951
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= A sophisticated exporter for custom-built routines
+
+BUILD_DEPENDS= p5-Sub-Install>=0.91:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::OptList.3 \
+ Sub::Exporter.3 \
+ Sub::Exporter::Tutorial.3 \
+ Sub::Exporter::Util.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Exporter/distinfo b/devel/p5-Sub-Exporter/distinfo
new file mode 100644
index 000000000000..33cfa922f680
--- /dev/null
+++ b/devel/p5-Sub-Exporter/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sub-Exporter-0.951.tar.gz) = 2bb78f636b62a8d5f611d03f0b381629
+SHA256 (Sub-Exporter-0.951.tar.gz) = c9f56b5a0a730bd2d59675c8f521a9d4312686a5ec3db82a5d5cac0e3ae5a6ff
+SIZE (Sub-Exporter-0.951.tar.gz) = 38698
diff --git a/devel/p5-Sub-Exporter/pkg-descr b/devel/p5-Sub-Exporter/pkg-descr
new file mode 100644
index 000000000000..0df5e62f57a8
--- /dev/null
+++ b/devel/p5-Sub-Exporter/pkg-descr
@@ -0,0 +1,5 @@
+The biggest benefit of Sub::Exporter over existing exporters (including the
+ubiquitous Exporter.pm) is its ability to build new coderefs for export, rather
+than to simply export code identical to that found in the exporting package.
+
+WWW: http://search.cpan.org/dist/Sub-Exporter/
diff --git a/devel/p5-Sub-Exporter/pkg-plist b/devel/p5-Sub-Exporter/pkg-plist
new file mode 100644
index 000000000000..9b9c3d6175c8
--- /dev/null
+++ b/devel/p5-Sub-Exporter/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Data/OptList.pm
+%%SITE_PERL%%/Sub/Exporter.pm
+%%SITE_PERL%%/Sub/Exporter/Tutorial.pod
+%%SITE_PERL%%/Sub/Exporter/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub
+@dirrmtry %%SITE_PERL%%/Sub/Exporter
+@dirrmtry %%SITE_PERL%%/Sub
+@dirrmtry %%SITE_PERL%%/Data