aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2004-11-29 02:46:47 +0800
committerkwm <kwm@FreeBSD.org>2004-11-29 02:46:47 +0800
commita7bb1c14d4fb40ce0c7775bc736daa33a9f1facc (patch)
tree0c9a71c25b459bf416f10fec5d170e1a98b3ae6b /devel
parent214d5002f1fcab6075388291a57eea52504ca303 (diff)
downloadfreebsd-ports-gnome-a7bb1c14d4fb40ce0c7775bc736daa33a9f1facc.tar.gz
freebsd-ports-gnome-a7bb1c14d4fb40ce0c7775bc736daa33a9f1facc.tar.zst
freebsd-ports-gnome-a7bb1c14d4fb40ce0c7775bc736daa33a9f1facc.zip
Add liboil a library of simple functions that are optimized for various CPUs.
These functions are generally loops implementing simple algorithmes. Grab maintainer-ship PR: 74361 Submitted by: ijliao Approved by: pav (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/liboil/Makefile28
-rw-r--r--devel/liboil/distinfo2
-rw-r--r--devel/liboil/files/patch-configure18
-rw-r--r--devel/liboil/files/patch-liboil_dct_dct.h13
-rw-r--r--devel/liboil/files/patch-liboil_liboilcpu.c10
-rw-r--r--devel/liboil/pkg-descr13
-rw-r--r--devel/liboil/pkg-plist16
8 files changed, 101 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f17c3b11e586..56677d40c6c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -437,6 +437,7 @@
SUBDIR += libmcve
SUBDIR += libmimedir
SUBDIR += libmtrie
+ SUBDIR += liboil
SUBDIR += libol
SUBDIR += libole2
SUBDIR += liboop
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
new file mode 100644
index 000000000000..5207be706e17
--- /dev/null
+++ b/devel/liboil/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: liboil
+# Date created: Nov 24, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboil
+PORTVERSION= 0.2.2
+CATEGORIES= devel
+MASTER_SITES= http://www.schleef.org/liboil/download/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Library of optimized inner loops
+
+USE_GNOME= gnomeprefix glib20
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+
+PLIST_SUB= VERSION=${PORTVERSION:R}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|g' \
+ ${WRKSRC}/liboil/liboiltypes.h \
+ ${WRKSRC}/liboil/liboil.h
+
+.include <bsd.port.mk>
diff --git a/devel/liboil/distinfo b/devel/liboil/distinfo
new file mode 100644
index 000000000000..5d5d3ccc4f55
--- /dev/null
+++ b/devel/liboil/distinfo
@@ -0,0 +1,2 @@
+MD5 (liboil-0.2.2.tar.gz) = 5eeab2994b45f088c3b36a71ae66fb94
+SIZE (liboil-0.2.2.tar.gz) = 415092
diff --git a/devel/liboil/files/patch-configure b/devel/liboil/files/patch-configure
new file mode 100644
index 000000000000..fa07fe2c728a
--- /dev/null
+++ b/devel/liboil/files/patch-configure
@@ -0,0 +1,18 @@
+--- configure.orig Sun Nov 28 19:14:30 2004
++++ configure Sun Nov 28 19:15:34 2004
+@@ -20691,13 +20691,13 @@
+
+ fi
+
+-LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_GNU_SOURCE -D_POSIX_C_SOURCE=200112L -I\$(top_srcdir)"
++LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_GNU_SOURCE -I\$(top_srcdir)"
+
+
+ LIBOIL_LIBS="\$(top_builddir)/liboil/liboil-$LIBOIL_MAJORMINOR.la"
+
+
+-pkgconfigdir="\$(libdir)/pkgconfig"
++pkgconfigdir="\$(prefix)/libdata/pkgconfig"
+
+
+ ac_config_files="$ac_config_files Makefile liboil/Makefile liboil/copy/Makefile liboil/dct/Makefile liboil/md5/Makefile liboil/jpeg/Makefile liboil/simdpack/Makefile testsuite/Makefile examples/Makefile examples/jpeg/Makefile examples/md5/Makefile liboil.pc"
diff --git a/devel/liboil/files/patch-liboil_dct_dct.h b/devel/liboil/files/patch-liboil_dct_dct.h
new file mode 100644
index 000000000000..50f8946aee47
--- /dev/null
+++ b/devel/liboil/files/patch-liboil_dct_dct.h
@@ -0,0 +1,13 @@
+--- liboil/dct/dct.h.orig Sat Nov 13 11:34:25 2004
++++ liboil/dct/dct.h Sat Nov 13 11:34:55 2004
+@@ -21,6 +21,10 @@
+
+ #include <liboil/liboilfunction.h>
+
++#ifdef __FreeBSD__
++#define M_PI 3.14159265358979323846
++#endif
++
+ OIL_DECLARE_CLASS(dct12_f32);
+ OIL_DECLARE_CLASS(dct36_f32);
+ OIL_DECLARE_CLASS(fdct8_f64);
diff --git a/devel/liboil/files/patch-liboil_liboilcpu.c b/devel/liboil/files/patch-liboil_liboilcpu.c
new file mode 100644
index 000000000000..a7f287bc0fc9
--- /dev/null
+++ b/devel/liboil/files/patch-liboil_liboilcpu.c
@@ -0,0 +1,10 @@
+--- liboil/liboilcpu.c.orig Sun Nov 28 13:15:12 2004
++++ liboil/liboilcpu.c Sun Nov 28 13:15:41 2004
+@@ -64,6 +64,7 @@
+ char **f;
+
+ cpuinfo = get_cpuinfo();
++ if (cpuinfo == NULL) return;
+
+ cpuinfo_flags = get_cpuinfo_flags_string(cpuinfo);
+ if (cpuinfo_flags == NULL) return;
diff --git a/devel/liboil/pkg-descr b/devel/liboil/pkg-descr
new file mode 100644
index 000000000000..bc957e90e9a2
--- /dev/null
+++ b/devel/liboil/pkg-descr
@@ -0,0 +1,13 @@
+Liboil is a library of simple functions that are optimized for various CPUs.
+These functions are generally loops implementing simple algorithms, such as
+converting an array of N integers to floating-point numbers or multiplying
+and summing an array of N numbers. Clearly such functions are candidates for
+significant optimization using various techniques, especially by using
+extended instructions provided by modern CPUs (Altivec, MMX, SSE, etc.).
+
+Many multimedia applications and libraries already do similar things
+internally. The goal of this project is to consolidate some of the code used
+by various multimedia projects, and also make optimizations easier to use by
+a broad range of applications.
+
+WWW: http://www.schleef.org/liboil/
diff --git a/devel/liboil/pkg-plist b/devel/liboil/pkg-plist
new file mode 100644
index 000000000000..1f5e864de3a2
--- /dev/null
+++ b/devel/liboil/pkg-plist
@@ -0,0 +1,16 @@
+include/liboil-%%VERSION%%/liboil/liboil.h
+include/liboil-%%VERSION%%/liboil/liboilcpu.h
+include/liboil-%%VERSION%%/liboil/liboildebug.h
+include/liboil-%%VERSION%%/liboil/liboilfuncs.h
+include/liboil-%%VERSION%%/liboil/liboilfunction.h
+include/liboil-%%VERSION%%/liboil/liboilprototype.h
+include/liboil-%%VERSION%%/liboil/liboiltypes.h
+lib/liboil-%%VERSION%%.a
+lib/liboil-%%VERSION%%.so
+lib/liboil-%%VERSION%%.so.0
+lib/liboiltmp1.a
+lib/liboiltmp1.so
+lib/liboiltmp1.so.0
+libdata/pkgconfig/liboil-%%VERSION%%.pc
+@dirrm include/liboil-%%VERSION%%/liboil
+@dirrm include/liboil-%%VERSION%%