aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2019-09-21 14:05:53 +0800
committerantoine <antoine@FreeBSD.org>2019-09-21 14:05:53 +0800
commita9957d36119cb95677dcea4610ca80f48515d183 (patch)
tree9505ad9a37fe1052265e7bac1f8d2eb307d70ae9 /devel
parent822295dffdff8c5ea121b6b1637d991980f70206 (diff)
downloadfreebsd-ports-gnome-a9957d36119cb95677dcea4610ca80f48515d183.tar.gz
freebsd-ports-gnome-a9957d36119cb95677dcea4610ca80f48515d183.tar.zst
freebsd-ports-gnome-a9957d36119cb95677dcea4610ca80f48515d183.zip
Unbreak py27 FLAVOR
Reported by: pkg-fallout
Diffstat (limited to 'devel')
-rw-r--r--devel/py-virtualenv/Makefile3
-rw-r--r--devel/py-virtualenv/files/patch-docs_conf.py9
2 files changed, 10 insertions, 2 deletions
diff --git a/devel/py-virtualenv/Makefile b/devel/py-virtualenv/Makefile
index 38f0deff4c2c..827bd252e52c 100644
--- a/devel/py-virtualenv/Makefile
+++ b/devel/py-virtualenv/Makefile
@@ -17,6 +17,9 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.1.3:textproc/py-sphinx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}towncrier>0:textproc/py-towncrier@${PY_FLAVOR}
+.if ${FLAVOR:U:Mpy27}
+DOCS_BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pathlib2>0:devel/py-pathlib2@${PY_FLAVOR}
+.endif
DOCS_PORTDOCS= *
DOCS_VARS= PYDISTUTILS_BUILD_TARGET="build build_sphinx"
diff --git a/devel/py-virtualenv/files/patch-docs_conf.py b/devel/py-virtualenv/files/patch-docs_conf.py
index 9f9664a1740f..9ce57124c7bf 100644
--- a/devel/py-virtualenv/files/patch-docs_conf.py
+++ b/devel/py-virtualenv/files/patch-docs_conf.py
@@ -1,9 +1,14 @@
--- docs/conf.py.orig 2019-09-03 16:32:54 UTC
+++ docs/conf.py
-@@ -5,6 +5,7 @@ import re
+@@ -4,7 +4,11 @@ import os
+ import re
import subprocess
import sys
- from pathlib import Path
+-from pathlib import Path
++if sys.version_info[0] == 2:
++ from pathlib2 import Path
++else:
++ from pathlib import Path
+sys.path.insert(0, os.path.abspath('../build/lib'))
from virtualenv import __version__