aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-05-30 04:07:31 +0800
committerthierry <thierry@FreeBSD.org>2004-05-30 04:07:31 +0800
commitaae677e57643c920a012dc4e22a1be238b4dc84b (patch)
treef0d98dde6103dde7f6a82b70e0833586d90db645 /devel
parent6a54b3e6d6f1759c64ee544591a07814f2cc30bb (diff)
downloadfreebsd-ports-gnome-aae677e57643c920a012dc4e22a1be238b4dc84b.tar.gz
freebsd-ports-gnome-aae677e57643c920a012dc4e22a1be238b4dc84b.tar.zst
freebsd-ports-gnome-aae677e57643c920a012dc4e22a1be238b4dc84b.zip
Add pear-HTML_BBCodeParser 1.1, parser to replace UBB style tags
with their HTML equivalents. PR: 67348 Submitted by: Lewis Thompson <purple@lewiz.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_BBCodeParser/Makefile31
-rw-r--r--devel/pear-HTML_BBCodeParser/distinfo2
-rw-r--r--devel/pear-HTML_BBCodeParser/pkg-descr9
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1320b319b785..f8358b5c0fc3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -975,6 +975,7 @@
SUBDIR += pear-Console_Getopt
SUBDIR += pear-Console_Table
SUBDIR += pear-Date
+ SUBDIR += pear-HTML_BBCodeParser
SUBDIR += pear-HTML_Common
SUBDIR += pear-HTML_QuickForm
SUBDIR += pear-HTML_Select_Common
diff --git a/devel/pear-HTML_BBCodeParser/Makefile b/devel/pear-HTML_BBCodeParser/Makefile
new file mode 100644
index 000000000000..827518339ca9
--- /dev/null
+++ b/devel/pear-HTML_BBCodeParser/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pear-HTML_BBCodeParser
+# Date created: 29 May 2004
+# Whom: Lewis Thompson <purple@lewiz.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_BBCodeParser
+PORTVERSION= 1.1
+CATEGORIES= devel www pear
+
+MAINTAINER= purple@lewiz.net
+COMMENT= Parser to replace UBB style tags with their HTML equivalents
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTML
+FILES= BBCodeParser.php \
+ BBCodeParser/Filter/Basic.php \
+ BBCodeParser/Filter/Email.php \
+ BBCodeParser/Filter/Extended.php \
+ BBCodeParser/Filter/Images.php \
+ BBCodeParser/Filter/Links.php \
+ BBCodeParser/Filter/Lists.php
+EXAMPLES= BBCodeParser.ini parser.php
+_EXAMPLESDIR= BBCodeParser/example
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_BBCodeParser/distinfo b/devel/pear-HTML_BBCodeParser/distinfo
new file mode 100644
index 000000000000..213eb8e3a2d6
--- /dev/null
+++ b/devel/pear-HTML_BBCodeParser/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTML_BBCodeParser-1.1.tgz) = 0baca616b569dff6966ff6422b5ecdc4
+SIZE (PEAR/HTML_BBCodeParser-1.1.tgz) = 8821
diff --git a/devel/pear-HTML_BBCodeParser/pkg-descr b/devel/pear-HTML_BBCodeParser/pkg-descr
new file mode 100644
index 000000000000..b18d20f42e97
--- /dev/null
+++ b/devel/pear-HTML_BBCodeParser/pkg-descr
@@ -0,0 +1,9 @@
+This is a parser to replace UBB style tags with their html equivalents.
+It does not simply do some regex calls, but is complete stack based
+parse engine. This ensures that all tags are properly nested, if not,
+extra tags are added to maintain the nesting. This parser should only
+produce xhtml 1.0 compliant code. All tags are validated and so are all
+their attributes. It should be easy to extend this parser with your own
+tags.
+
+WWW: http://pear.php.net/package/HTML_BBCodeParser/