aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-03-10 07:38:36 +0800
committercpm <cpm@FreeBSD.org>2017-03-10 07:38:36 +0800
commitab156d4ef14a6176cbc2704723b2c8dd3a84e877 (patch)
tree89690c2237e07520b8101ee8b857351c05243f48 /devel
parent619349586acb9f6203b56c98bbe2a94d0f03bb5a (diff)
downloadfreebsd-ports-gnome-ab156d4ef14a6176cbc2704723b2c8dd3a84e877.tar.gz
freebsd-ports-gnome-ab156d4ef14a6176cbc2704723b2c8dd3a84e877.tar.zst
freebsd-ports-gnome-ab156d4ef14a6176cbc2704723b2c8dd3a84e877.zip
Add new port devel/py-stackexchange
Py-StackExchange is a simple Python binding for the StackExchange API. Py-StackExchange API coverage: - Access any StackExchange site, with just its URL. Even those that aren't online yet. - If you just can't decide which one to use, you can use StackAuth to look up the full list of sites. - Once you're online, you can view everything about users, questions, answers, badges, comments and tags. - You can even go back in time by playing with post revisions. - Help users by looking up every StackExchange account they have. Every single one. - See how well an SE site is doing; check its site statistics. - Search the questions of StackExchange sites. WWW: https://github.com/lucjon/Py-StackExchange
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-stackexchange/Makefile24
-rw-r--r--devel/py-stackexchange/distinfo3
-rw-r--r--devel/py-stackexchange/pkg-descr16
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d63138ff5692..d750a3bcc41a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4701,6 +4701,7 @@
SUBDIR += py-speaklater
SUBDIR += py-spyder
SUBDIR += py-sqlcc
+ SUBDIR += py-stackexchange
SUBDIR += py-statgrab
SUBDIR += py-statsd
SUBDIR += py-stdnum
diff --git a/devel/py-stackexchange/Makefile b/devel/py-stackexchange/Makefile
new file mode 100644
index 000000000000..f65bdd83f78d
--- /dev/null
+++ b/devel/py-stackexchange/Makefile
@@ -0,0 +1,24 @@
+# Created by: Carlos J. Puga Medina <cpm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= stackexchange
+PORTVERSION= 2.2.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= cpm@FreeBSD.org
+COMMENT= Python binding to the StackExchange website APIs
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.8.0:devel/py-six
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-stackexchange/distinfo b/devel/py-stackexchange/distinfo
new file mode 100644
index 000000000000..b34e885ddef4
--- /dev/null
+++ b/devel/py-stackexchange/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488762464
+SHA256 (py-stackexchange-2.2.6.tar.gz) = deadc9b8f916f1273ae12f12623e036fa4d3342e4ec585e62ce167b9ddb797fb
+SIZE (py-stackexchange-2.2.6.tar.gz) = 27257
diff --git a/devel/py-stackexchange/pkg-descr b/devel/py-stackexchange/pkg-descr
new file mode 100644
index 000000000000..f8e657e3ac04
--- /dev/null
+++ b/devel/py-stackexchange/pkg-descr
@@ -0,0 +1,16 @@
+Py-StackExchange is a simple Python binding for the StackExchange API.
+
+Py-StackExchange API coverage:
+- Access any StackExchange site, with just its URL. Even those that aren't
+ online yet.
+- If you just can't decide which one to use, you can use StackAuth to look up
+ the full list of sites.
+- Once you're online, you can view everything about users, questions, answers,
+ badges, comments and tags.
+- You can even go back in time by playing with post revisions.
+- Help users by looking up every StackExchange account they have. Every single
+ one.
+- See how well an SE site is doing; check its site statistics.
+- Search the questions of StackExchange sites.
+
+WWW: https://github.com/lucjon/Py-StackExchange