aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-10-05 04:44:42 +0800
committerantoine <antoine@FreeBSD.org>2013-10-05 04:44:42 +0800
commitabd99f10c21f95ed72a1e34fe69d1461aa5c0f3e (patch)
tree11a935b985f34241cdbf06f23c5de80bbd4d35c1 /devel
parent715fafb57e43ea5f78f64fe339dc7f9be711bc32 (diff)
downloadfreebsd-ports-gnome-abd99f10c21f95ed72a1e34fe69d1461aa5c0f3e.tar.gz
freebsd-ports-gnome-abd99f10c21f95ed72a1e34fe69d1461aa5c0f3e.tar.zst
freebsd-ports-gnome-abd99f10c21f95ed72a1e34fe69d1461aa5c0f3e.zip
Convert to STAGEDIR
Diffstat (limited to 'devel')
-rw-r--r--devel/libdasm/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/devel/libdasm/Makefile b/devel/libdasm/Makefile
index 7e4d59011362..269aba5cb469 100644
--- a/devel/libdasm/Makefile
+++ b/devel/libdasm/Makefile
@@ -12,14 +12,14 @@ COMMENT= Simple x86 disassembly library
LICENSE= BSD
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${STAGEDIR}${PREFIX}"
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS EXAMPLES
-
PORTDOCS= HISTORY.txt README.txt
PORTEXAMPLES= README.txt das.c simple.c
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
@@ -27,19 +27,19 @@ CFLAGS+= -fPIC -DPIC
.endif
post-patch:
- @${REINPLACE_CMD} -E 's,^(CC|CFLAGS|PREFIX).*=,\1 ?=,; \
- s,libdasm.so.1.0,libdasm.so.1,g; \
- s,cp ,${INSTALL_DATA} ,g' \
- ${WRKSRC}/Makefile ${WRKSRC}/examples/Makefile
+ @${REINPLACE_CMD} 's,libdasm.so.1.0,libdasm.so.1,g; \
+ s,cp ,${INSTALL_DATA} ,g; \
+ /cd examples/d' \
+ ${WRKSRC}/Makefile
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/examples/,} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/examples/,} ${STAGEDIR}${EXAMPLESDIR}
.endif
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>