aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-02-04 20:20:42 +0800
committerantoine <antoine@FreeBSD.org>2018-02-04 20:20:42 +0800
commitacd5e4b6e5044ef1cf62526523e00d787538dbbc (patch)
tree415ce5f65abd4358a923f4d169bdc66f62dc3dda /devel
parentf55e7fb212a65be4b0ae512663f188bf92cba5f1 (diff)
downloadfreebsd-ports-gnome-acd5e4b6e5044ef1cf62526523e00d787538dbbc.tar.gz
freebsd-ports-gnome-acd5e4b6e5044ef1cf62526523e00d787538dbbc.tar.zst
freebsd-ports-gnome-acd5e4b6e5044ef1cf62526523e00d787538dbbc.zip
New port: devel/py-expiringdict
expiringdict is a Python caching library. The core of the library is ExpiringDict class which is an ordered dictionary with auto-expiring values for caching purposes. Expiration happens on any access, object is locked during cleanup from expired values. ExpiringDict can not store more than max_len elements - the oldest will be deleted. WWW: https://github.com/mailgun/expiringdict
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-expiringdict/Makefile19
-rw-r--r--devel/py-expiringdict/distinfo3
-rw-r--r--devel/py-expiringdict/pkg-descr7
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e8a5e51c50ab..f123d7228d29 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4418,6 +4418,7 @@
SUBDIR += py-evdev
SUBDIR += py-eventlib
SUBDIR += py-exam
+ SUBDIR += py-expiringdict
SUBDIR += py-extras
SUBDIR += py-extremes
SUBDIR += py-ezpyinline
diff --git a/devel/py-expiringdict/Makefile b/devel/py-expiringdict/Makefile
new file mode 100644
index 000000000000..b0fa208a97de
--- /dev/null
+++ b/devel/py-expiringdict/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= expiringdict
+PORTVERSION= 1.1.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Dictionary with auto-expiring values for caching purposes
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-expiringdict/distinfo b/devel/py-expiringdict/distinfo
new file mode 100644
index 000000000000..ee4f103b4ab4
--- /dev/null
+++ b/devel/py-expiringdict/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509629327
+SHA256 (expiringdict-1.1.4.tar.gz) = 9275c3f3aa6cabe394355b6454100eb1cdfe395c6b592c26603a2a0f9e3a0587
+SIZE (expiringdict-1.1.4.tar.gz) = 6900
diff --git a/devel/py-expiringdict/pkg-descr b/devel/py-expiringdict/pkg-descr
new file mode 100644
index 000000000000..d62fe94d727c
--- /dev/null
+++ b/devel/py-expiringdict/pkg-descr
@@ -0,0 +1,7 @@
+expiringdict is a Python caching library. The core of the library is
+ExpiringDict class which is an ordered dictionary with auto-expiring values for
+caching purposes. Expiration happens on any access, object is locked during
+cleanup from expired values. ExpiringDict can not store more than max_len
+elements - the oldest will be deleted.
+
+WWW: https://github.com/mailgun/expiringdict