aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-28 06:42:25 +0800
committerkrion <krion@FreeBSD.org>2004-02-28 06:42:25 +0800
commitad71cf8a242f497ee1d4a4301d91301f581e7589 (patch)
treec5087e495cbb4a4b672baff6a0aa56d532979165 /devel
parentd626939d1a0efd54d8cb347be1e924358246822b (diff)
downloadfreebsd-ports-gnome-ad71cf8a242f497ee1d4a4301d91301f581e7589.tar.gz
freebsd-ports-gnome-ad71cf8a242f497ee1d4a4301d91301f581e7589.tar.zst
freebsd-ports-gnome-ad71cf8a242f497ee1d4a4301d91301f581e7589.zip
- Update to version 0.18
PR: ports/63450 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/libowfat/Makefile12
-rw-r--r--devel/libowfat/distinfo4
-rw-r--r--devel/libowfat/files/patch-io_iob_prefetch.c9
3 files changed, 11 insertions, 14 deletions
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index bf4ec8ab6208..bcf282a09c91 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libowfat
-PORTVERSION= 0.17
+PORTVERSION= 0.18
CATEGORIES= devel
MASTER_SITES= http://dl.fefe.de/
@@ -29,9 +29,13 @@ CFLAGS+= -O2 -fomit-frame-pointer
.include "${FILESDIR}/manpages"
-PLIST_FILES= lib/libowfat.a
+examples= test/client.c test/dllink.c test/httpd.c test/readhttp.c \
+ test/server.c test/uudecode.c test/vd.c
+examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
+PLIST_DIRS= ${examplesdir}
+PLIST_FILES= lib/libowfat.a ${examples:S,^test/,${examplesdir}/,}
.if!defined(NOPORTDOCS)
-PORTDOCS= README
+PORTDOCS= CHANGES README TODO
.endif
post-install:
@@ -39,6 +43,8 @@ post-install:
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${examples} ${EXAMPLESDIR}
# add installed header files to packaging list:
@cd ${PREFIX} && \
${FIND} include/libowfat -type f -o -type l | ${SORT} >>${TMPPLIST}
diff --git a/devel/libowfat/distinfo b/devel/libowfat/distinfo
index b4aa298342ac..a06c847ffc7d 100644
--- a/devel/libowfat/distinfo
+++ b/devel/libowfat/distinfo
@@ -1,2 +1,2 @@
-MD5 (libowfat-0.17.tar.bz2) = a8da3ebe361004b0dbec26d330e1c155
-SIZE (libowfat-0.17.tar.bz2) = 121919
+MD5 (libowfat-0.18.tar.bz2) = 112dcc80db665f6c43e7961343cd84e1
+SIZE (libowfat-0.18.tar.bz2) = 96786
diff --git a/devel/libowfat/files/patch-io_iob_prefetch.c b/devel/libowfat/files/patch-io_iob_prefetch.c
deleted file mode 100644
index e8ee5456d315..000000000000
--- a/devel/libowfat/files/patch-io_iob_prefetch.c
+++ /dev/null
@@ -1,9 +0,0 @@
---- io/iob_prefetch.c.orig Sat Feb 21 17:56:29 2004
-+++ io/iob_prefetch.c Sat Feb 21 17:56:49 2004
-@@ -1,5 +1,6 @@
- #include "iob_internal.h"
- #include <stdio.h>
-+#include <sys/types.h>
- #include <sys/mman.h>
-
- void iob_prefetch(io_batch* b,uint64 bytes) {