aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2014-08-02 19:47:11 +0800
committerolivierd <olivierd@FreeBSD.org>2014-08-02 19:47:11 +0800
commitb0d8f747e3d8cb884fe90c6c5374d9de51cf0086 (patch)
tree14898eaeb4393576255693f599c18d1d829f36a7 /devel
parentaff0c6d2f97358cd6ad0844b9f452db9936df23a (diff)
downloadfreebsd-ports-gnome-b0d8f747e3d8cb884fe90c6c5374d9de51cf0086.tar.gz
freebsd-ports-gnome-b0d8f747e3d8cb884fe90c6c5374d9de51cf0086.tar.zst
freebsd-ports-gnome-b0d8f747e3d8cb884fe90c6c5374d9de51cf0086.zip
- Update to 3.1
ChangeLog: http://mercurial.selenic.com/wiki/WhatsNew#Mercurial_3.1_.282014-08-01.29
Diffstat (limited to 'devel')
-rw-r--r--devel/mercurial/Makefile2
-rw-r--r--devel/mercurial/distinfo4
-rw-r--r--devel/mercurial/files/extra-patch-authormapsuffix140
-rw-r--r--devel/mercurial/pkg-plist3
4 files changed, 11 insertions, 138 deletions
diff --git a/devel/mercurial/Makefile b/devel/mercurial/Makefile
index e23838d8dfef..3b00d8d0afdf 100644
--- a/devel/mercurial/Makefile
+++ b/devel/mercurial/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mercurial
-PORTVERSION= 3.0.2
+PORTVERSION= 3.1
CATEGORIES= devel python
MASTER_SITES= http://mercurial.selenic.com/release/
diff --git a/devel/mercurial/distinfo b/devel/mercurial/distinfo
index 5c938a6eed09..edcb8b135fcc 100644
--- a/devel/mercurial/distinfo
+++ b/devel/mercurial/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mercurial-3.0.2.tar.gz) = ed387cc0e9754ec59bd4a390639b5a4ea11698ae4413243f8b4a2d6d48b3b7d6
-SIZE (mercurial-3.0.2.tar.gz) = 3907502
+SHA256 (mercurial-3.1.tar.gz) = f1ddc279ac2f69f012f38a7a4f1e75dc8f2a8cf97b6029b0bef418a4666fd0e4
+SIZE (mercurial-3.1.tar.gz) = 3963443
diff --git a/devel/mercurial/files/extra-patch-authormapsuffix b/devel/mercurial/files/extra-patch-authormapsuffix
index 7d2a5cbb25aa..b06983e96469 100644
--- a/devel/mercurial/files/extra-patch-authormapsuffix
+++ b/devel/mercurial/files/extra-patch-authormapsuffix
@@ -1,26 +1,5 @@
---- hgext/convert/__init__.py.orig 2014-06-01 17:15:14.000000000 -0400
-+++ hgext/convert/__init__.py 2014-06-22 16:11:35.609199105 -0400
-@@ -85,6 +85,9 @@
-
- Empty lines and lines starting with a ``#`` are ignored.
-
-+ The authormapsuffix can be used to append set text to each
-+ post-authormap-translated author name.
-+
- The filemap is a file that allows filtering and remapping of files
- and directories. Each line can contain one of the following
- directives::
-@@ -314,6 +317,8 @@
- _('import up to source revision REV'), _('REV')),
- ('A', 'authormap', '',
- _('remap usernames using this file'), _('FILE')),
-+ ('', 'authormapsuffix', '',
-+ _('append this suffix to remapped author names'), _('SUFFIX')),
- ('', 'filemap', '',
- _('remap file names using contents of file'), _('FILE')),
- ('', 'splicemap', '',
---- hgext/convert/convcmd.py.orig 2014-06-01 17:15:14.000000000 -0400
-+++ hgext/convert/convcmd.py 2014-06-22 16:11:35.610199033 -0400
+--- ./hgext/convert/convcmd.py.orig 2014-08-01 23:22:55.000000000 +0000
++++ ./hgext/convert/convcmd.py 2014-08-02 06:58:26.000000000 +0000
@@ -103,12 +103,15 @@
self.commitcache = {}
self.authors = {}
@@ -37,7 +16,7 @@
# Read first the dst author map if any
authorfile = self.dest.authorfile()
if authorfile and os.path.exists(authorfile):
-@@ -356,7 +359,7 @@
+@@ -360,7 +363,7 @@
continue
srcauthor = srcauthor.strip()
@@ -46,121 +25,12 @@
if self.authors.get(srcauthor) in (None, dstauthor):
msg = _('mapping author %s to %s\n')
self.ui.debug(msg % (srcauthor, dstauthor))
-@@ -370,7 +373,8 @@
+@@ -374,7 +377,7 @@
def cachecommit(self, rev):
commit = self.source.getcommit(rev)
- commit.author = self.authors.get(commit.author, commit.author)
-+ commit.author = self.authors.get(commit.author,
-+ commit.author + self.authormapsuffix)
++ commit.author = self.authors.get(commit.author, commit.author + self.authormapsuffix)
# If commit.branch is None, this commit is coming from the source
# repository's default branch and destined for the default branch in the
# destination repository. For such commits, passing a literal "None"
---- tests/test-convert-authormap.t.orig 2014-06-01 17:15:14.000000000 -0400
-+++ tests/test-convert-authormap.t 2014-06-22 16:11:35.610199033 -0400
-@@ -10,6 +10,8 @@
- $ cd orig
- $ echo foo > foo
- $ HGUSER='user name' hg ci -qAm 'foo'
-+ $ echo bar > bar
-+ $ HGUSER='user name 2' hg ci -qAm 'bar'
- $ cd ..
-
- Explicit --authors
-@@ -26,13 +28,19 @@
- scanning source...
- sorting...
- converting...
-- 0 foo
-+ 1 foo
-+ 0 bar
- writing author map file $TESTTMP/new/.hg/authormap (glob)
- $ cat new/.hg/authormap
- user name=Long User Name
- $ hg -Rnew log
-- changeset: 0:d89716e88087
-+ changeset: 1:263e7765e4b7
- tag: tip
-+ user: user name 2
-+ date: Thu Jan 01 00:00:00 1970 +0000
-+ summary: bar
-+
-+ changeset: 0:d89716e88087
- user: Long User Name
- date: Thu Jan 01 00:00:00 1970 +0000
- summary: foo
-@@ -48,11 +56,72 @@
- scanning source...
- sorting...
- converting...
-- 0 foo
-+ 1 foo
-+ 0 bar
- $ hg -Rnew log
-- changeset: 0:d89716e88087
-+ changeset: 1:263e7765e4b7
- tag: tip
-+ user: user name 2
-+ date: Thu Jan 01 00:00:00 1970 +0000
-+ summary: bar
-+
-+ changeset: 0:d89716e88087
- user: Long User Name
- date: Thu Jan 01 00:00:00 1970 +0000
- summary: foo
-
-+ $ rm -rf new
-+
-+Use authormapsuffix together with authormap
-+
-+ $ cat > authormap.txt <<EOF
-+ > user name = username
-+ > user name 2 = username2
-+ > EOF
-+ $ hg convert --authormap authormap.txt --authormapsuffix '@test.org' orig new
-+ initializing destination new repository
-+ scanning source...
-+ sorting...
-+ converting...
-+ 1 foo
-+ 0 bar
-+ writing author map file $TESTTMP/new/.hg/authormap
-+ $ cat new/.hg/authormap
-+ user name 2=username2@test.org
-+ user name=username@test.org
-+ $ hg -Rnew log
-+ changeset: 1:aeeaab422b32
-+ tag: tip
-+ user: username2@test.org
-+ date: Thu Jan 01 00:00:00 1970 +0000
-+ summary: bar
-+
-+ changeset: 0:51317d63da9e
-+ user: username@test.org
-+ date: Thu Jan 01 00:00:00 1970 +0000
-+ summary: foo
-+
-+ $ rm -rf new
-+
-+Use authormapsuffix stand alone
-+
-+ $ hg convert --authormapsuffix '@test.org' orig new
-+ initializing destination new repository
-+ scanning source...
-+ sorting...
-+ converting...
-+ 1 foo
-+ 0 bar
-+ $ hg -Rnew log
-+ changeset: 1:94e0dcfe3b0d
-+ tag: tip
-+ user: user name 2@test.org
-+ date: Thu Jan 01 00:00:00 1970 +0000
-+ summary: bar
-+
-+ changeset: 0:e2ff155c86b8
-+ user: user name@test.org
-+ date: Thu Jan 01 00:00:00 1970 +0000
-+ summary: foo
-+
-+
diff --git a/devel/mercurial/pkg-plist b/devel/mercurial/pkg-plist
index 972ead13a5d9..602724423858 100644
--- a/devel/mercurial/pkg-plist
+++ b/devel/mercurial/pkg-plist
@@ -510,6 +510,9 @@ bin/hg
%%PYTHON_SITELIBDIR%%/mercurial/subrepo.py
%%PYTHON_SITELIBDIR%%/mercurial/subrepo.pyc
%%PYTHON_SITELIBDIR%%/mercurial/subrepo.pyo
+%%PYTHON_SITELIBDIR%%/mercurial/tagmerge.py
+%%PYTHON_SITELIBDIR%%/mercurial/tagmerge.pyc
+%%PYTHON_SITELIBDIR%%/mercurial/tagmerge.pyo
%%PYTHON_SITELIBDIR%%/mercurial/tags.py
%%PYTHON_SITELIBDIR%%/mercurial/tags.pyc
%%PYTHON_SITELIBDIR%%/mercurial/tags.pyo