aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2016-04-17 20:28:10 +0800
committerdemon <demon@FreeBSD.org>2016-04-17 20:28:10 +0800
commitb1d557c0172f52a68ed9c2d2017057444e1b1971 (patch)
tree16ee075dbd73cb31d6f58d3412999bbdfe5edd4e /devel
parentb2b6f26ceb33435973563b97100f2254e8bbedad (diff)
downloadfreebsd-ports-gnome-b1d557c0172f52a68ed9c2d2017057444e1b1971.tar.gz
freebsd-ports-gnome-b1d557c0172f52a68ed9c2d2017057444e1b1971.tar.zst
freebsd-ports-gnome-b1d557c0172f52a68ed9c2d2017057444e1b1971.zip
Allow to build hadoop stack with java-1.8, there are several reports
it is working fine.
Diffstat (limited to 'devel')
-rw-r--r--devel/hadoop2/Makefile2
-rw-r--r--devel/spark/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/devel/hadoop2/Makefile b/devel/hadoop2/Makefile
index d5fb645501e0..4fd330f7fff4 100644
--- a/devel/hadoop2/Makefile
+++ b/devel/hadoop2/Makefile
@@ -37,7 +37,7 @@ CONFLICTS_INSTALL= hadoop-1*
USES= cpe shebangfix
CPE_VENDOR= apache
USE_JAVA= yes
-JAVA_VERSION= 1.7
+JAVA_VERSION= 1.7+
USE_LDCONFIG= yes
SHEBANG_FILES= hadoop-hdfs-project/hadoop-hdfs-httpfs/src/main/sbin/httpfs.sh hadoop-hdfs-project/hadoop-hdfs-httpfs/src/main/libexec/httpfs-config.sh hadoop-hdfs-project/hadoop-hdfs-httpfs/src/main/conf/httpfs-env.sh hadoop-common-project/hadoop-kms/src/main/sbin/kms.sh hadoop-common-project/hadoop-kms/src/main/libexec/kms-config.sh hadoop-common-project/hadoop-kms/src/main/conf/kms-env.sh hadoop-tools/hadoop-sls/src/main/bin/rumen2sls.sh hadoop-tools/hadoop-sls/src/main/bin/slsrun.sh
MAKE_ENV+= JAVA_HOME=${JAVA_HOME} HADOOP_PROTOC_PATH=${LOCALBASE}/protobuf25/bin/protoc
diff --git a/devel/spark/Makefile b/devel/spark/Makefile
index becac873daa0..1ab909df3c82 100644
--- a/devel/spark/Makefile
+++ b/devel/spark/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= bash:shells/bash \
USES= python:2
USE_JAVA= yes
-JAVA_VERSION= 1.7
+JAVA_VERSION= 1.7+
MAKE_ENV+= JAVA_HOME=${JAVA_HOME} MAVEN_OPTS="-Xmx2g -XX:MaxPermSize=512M -XX:ReservedCodeCacheSize=512m"
USERS= spark