aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-09-10 01:26:41 +0800
committeryuri <yuri@FreeBSD.org>2018-09-10 01:26:41 +0800
commitb1da56afd69517f0fbaac9f59d6ef518f7b46e7e (patch)
treede04160eebdc72811cbd7a86160eea5107b9051d /devel
parent368ea77e78968d926328648f7c195bc7cd43b2e6 (diff)
downloadfreebsd-ports-gnome-b1da56afd69517f0fbaac9f59d6ef518f7b46e7e.tar.gz
freebsd-ports-gnome-b1da56afd69517f0fbaac9f59d6ef518f7b46e7e.tar.zst
freebsd-ports-gnome-b1da56afd69517f0fbaac9f59d6ef518f7b46e7e.zip
New port: devel/py-pytest-flakes: Pytest plugin for efficiently checking python source with pyflakes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-flakes/Makefile21
-rw-r--r--devel/py-pytest-flakes/distinfo3
-rw-r--r--devel/py-pytest-flakes/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e8138f4bed14..5b721ae3418c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4931,6 +4931,7 @@
SUBDIR += py-pytest-cov
SUBDIR += py-pytest-django
SUBDIR += py-pytest-flake8
+ SUBDIR += py-pytest-flakes
SUBDIR += py-pytest-localserver
SUBDIR += py-pytest-mock
SUBDIR += py-pytest-runner
diff --git a/devel/py-pytest-flakes/Makefile b/devel/py-pytest-flakes/Makefile
new file mode 100644
index 000000000000..e2093c6f9fd7
--- /dev/null
+++ b/devel/py-pytest-flakes/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pytest-flakes
+PORTVERSION= 4.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pytest plugin for efficiently checking python source with pyflakes
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-flakes/distinfo b/devel/py-pytest-flakes/distinfo
new file mode 100644
index 000000000000..5d31e435efa7
--- /dev/null
+++ b/devel/py-pytest-flakes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536513507
+SHA256 (pytest-flakes-4.0.0.tar.gz) = 341964bf5760ebbdde9619f68a17d5632c674c3f6903ef66daa0a4f540b3d143
+SIZE (pytest-flakes-4.0.0.tar.gz) = 7138
diff --git a/devel/py-pytest-flakes/pkg-descr b/devel/py-pytest-flakes/pkg-descr
new file mode 100644
index 000000000000..49fc3104ee41
--- /dev/null
+++ b/devel/py-pytest-flakes/pkg-descr
@@ -0,0 +1,3 @@
+pytest plugin to check source code with pyflakes.
+
+WWW: https://github.com/fschulze/pytest-flakes