aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-09-03 17:13:07 +0800
committerrakuco <rakuco@FreeBSD.org>2015-09-03 17:13:07 +0800
commitb1ffd4a32afc12ab7a5f34aacade091f6b4d1482 (patch)
treec0214fb43b85e48e66d83d9bfa8680c770d4e41c /devel
parent1735281608a817977d25eb1b57503201dabc1f9d (diff)
downloadfreebsd-ports-gnome-b1ffd4a32afc12ab7a5f34aacade091f6b4d1482.tar.gz
freebsd-ports-gnome-b1ffd4a32afc12ab7a5f34aacade091f6b4d1482.tar.zst
freebsd-ports-gnome-b1ffd4a32afc12ab7a5f34aacade091f6b4d1482.zip
Update Qt Creator to 3.5.0.
This has been in our experimental area51 repository for a while, and there is no reason to hold it back. Release notes: https://blog.qt.io/blog/2015/08/20/qt-creator-3-5-0-released/ https://blog.qt.io/blog/2015/07/01/qt-creator-3-4-2-released/ https://blog.qt.io/blog/2015/06/02/qt-creator-3-4-1-released/ Thanks to Alonso Schaich (alonso@), Tobias Berner (tcberner@gmail.com) and Ralf Nolden (nolden@kde.org) for their porting work!
Diffstat (limited to 'devel')
-rw-r--r--devel/qtcreator/Makefile10
-rw-r--r--devel/qtcreator/distinfo4
-rw-r--r--devel/qtcreator/pkg-plist275
3 files changed, 103 insertions, 186 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 88ae8872f428..2b87eb3c387d 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qtcreator
-DISTVERSION= 3.4.0
+DISTVERSION= 3.5.0
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
@@ -12,7 +12,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= C++ and QML IDE for Qt development
USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}
-USES= qmake:outsource compiler:c++11-lib shebangfix
+USES= qmake:outsource compiler:c++11-lib
USE_QT5= buildtools concurrent core declarative designer gui linguist network\
qml quick quickcontrols script script sql svg webkit widgets xml\
xmlpatterns
@@ -27,15 +27,13 @@ QMAKE_ARGS+= DEFINES+=_GLIBCXX_USE_C99
DESKTOP_ENTRIES="Qt Creator" "" "QtProject-qtcreator" \
"${PREFIX}/bin/${PORTNAME}" "Development;Qt;" true
-# There seems to be only one file needing a shebangfix (all the others
-# do not get installed).
-SHEBANG_FILES= share/qtcreator/templates/wizards/scriptgeneratedproject/generate.pl
-
# Fix paths for gnuplot and ant.
post-patch:
${REINPLACE_CMD} -e 's|/usr/bin/gnuplot|${LOCALBASE}/bin/gnuplot|' \
${WRKSRC}/share/qtcreator/debugger/dumper.py
${REINPLACE_CMD} -e 's|/usr/bin/ant|${LOCALBASE}/bin/ant|' \
${WRKSRC}/src/plugins/android/androidsettingswidget.cpp
+ ${REINPLACE_CMD} -e '/unix:LIBS += -ldl/d' \
+ ${WRKSRC}/src/libs/sqlite/sqlite-lib.pri
.include <bsd.port.mk>
diff --git a/devel/qtcreator/distinfo b/devel/qtcreator/distinfo
index ea6fbc3210c1..58facdac581d 100644
--- a/devel/qtcreator/distinfo
+++ b/devel/qtcreator/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/qt-creator-opensource-src-3.4.0.tar.gz) = b80baf5be9b0421b3d951a8a0eb411a65cf008f4c753f5a80d205e90fa4fe112
-SIZE (KDE/qt-creator-opensource-src-3.4.0.tar.gz) = 23199469
+SHA256 (KDE/qt-creator-opensource-src-3.5.0.tar.gz) = 5dc35f81b50d65243a6ae046125061051d03c3d50937a37e29e0669384bb0eb6
+SIZE (KDE/qt-creator-opensource-src-3.5.0.tar.gz) = 22583597
diff --git a/devel/qtcreator/pkg-plist b/devel/qtcreator/pkg-plist
index 659571c5a99c..0177197dd34f 100644
--- a/devel/qtcreator/pkg-plist
+++ b/devel/qtcreator/pkg-plist
@@ -1,4 +1,5 @@
bin/buildoutputparser
+bin/cpaster
bin/qbs
bin/qbs-config
bin/qbs-config-ui
@@ -7,7 +8,6 @@ bin/qbs-setup-android
bin/qbs-setup-qt
bin/qbs-setup-toolchains
bin/qml2puppet
-bin/qmlpuppet
bin/qtcreator
bin/qtcreator.sh
bin/qtcreator_process_stub
@@ -21,6 +21,10 @@ lib/qtcreator/libCPlusPlus.so
lib/qtcreator/libCPlusPlus.so.1
lib/qtcreator/libCPlusPlus.so.1.0
lib/qtcreator/libCPlusPlus.so.1.0.0
+lib/qtcreator/libClangbackendipc.so
+lib/qtcreator/libClangbackendipc.so.1
+lib/qtcreator/libClangbackendipc.so.1.0
+lib/qtcreator/libClangbackendipc.so.1.0.0
lib/qtcreator/libExtensionSystem.so
lib/qtcreator/libExtensionSystem.so.1
lib/qtcreator/libExtensionSystem.so.1.0
@@ -49,6 +53,10 @@ lib/qtcreator/libQtcSsh.so
lib/qtcreator/libQtcSsh.so.1
lib/qtcreator/libQtcSsh.so.1.0
lib/qtcreator/libQtcSsh.so.1.0.0
+lib/qtcreator/libSqlite.so
+lib/qtcreator/libSqlite.so.1
+lib/qtcreator/libSqlite.so.1.0
+lib/qtcreator/libSqlite.so.1.0.0
lib/qtcreator/libTimeline.so
lib/qtcreator/libTimeline.so.1
lib/qtcreator/libTimeline.so.1.0
@@ -60,11 +68,11 @@ lib/qtcreator/libUtils.so.1.0.0
lib/qtcreator/libqbscore.so
lib/qtcreator/libqbscore.so.1
lib/qtcreator/libqbscore.so.1.4
-lib/qtcreator/libqbscore.so.1.4.0
+lib/qtcreator/libqbscore.so.1.4.2
lib/qtcreator/libqbsqtprofilesetup.so
lib/qtcreator/libqbsqtprofilesetup.so.1
lib/qtcreator/libqbsqtprofilesetup.so.1.4
-lib/qtcreator/libqbsqtprofilesetup.so.1.4.0
+lib/qtcreator/libqbsqtprofilesetup.so.1.4.2
lib/qtcreator/plugins/libAnalyzerBase.so
lib/qtcreator/plugins/libAndroid.so
lib/qtcreator/plugins/libAutotoolsProjectManager.so
@@ -114,6 +122,7 @@ lib/qtcreator/plugins/libSubversion.so
lib/qtcreator/plugins/libTaskList.so
lib/qtcreator/plugins/libTextEditor.so
lib/qtcreator/plugins/libTodo.so
+lib/qtcreator/plugins/libUpdateInfo.so
lib/qtcreator/plugins/libValgrind.so
lib/qtcreator/plugins/libVcsBase.so
lib/qtcreator/plugins/libWelcome.so
@@ -130,18 +139,19 @@ share/icons/hicolor/32x32/apps/QtProject-qtcreator.png
share/icons/hicolor/48x48/apps/QtProject-qtcreator.png
share/icons/hicolor/512x512/apps/QtProject-qtcreator.png
share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
-share/qtcreator/cplusplus/qt5-qobjectdefs-injected.h
+share/qtcreator/cplusplus/wrappedQtHeaders/QtCore/qobjectdefs.h
share/qtcreator/debugger/LGPL_EXCEPTION.TXT
share/qtcreator/debugger/LICENSE.LGPL
share/qtcreator/debugger/README.txt
share/qtcreator/debugger/boosttypes.py
share/qtcreator/debugger/creatortypes.py
share/qtcreator/debugger/dumper.py
+share/qtcreator/debugger/dumper.py.bak
share/qtcreator/debugger/gdbbridge.py
share/qtcreator/debugger/lldbbridge.py
share/qtcreator/debugger/misctypes.py
-share/qtcreator/debugger/personaltypes.py
share/qtcreator/debugger/pdbbridge.py
+share/qtcreator/debugger/personaltypes.py
share/qtcreator/debugger/qttypes.py
share/qtcreator/debugger/stdtypes.py
share/qtcreator/designer/templates.xml
@@ -183,8 +193,8 @@ share/qtcreator/qbs/share/qbs/examples/app-and-lib/app/app.qbs
share/qtcreator/qbs/share/qbs/examples/app-and-lib/app/main.cpp
share/qtcreator/qbs/share/qbs/examples/app-and-lib/app_and_lib.qbs
share/qtcreator/qbs/share/qbs/examples/app-and-lib/lib/lib.cpp
-share/qtcreator/qbs/share/qbs/examples/app-and-lib/lib/lib.qbs
share/qtcreator/qbs/share/qbs/examples/app-and-lib/lib/lib.h
+share/qtcreator/qbs/share/qbs/examples/app-and-lib/lib/lib.qbs
share/qtcreator/qbs/share/qbs/examples/cocoa-application/CocoaApplication.qbs
share/qtcreator/qbs/share/qbs/examples/cocoa-application/CocoaApplication.xcodeproj/project.pbxproj
share/qtcreator/qbs/share/qbs/examples/cocoa-application/CocoaApplication/AppDelegate.h
@@ -233,16 +243,25 @@ share/qtcreator/qbs/share/qbs/examples/helloworld-minimal/hello.qbs
share/qtcreator/qbs/share/qbs/examples/helloworld-minimal/main.cpp
share/qtcreator/qbs/share/qbs/examples/helloworld-qt/hello.qbs
share/qtcreator/qbs/share/qbs/examples/helloworld-qt/main.cpp
+share/qtcreator/qbs/share/qbs/examples/install-bundle/coreutils.cpp
+share/qtcreator/qbs/share/qbs/examples/install-bundle/coreutils.h
+share/qtcreator/qbs/share/qbs/examples/install-bundle/install-bundle.qbs
+share/qtcreator/qbs/share/qbs/examples/install-bundle/main.cpp
share/qtcreator/qbs/share/qbs/imports/qbs/BundleTools/bundle-tools.js
share/qtcreator/qbs/share/qbs/imports/qbs/DarwinTools/darwin-tools.js
share/qtcreator/qbs/share/qbs/imports/qbs/FileInfo/fileinfo.js
share/qtcreator/qbs/share/qbs/imports/qbs/ModUtils/utils.js
share/qtcreator/qbs/share/qbs/imports/qbs/PathTools/path-tools.js
+share/qtcreator/qbs/share/qbs/imports/qbs/Probes/AndroidNdkProbe.qbs
+share/qtcreator/qbs/share/qbs/imports/qbs/Probes/AndroidSdkProbe.qbs
share/qtcreator/qbs/share/qbs/imports/qbs/Probes/BinaryProbe.qbs
share/qtcreator/qbs/share/qbs/imports/qbs/Probes/FrameworkProbe.qbs
share/qtcreator/qbs/share/qbs/imports/qbs/Probes/IncludeProbe.qbs
+share/qtcreator/qbs/share/qbs/imports/qbs/Probes/JdkProbe.qbs
+share/qtcreator/qbs/share/qbs/imports/qbs/Probes/NodeJsProbe.qbs
share/qtcreator/qbs/share/qbs/imports/qbs/Probes/PathProbe.qbs
share/qtcreator/qbs/share/qbs/imports/qbs/Probes/PkgConfigProbe.qbs
+share/qtcreator/qbs/share/qbs/imports/qbs/Probes/TypeScriptProbe.qbs
share/qtcreator/qbs/share/qbs/imports/qbs/UnixUtils/unix-utils.js
share/qtcreator/qbs/share/qbs/imports/qbs/WindowsUtils/windows-utils.js
share/qtcreator/qbs/share/qbs/imports/qbs/base/AndroidApk.qbs
@@ -285,14 +304,27 @@ share/qtcreator/qbs/share/qbs/modules/cpp/windows-msvc.qbs
share/qtcreator/qbs/share/qbs/modules/ib/IBModule.qbs
share/qtcreator/qbs/share/qbs/modules/ib/ib.js
share/qtcreator/qbs/share/qbs/modules/java/JavaModule.qbs
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/Artifact.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/ArtifactListJsonWriter.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/ArtifactListTextWriter.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/ArtifactListWriter.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/ArtifactListXmlWriter.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/tools/JavaCompilerScannerTool.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/tools/utils/JavaCompilerOptions.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/tools/utils/JavaCompilerScanner.java
+share/qtcreator/qbs/share/qbs/modules/java/io/qt/qbs/tools/utils/NullFileObject.java
share/qtcreator/qbs/share/qbs/modules/java/utils.js
share/qtcreator/qbs/share/qbs/modules/nodejs/NodeJS.qbs
share/qtcreator/qbs/share/qbs/modules/nsis/NSISModule.qbs
share/qtcreator/qbs/share/qbs/modules/qbs/common.qbs
share/qtcreator/qbs/share/qbs/modules/typescript/TypeScriptModule.qbs
+share/qtcreator/qbs/share/qbs/modules/typescript/qbs-tsc-scan/.gitignore
+share/qtcreator/qbs/share/qbs/modules/typescript/qbs-tsc-scan/qbs-tsc-scan.ts
+share/qtcreator/qbs/share/qbs/modules/typescript/typescript.js
share/qtcreator/qbs/share/qbs/modules/wix/WiXModule.qbs
share/qtcreator/qml-type-descriptions/builtins.qmltypes
share/qtcreator/qml-type-descriptions/qbs-bundle.json
+share/qtcreator/qml-type-descriptions/qbs.qmltypes
share/qtcreator/qml-type-descriptions/qmlproject-bundle.json
share/qtcreator/qml-type-descriptions/qmlproject.qmltypes
share/qtcreator/qml-type-descriptions/qmlruntime.qmltypes
@@ -316,7 +348,6 @@ share/qtcreator/qml-type-descriptions/qtmobility-serviceframework.qmltypes
share/qtcreator/qml-type-descriptions/qtmobility-systeminfo.qmltypes
share/qtcreator/qml-type-descriptions/qtmultimediakit.qmltypes
share/qtcreator/qml-type-descriptions/qtwebkit.qmltypes
-share/qtcreator/qml/qmldump/Info.plist.in
share/qtcreator/qml/qmldump/LGPL_EXCEPTION.TXT
share/qtcreator/qml/qmldump/LICENSE.LGPL
share/qtcreator/qml/qmldump/main.cpp
@@ -427,8 +458,6 @@ share/qtcreator/qml/qmlpuppet/qml2puppet/instances/dummynodeinstance.h
share/qtcreator/qml/qmlpuppet/qml2puppet/instances/instances.pri
share/qtcreator/qml/qmlpuppet/qml2puppet/instances/layoutnodeinstance.cpp
share/qtcreator/qml/qmlpuppet/qml2puppet/instances/layoutnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qml2puppet/instances/nodeinstancemetaobject.cpp
-share/qtcreator/qml/qmlpuppet/qml2puppet/instances/nodeinstancemetaobject.h
share/qtcreator/qml/qmlpuppet/qml2puppet/instances/nodeinstanceserver.cpp
share/qtcreator/qml/qmlpuppet/qml2puppet/instances/nodeinstanceserver.h
share/qtcreator/qml/qmlpuppet/qml2puppet/instances/nodeinstancesignalspy.cpp
@@ -462,56 +491,15 @@ share/qtcreator/qml/qmlpuppet/qml2puppet/instances/servernodeinstance.h
share/qtcreator/qml/qmlpuppet/qml2puppet/qml2puppet.pri
share/qtcreator/qml/qmlpuppet/qml2puppet/qml2puppet.pro
share/qtcreator/qml/qmlpuppet/qml2puppet/qml2puppetmain.cpp
+share/qtcreator/qml/qmlpuppet/qmlprivategate/designercustomobjectdata.cpp
+share/qtcreator/qml/qmlpuppet/qmlprivategate/designercustomobjectdata.h
+share/qtcreator/qml/qmlpuppet/qmlprivategate/designersupportdelegate.h
+share/qtcreator/qml/qmlpuppet/qmlprivategate/metaobject.cpp
+share/qtcreator/qml/qmlpuppet/qmlprivategate/metaobject.h
+share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.cpp
+share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h
+share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.pri
share/qtcreator/qml/qmlpuppet/qmlpuppet.qrc
-share/qtcreator/qml/qmlpuppet/qmlpuppet/Info.plist
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/anchorchangesnodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/anchorchangesnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/behaviornodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/behaviornodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/childrenchangeeventfilter.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/childrenchangeeventfilter.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/componentnodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/componentnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/dummycontextobject.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/dummycontextobject.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/dummynodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/dummynodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/graphicsobjectnodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/graphicsobjectnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/instances.pri
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/nodeinstancemetaobject.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/nodeinstancemetaobject.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/nodeinstanceserver.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/nodeinstanceserver.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/nodeinstancesignalspy.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/nodeinstancesignalspy.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/objectnodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/objectnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/positionernodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/positionernodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmlgraphicsitemnodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmlgraphicsitemnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmlpropertychangesnodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmlpropertychangesnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmlstatenodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmlstatenodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmltransitionnodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qmltransitionnodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4informationnodeinstanceserver.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4informationnodeinstanceserver.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4nodeinstanceclientproxy.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4nodeinstanceclientproxy.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4nodeinstanceserver.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4nodeinstanceserver.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4previewnodeinstanceserver.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4previewnodeinstanceserver.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4rendernodeinstanceserver.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/qt4rendernodeinstanceserver.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/servernodeinstance.cpp
-share/qtcreator/qml/qmlpuppet/qmlpuppet/instances/servernodeinstance.h
-share/qtcreator/qml/qmlpuppet/qmlpuppet/qmlpuppet.pri
-share/qtcreator/qml/qmlpuppet/qmlpuppet/qmlpuppet.pro
-share/qtcreator/qml/qmlpuppet/qmlpuppet/qmlpuppetmain.cpp
share/qtcreator/qml/qmlpuppet/qmlpuppet_utilities.pri
share/qtcreator/qml/qmlpuppet/types/enumeration.cpp
share/qtcreator/qml/qmlpuppet/types/enumeration.h
@@ -703,35 +691,6 @@ share/qtcreator/styles/default.xml
share/qtcreator/styles/grayscale.xml
share/qtcreator/styles/inkpot.xml
share/qtcreator/styles/intellij.xml
-share/qtcreator/templates/qml/qtquick_1_1/main.qml
-share/qtcreator/templates/qml/qtquick_1_1/main.qmlproject
-share/qtcreator/templates/qml/qtquick_1_1/template.xml
-share/qtcreator/templates/qml/qtquick_2_1/main.qml
-share/qtcreator/templates/qml/qtquick_2_1/main.qmlproject
-share/qtcreator/templates/qml/qtquick_2_1/template.xml
-share/qtcreator/templates/qml/qtquick_2_2/main.qml
-share/qtcreator/templates/qml/qtquick_2_2/main.qmlproject
-share/qtcreator/templates/qml/qtquick_2_2/template.xml
-share/qtcreator/templates/qml/qtquick_2_3/main.qml
-share/qtcreator/templates/qml/qtquick_2_3/main.qmlproject
-share/qtcreator/templates/qml/qtquick_2_3/template.xml
-share/qtcreator/templates/qml/qtquick_2_4/MainForm.ui.qml
-share/qtcreator/templates/qml/qtquick_2_4/main.qml
-share/qtcreator/templates/qml/qtquick_2_4/main.qmlproject
-share/qtcreator/templates/qml/qtquick_2_4/template.xml
-share/qtcreator/templates/qml/qtquickcontrols_1_0/main.qml
-share/qtcreator/templates/qml/qtquickcontrols_1_0/main.qmlproject
-share/qtcreator/templates/qml/qtquickcontrols_1_0/template.xml
-share/qtcreator/templates/qml/qtquickcontrols_1_1/main.qml
-share/qtcreator/templates/qml/qtquickcontrols_1_1/main.qmlproject
-share/qtcreator/templates/qml/qtquickcontrols_1_1/template.xml
-share/qtcreator/templates/qml/qtquickcontrols_1_2/main.qml
-share/qtcreator/templates/qml/qtquickcontrols_1_2/main.qmlproject
-share/qtcreator/templates/qml/qtquickcontrols_1_2/template.xml
-share/qtcreator/templates/qml/qtquickcontrols_1_3/MainForm.ui.qml
-share/qtcreator/templates/qml/qtquickcontrols_1_3/main.qml
-share/qtcreator/templates/qml/qtquickcontrols_1_3/main.qmlproject
-share/qtcreator/templates/qml/qtquickcontrols_1_3/template.xml
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_collection.cpp
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_collection.h
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_plugin.pro
@@ -748,73 +707,8 @@ share/qtcreator/templates/qt4project/mywidget.h
share/qtcreator/templates/qt4project/mywidget_form.cpp
share/qtcreator/templates/qt4project/mywidget_form.h
share/qtcreator/templates/qt4project/widget.ui
-share/qtcreator/templates/qtquick/qtquick_1_1/app.pro
-share/qtcreator/templates/qtquick/qtquick_1_1/main.cpp
-share/qtcreator/templates/qtquick/qtquick_1_1/main.qml
-share/qtcreator/templates/qtquick/qtquick_1_1/qml.qrc
-share/qtcreator/templates/qtquick/qtquick_1_1/template.xml
-share/qtcreator/templates/qtquick/qtquick_2_1/app.pro
-share/qtcreator/templates/qtquick/qtquick_2_1/main.cpp
-share/qtcreator/templates/qtquick/qtquick_2_1/main.qml
-share/qtcreator/templates/qtquick/qtquick_2_1/qml.qrc
-share/qtcreator/templates/qtquick/qtquick_2_1/template.xml
-share/qtcreator/templates/qtquick/qtquick_2_2/app.pro
-share/qtcreator/templates/qtquick/qtquick_2_2/main.cpp
-share/qtcreator/templates/qtquick/qtquick_2_2/main.qml
-share/qtcreator/templates/qtquick/qtquick_2_2/qml.qrc
-share/qtcreator/templates/qtquick/qtquick_2_2/template.xml
-share/qtcreator/templates/qtquick/qtquick_2_3/app.pro
-share/qtcreator/templates/qtquick/qtquick_2_3/main.cpp
-share/qtcreator/templates/qtquick/qtquick_2_3/main.qml
-share/qtcreator/templates/qtquick/qtquick_2_3/qml.qrc
-share/qtcreator/templates/qtquick/qtquick_2_3/template.xml
-share/qtcreator/templates/qtquick/qtquick_2_4/MainForm.ui.qml
-share/qtcreator/templates/qtquick/qtquick_2_4/app.pro
-share/qtcreator/templates/qtquick/qtquick_2_4/main.cpp
-share/qtcreator/templates/qtquick/qtquick_2_4/main.qml
-share/qtcreator/templates/qtquick/qtquick_2_4/qml.qrc
-share/qtcreator/templates/qtquick/qtquick_2_4/template.xml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_0/app.pro
-share/qtcreator/templates/qtquick/qtquickcontrols_1_0/main.cpp
-share/qtcreator/templates/qtquick/qtquickcontrols_1_0/main.qml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_0/qml.qrc
-share/qtcreator/templates/qtquick/qtquickcontrols_1_0/template.xml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_1/app.pro
-share/qtcreator/templates/qtquick/qtquickcontrols_1_1/main.cpp
-share/qtcreator/templates/qtquick/qtquickcontrols_1_1/main.qml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_1/qml.qrc
-share/qtcreator/templates/qtquick/qtquickcontrols_1_1/template.xml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_2/app.pro
-share/qtcreator/templates/qtquick/qtquickcontrols_1_2/main.cpp
-share/qtcreator/templates/qtquick/qtquickcontrols_1_2/main.qml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_2/qml.qrc
-share/qtcreator/templates/qtquick/qtquickcontrols_1_2/template.xml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_3/MainForm.ui.qml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_3/app.pro
-share/qtcreator/templates/qtquick/qtquickcontrols_1_3/main.cpp
-share/qtcreator/templates/qtquick/qtquickcontrols_1_3/main.qml
-share/qtcreator/templates/qtquick/qtquickcontrols_1_3/qml.qrc
-share/qtcreator/templates/qtquick/qtquickcontrols_1_3/template.xml
-share/qtcreator/templates/shared/app.desktop
-share/qtcreator/templates/shared/deployment.pri
-share/qtcreator/templates/shared/manifest.aegis
share/qtcreator/templates/shared/qrcdeployment.pri
-share/qtcreator/templates/shared/qtquickapplicationviewer/qtquick1applicationviewer/qtquick1applicationviewer.cpp
-share/qtcreator/templates/shared/qtquickapplicationviewer/qtquick1applicationviewer/qtquick1applicationviewer.h
-share/qtcreator/templates/shared/qtquickapplicationviewer/qtquick1applicationviewer/qtquick1applicationviewer.pri
share/qtcreator/templates/wizards/README.txt
-share/qtcreator/templates/wizards/bb-bardescriptor/bar-descriptor.xml
-share/qtcreator/templates/wizards/bb-bardescriptor/wizard.xml
-share/qtcreator/templates/wizards/bb-cascades-app/assets/main.qml
-share/qtcreator/templates/wizards/bb-cascades-app/bar-descriptor.xml
-share/qtcreator/templates/wizards/bb-cascades-app/icon.png
-share/qtcreator/templates/wizards/bb-cascades-app/project.pro
-share/qtcreator/templates/wizards/bb-cascades-app/src/applicationui.cpp
-share/qtcreator/templates/wizards/bb-cascades-app/src/applicationui.h
-share/qtcreator/templates/wizards/bb-cascades-app/src/main.cpp
-share/qtcreator/templates/wizards/bb-cascades-app/wizard.xml
-share/qtcreator/templates/wizards/bb-qt5-bardescriptor/bar-descriptor.xml
-share/qtcreator/templates/wizards/bb-qt5-bardescriptor/wizard.xml
share/qtcreator/templates/wizards/classes/cpp/file.cpp
share/qtcreator/templates/wizards/classes/cpp/file.h
share/qtcreator/templates/wizards/classes/cpp/wizard.json
@@ -856,34 +750,61 @@ share/qtcreator/templates/wizards/files/scratch/file.txt
share/qtcreator/templates/wizards/files/scratch/wizard.json
share/qtcreator/templates/wizards/files/text/file.txt
share/qtcreator/templates/wizards/files/text/wizard.json
+share/qtcreator/templates/wizards/global/consoleapplication.png
share/qtcreator/templates/wizards/global/genericfilewizard.png
share/qtcreator/templates/wizards/global/guiapplication.png
-share/qtcreator/templates/wizards/helloworld/console.png
-share/qtcreator/templates/wizards/helloworld/main.cpp
-share/qtcreator/templates/wizards/helloworld/project.pro
-share/qtcreator/templates/wizards/helloworld/wizard_sample.xml
-share/qtcreator/templates/wizards/listmodel/listmodel.cpp
-share/qtcreator/templates/wizards/listmodel/listmodel.h
-share/qtcreator/templates/wizards/listmodel/wizard_sample.xml
-share/qtcreator/templates/wizards/plaincapp/cmake/CMakeLists.txt
-share/qtcreator/templates/wizards/plaincapp/cmake/wizard.xml
-share/qtcreator/templates/wizards/plaincapp/common/console.png
-share/qtcreator/templates/wizards/plaincapp/common/main.c
-share/qtcreator/templates/wizards/plaincapp/qbs/project.qbs
-share/qtcreator/templates/wizards/plaincapp/qbs/wizard.xml
-share/qtcreator/templates/wizards/plaincapp/qmake/project.pro
-share/qtcreator/templates/wizards/plaincapp/qmake/wizard.xml
-share/qtcreator/templates/wizards/plaincppapp/cmake/CMakeLists.txt
-share/qtcreator/templates/wizards/plaincppapp/cmake/wizard.xml
-share/qtcreator/templates/wizards/plaincppapp/common/console.png
-share/qtcreator/templates/wizards/plaincppapp/common/main.cpp
-share/qtcreator/templates/wizards/plaincppapp/qbs/project.qbs
-share/qtcreator/templates/wizards/plaincppapp/qbs/wizard.xml
-share/qtcreator/templates/wizards/plaincppapp/qmake/project.pro
-share/qtcreator/templates/wizards/plaincppapp/qmake/wizard.xml
+share/qtcreator/templates/wizards/projects/git.ignore
+share/qtcreator/templates/wizards/projects/plainc/CMakeLists.txt
+share/qtcreator/templates/wizards/projects/plainc/file.pro
+share/qtcreator/templates/wizards/projects/plainc/file.qbs
+share/qtcreator/templates/wizards/projects/plainc/main.c
+share/qtcreator/templates/wizards/projects/plainc/wizard.json
+share/qtcreator/templates/wizards/projects/plaincpp/CMakeLists.txt
+share/qtcreator/templates/wizards/projects/plaincpp/file.pro
+share/qtcreator/templates/wizards/projects/plaincpp/file.qbs
+share/qtcreator/templates/wizards/projects/plaincpp/main.cpp
+share/qtcreator/templates/wizards/projects/plaincpp/wizard.json
+share/qtcreator/templates/wizards/projects/qmake/consoleapp/file.pro
+share/qtcreator/templates/wizards/projects/qmake/consoleapp/main.cpp
+share/qtcreator/templates/wizards/projects/qmake/consoleapp/wizard.json
share/qtcreator/templates/wizards/projects/qmake/empty/file.pro
share/qtcreator/templates/wizards/projects/qmake/empty/wizard.json
-share/qtcreator/templates/wizards/projects/qmake/git.ignore
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/3dapplication.png
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/app.pro
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/main.cpp
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/main.qml
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/plaincanvas3d/glcode.js
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/qml.qrc
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/threejs/3rdparty/three.js
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/threejs/glcode.js
+share/qtcreator/templates/wizards/projects/qmake/qtcanvas3dapplication/wizard.json
+share/qtcreator/templates/wizards/projects/qmake/qtquickapplication/MainForm.ui.qml
+share/qtcreator/templates/wizards/projects/qmake/qtquickapplication/app.pro
+share/qtcreator/templates/wizards/projects/qmake/qtquickapplication/main.cpp
+share/qtcreator/templates/wizards/projects/qmake/qtquickapplication/main.qml
+share/qtcreator/templates/wizards/projects/qmake/qtquickapplication/qml.qrc
+share/qtcreator/templates/wizards/projects/qmake/qtquickapplication/qml_wizard.png
+share/qtcreator/templates/wizards/projects/qmake/qtquickapplication/wizard.json
+share/qtcreator/templates/wizards/projects/qmake/qtquickcontrolsapplication/MainForm.ui.qml
+share/qtcreator/templates/wizards/projects/qmake/qtquickcontrolsapplication/app.pro
+share/qtcreator/templates/wizards/projects/qmake/qtquickcontrolsapplication/main.cpp
+share/qtcreator/templates/wizards/projects/qmake/qtquickcontrolsapplication/main.qml
+share/qtcreator/templates/wizards/projects/qmake/qtquickcontrolsapplication/qml.qrc
+share/qtcreator/templates/wizards/projects/qmake/qtquickcontrolsapplication/wizard.json
+share/qtcreator/templates/wizards/projects/qmlproject/qtquickapplication/app.qmlproject
+share/qtcreator/templates/wizards/projects/qmlproject/qtquickapplication/wizard.json
+share/qtcreator/templates/wizards/projects/qmlproject/qtquickcontrolsapplication/app.qmlproject
+share/qtcreator/templates/wizards/projects/qmlproject/qtquickcontrolsapplication/wizard.json
+share/qtcreator/templates/wizards/projects/vcs/bazaar/icon.png
+share/qtcreator/templates/wizards/projects/vcs/bazaar/wizard.json
+share/qtcreator/templates/wizards/projects/vcs/cvs/icon.png
+share/qtcreator/templates/wizards/projects/vcs/cvs/wizard.json
+share/qtcreator/templates/wizards/projects/vcs/git/icon.png
+share/qtcreator/templates/wizards/projects/vcs/git/wizard.json
+share/qtcreator/templates/wizards/projects/vcs/mercurial/icon.png
+share/qtcreator/templates/wizards/projects/vcs/mercurial/wizard.json
+share/qtcreator/templates/wizards/projects/vcs/subversion/icon.png
+share/qtcreator/templates/wizards/projects/vcs/subversion/wizard.json
share/qtcreator/templates/wizards/qtcreatorplugin/MyPlugin.json.in
share/qtcreator/templates/wizards/qtcreatorplugin/myplugin.cpp
share/qtcreator/templates/wizards/qtcreatorplugin/myplugin.h
@@ -908,8 +829,6 @@ share/qtcreator/templates/wizards/qtquick2-extension/plugin.h
share/qtcreator/templates/wizards/qtquick2-extension/project.pro
share/qtcreator/templates/wizards/qtquick2-extension/qmldir
share/qtcreator/templates/wizards/qtquick2-extension/wizard.xml
-share/qtcreator/templates/wizards/scriptgeneratedproject/generate.pl
-share/qtcreator/templates/wizards/scriptgeneratedproject/wizard_sample.xml
share/qtcreator/themes/dark.creatortheme
share/qtcreator/themes/default.creatortheme
share/qtcreator/translations/qtcreator_cs.qm