aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 01:51:39 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 01:51:39 +0800
commitb4cf4d405d655deba8137ee3e09eb8357c577f91 (patch)
tree1f12c4fc9e5a73b8a868332e674b49570124921e /devel
parent59cf9a1ea21ca3b9be73f7372313784530270a14 (diff)
downloadfreebsd-ports-gnome-b4cf4d405d655deba8137ee3e09eb8357c577f91.tar.gz
freebsd-ports-gnome-b4cf4d405d655deba8137ee3e09eb8357c577f91.tar.zst
freebsd-ports-gnome-b4cf4d405d655deba8137ee3e09eb8357c577f91.zip
Only append to EXTRA_PATCHES after bsd.port.pre.mk
Diffstat (limited to 'devel')
-rw-r--r--devel/bazel/Makefile2
-rw-r--r--devel/glib20/Makefile2
-rw-r--r--devel/p5-Devel-BeginLift/Makefile2
-rw-r--r--devel/p5-UNIVERSAL-ref/Makefile2
-rw-r--r--devel/py-columnize/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/devel/bazel/Makefile b/devel/bazel/Makefile
index 71b4ab0a08f3..0a54a63185bf 100644
--- a/devel/bazel/Makefile
+++ b/devel/bazel/Makefile
@@ -41,7 +41,7 @@ STRIP= # The bazel binary is also a zip archive (extracted by the elf part), it
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
-EXTRA_PATCHES= ${FILESDIR}/extra-i386_src_BUILD ${FILESDIR}/extra-i386_tools_cpp_BUILD.static.freebsd
+EXTRA_PATCHES+= ${FILESDIR}/extra-i386_src_BUILD ${FILESDIR}/extra-i386_tools_cpp_BUILD.static.freebsd
.endif
# Have the location of the system-wide rc file reside ${ETCDIR}.
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index d693f8b3fc73..fa07decf8188 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -72,7 +72,7 @@ CONFIGURE_ARGS+= --with-libiconv=gnu
.endif
.if ${ARCH} == powerpc64
-EXTRA_PATCHES= ${FILESDIR}/extra-arch-powerpc64
+EXTRA_PATCHES+= ${FILESDIR}/extra-arch-powerpc64
.endif
# Let glib use asm code for implementing atomic ops on i386 and amd64.
diff --git a/devel/p5-Devel-BeginLift/Makefile b/devel/p5-Devel-BeginLift/Makefile
index 28ea2e292e5f..c90e4942af91 100644
--- a/devel/p5-Devel-BeginLift/Makefile
+++ b/devel/p5-Devel-BeginLift/Makefile
@@ -21,7 +21,7 @@ USE_PERL5= configure
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502501
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-BeginLift.xs
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-BeginLift.xs
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-UNIVERSAL-ref/Makefile b/devel/p5-UNIVERSAL-ref/Makefile
index 14978d9477a3..f83e0fa925fa 100644
--- a/devel/p5-UNIVERSAL-ref/Makefile
+++ b/devel/p5-UNIVERSAL-ref/Makefile
@@ -20,7 +20,7 @@ USE_PERL5= configure
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502501
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ref.xs
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ref.xs
.endif
.include <bsd.port.post.mk>
diff --git a/devel/py-columnize/Makefile b/devel/py-columnize/Makefile
index 6f81ec1b3412..9358963396d9 100644
--- a/devel/py-columnize/Makefile
+++ b/devel/py-columnize/Makefile
@@ -22,7 +22,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
.if ${PYTHON_MAJOR_VER} == "3"
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-____pkginfo____.py
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-____pkginfo____.py
.else
MY_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.shutil_get_terminal_size>=1.0:devel/py-backports.shutil_get_terminal_size@${PY_FLAVOR}
.endif