aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-05 22:25:02 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-05 22:25:02 +0800
commitb5f6848d66e447c98a0d4b60f347b906440b7602 (patch)
treea3de386c012a3d8735837396490c1e3d4a06c73e /devel
parent9ea7037651a63e02ace32a3ac8744d89f4e73017 (diff)
downloadfreebsd-ports-gnome-b5f6848d66e447c98a0d4b60f347b906440b7602.tar.gz
freebsd-ports-gnome-b5f6848d66e447c98a0d4b60f347b906440b7602.tar.zst
freebsd-ports-gnome-b5f6848d66e447c98a0d4b60f347b906440b7602.zip
- Add py-pydocstyle, py3-pydocstyle
Python docstring style checker (formerly pep257) pydocstyle is a static analysis tool for checking compliance with Python docstring conventions. pydocstyle supports most of PEP 257 out of the box, but it should not be considered a reference implementation. pydocstyle supports Python 2.6, 2.7, 3.3, 3.4, 3.5, pypy and pypy3. WWW: https://pypi.python.org/pypi/pydocstyle
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-pydocstyle/Makefile20
-rw-r--r--devel/py-pydocstyle/distinfo3
-rw-r--r--devel/py-pydocstyle/pkg-descr13
-rw-r--r--devel/py3-pydocstyle/Makefile8
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 61c93435d6c9..d131769eee82 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4505,6 +4505,7 @@
SUBDIR += py-pycodestyle
SUBDIR += py-pycparser
SUBDIR += py-pydenticon
+ SUBDIR += py-pydocstyle
SUBDIR += py-pydoop
SUBDIR += py-pyechonest
SUBDIR += py-pyee
@@ -4884,6 +4885,7 @@
SUBDIR += py3-nose
SUBDIR += py3-py
SUBDIR += py3-pycodestyle
+ SUBDIR += py3-pydocstyle
SUBDIR += py3-pyflakes
SUBDIR += py3-pyicu
SUBDIR += py3-pylru-cache
diff --git a/devel/py-pydocstyle/Makefile b/devel/py-pydocstyle/Makefile
new file mode 100644
index 000000000000..998ee26dc4b5
--- /dev/null
+++ b/devel/py-pydocstyle/Makefile
@@ -0,0 +1,20 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pydocstyle
+PORTVERSION= 1.1.1
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Python docstring style checker
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE-MIT
+
+USES?= python zip
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pydocstyle/distinfo b/devel/py-pydocstyle/distinfo
new file mode 100644
index 000000000000..45c18eb7da46
--- /dev/null
+++ b/devel/py-pydocstyle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486304287
+SHA256 (pydocstyle-1.1.1.zip) = f808d8fc23952fe93c2d85598732bfa854cb5ee8a25f8191f60600710f898e8d
+SIZE (pydocstyle-1.1.1.zip) = 26570
diff --git a/devel/py-pydocstyle/pkg-descr b/devel/py-pydocstyle/pkg-descr
new file mode 100644
index 000000000000..cece16b91f8e
--- /dev/null
+++ b/devel/py-pydocstyle/pkg-descr
@@ -0,0 +1,13 @@
+Python docstring style checker
+
+(formerly pep257)
+
+pydocstyle is a static analysis tool for checking compliance with
+Python docstring conventions.
+
+pydocstyle supports most of PEP 257 out of the box, but it should
+not be considered a reference implementation.
+
+pydocstyle supports Python 2.6, 2.7, 3.3, 3.4, 3.5, pypy and pypy3.
+
+WWW: https://pypi.python.org/pypi/pydocstyle
diff --git a/devel/py3-pydocstyle/Makefile b/devel/py3-pydocstyle/Makefile
new file mode 100644
index 000000000000..25571a9fbba7
--- /dev/null
+++ b/devel/py3-pydocstyle/Makefile
@@ -0,0 +1,8 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-pydocstyle
+
+USES= python:3 zip
+
+.include "${MASTERDIR}/Makefile"