aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-05-05 09:41:12 +0800
committerijliao <ijliao@FreeBSD.org>2004-05-05 09:41:12 +0800
commitb72cb8de639644ad4456de6dcd449b64e9c08c23 (patch)
tree36d91ddd2a6eb3632b12ebfefb7c9e14b96ec517 /devel
parent966416db3a5c5dd3f486e3d98f784cf850b5d725 (diff)
downloadfreebsd-ports-gnome-b72cb8de639644ad4456de6dcd449b64e9c08c23.tar.gz
freebsd-ports-gnome-b72cb8de639644ad4456de6dcd449b64e9c08c23.tar.zst
freebsd-ports-gnome-b72cb8de639644ad4456de6dcd449b64e9c08c23.zip
add jclassinfo 0.19
Shows information about Java class, dependencies and more
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jclassinfo/Makefile29
-rw-r--r--devel/jclassinfo/distinfo2
-rw-r--r--devel/jclassinfo/files/patch-jclass:Makefile.in11
-rw-r--r--devel/jclassinfo/files/patch-ltmain.sh15
-rw-r--r--devel/jclassinfo/pkg-descr4
-rw-r--r--devel/jclassinfo/pkg-plist23
7 files changed, 85 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f2ae6e6f5863..69bb2ca3f88d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -339,6 +339,7 @@
SUBDIR += ixlib
SUBDIR += jakelib2
SUBDIR += jam
+ SUBDIR += jclassinfo
SUBDIR += jrtplib
SUBDIR += jude_take
SUBDIR += kaptain
diff --git a/devel/jclassinfo/Makefile b/devel/jclassinfo/Makefile
new file mode 100644
index 000000000000..5d57f57e9687
--- /dev/null
+++ b/devel/jclassinfo/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: jclassinfo
+# Date created: May 5, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jclassinfo
+PORTVERSION= 0.19
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Shows information about Java class, dependencies and more
+
+USE_REINPLACE= yes
+USE_GETOPT_LONG= yes
+USE_GNOME= pkgconfig gnomehack
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= jclassinfo.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s, docs,," ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/jclassinfo/distinfo b/devel/jclassinfo/distinfo
new file mode 100644
index 000000000000..3de56d7388e2
--- /dev/null
+++ b/devel/jclassinfo/distinfo
@@ -0,0 +1,2 @@
+MD5 (jclassinfo-0.19.tar.gz) = fb512cbb399476fb4abd47df648c8b9b
+SIZE (jclassinfo-0.19.tar.gz) = 385709
diff --git a/devel/jclassinfo/files/patch-jclass:Makefile.in b/devel/jclassinfo/files/patch-jclass:Makefile.in
new file mode 100644
index 000000000000..6512a151b1e8
--- /dev/null
+++ b/devel/jclassinfo/files/patch-jclass:Makefile.in
@@ -0,0 +1,11 @@
+--- jclass/Makefile.in.orig Wed May 5 09:23:09 2004
++++ jclass/Makefile.in Wed May 5 09:23:17 2004
+@@ -156,7 +156,7 @@
+ lib_LTLIBRARIES = libjclass.la
+ libjclass_la_LDFLAGS = -no-undefined -version-info @JCLASS_CURRENT@:@JCLASS_RELEASE@:@JCLASS_AGE@
+
+-library_includedir = $(includedir)/jclass/jclass
++library_includedir = $(includedir)/jclass
+
+ library_include_HEADERS = \
+ attributes.h \
diff --git a/devel/jclassinfo/files/patch-ltmain.sh b/devel/jclassinfo/files/patch-ltmain.sh
new file mode 100644
index 000000000000..74ae099b3e91
--- /dev/null
+++ b/devel/jclassinfo/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Wed May 5 09:16:19 2004
++++ ltmain.sh Wed May 5 09:16:29 2004
+@@ -5528,10 +5528,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/jclassinfo/pkg-descr b/devel/jclassinfo/pkg-descr
new file mode 100644
index 000000000000..2979bd696a10
--- /dev/null
+++ b/devel/jclassinfo/pkg-descr
@@ -0,0 +1,4 @@
+jclassinfo reads java class files and provides information about the class,
+dependencies and more. It is a pure C implementantion.
+
+WWW: http://jclassinfo.sourceforge.net/
diff --git a/devel/jclassinfo/pkg-plist b/devel/jclassinfo/pkg-plist
new file mode 100644
index 000000000000..ae0727c15d20
--- /dev/null
+++ b/devel/jclassinfo/pkg-plist
@@ -0,0 +1,23 @@
+bin/jclassinfo
+include/jclass/attributes.h
+include/jclass/bytecode.h
+include/jclass/class.h
+include/jclass/class_loader.h
+include/jclass/constant_pool.h
+include/jclass/field.h
+include/jclass/jar.h
+include/jclass/jclass.h
+include/jclass/jstring.h
+include/jclass/manifest.h
+include/jclass/types.h
+lib/jclass/include/jclassconfig.h
+lib/libjclass.a
+lib/libjclass.so
+lib/libjclass.so.3
+libdata/pkgconfig/jclass.pc
+share/xml/jclassinfo/jclassinfo.dtd
+share/xml/jclassinfo/jclassinfo2xhtml.xsl
+@dirrm include/jclass
+@dirrm lib/jclass/include
+@dirrm lib/jclass
+@dirrm share/xml/jclassinfo