aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-02 12:33:05 +0800
committerJan Beich <jbeich@FreeBSD.org>2016-11-02 12:33:05 +0800
commitb7bc6d1bea4941b9ee634f8c863102b846811386 (patch)
tree55a16847de629c9e3ddc936c66d2e052f4ea5987 /devel
parent5d94618b17092611bf5b899fb83df7e05b75a02e (diff)
downloadfreebsd-ports-gnome-b7bc6d1bea4941b9ee634f8c863102b846811386.tar.gz
freebsd-ports-gnome-b7bc6d1bea4941b9ee634f8c863102b846811386.tar.zst
freebsd-ports-gnome-b7bc6d1bea4941b9ee634f8c863102b846811386.zip
devel/sfml: unbreak on 9.x via clang
cd src/SFML/Audio && /usr/bin/c++ -DFLAC__NO_DLL -DOV_EXCLUDE_STATIC_CALLBACKS -DSFML_AUDIO_EXPORTS -Iinclude -Isrc -I/usr/local/include/AL -I/usr/local/include -O2 -pipe -fno-strict-aliasing -O2 -pipe -fno-strict-aliasing -fPIC -fvisibility=hidden -o CMakeFiles/sfml-audio.dir/SoundFileFactory.cpp.o -c src/SFML/Audio/SoundFileFactory.cpp include/SFML/Audio/SoundFileFactory.inl: In static member function 'static void sf::SoundFileFactory::unregisterReader() [with T = sf::priv::SoundFileReaderFlac]': include/SFML/Audio/SoundFileFactory.inl:43: instantiated from 'static void sf::SoundFileFactory::registerReader() [with T = sf::priv::SoundFileReaderFlac]' src/SFML/Audio/SoundFileFactory.cpp:48: instantiated from here include/SFML/Audio/SoundFileFactory.inl:62: error: address of overloaded function with no contextual type information include/SFML/Audio/SoundFileFactory.inl: In static member function 'static void sf::SoundFileFactory::unregisterWriter() [with T = sf::priv::SoundFileWriterFlac]': include/SFML/Audio/SoundFileFactory.inl:74: instantiated from 'static void sf::SoundFileFactory::registerWriter() [with T = sf::priv::SoundFileWriterFlac]' src/SFML/Audio/SoundFileFactory.cpp:49: instantiated from here include/SFML/Audio/SoundFileFactory.inl:93: error: address of overloaded function with no contextual type information [...] Approved by: portmgr blanket
Diffstat (limited to 'devel')
-rw-r--r--devel/sfml/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/devel/sfml/Makefile b/devel/sfml/Makefile
index ce6d383a8918..8e09a634a83e 100644
--- a/devel/sfml/Makefile
+++ b/devel/sfml/Makefile
@@ -19,9 +19,7 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libvorbis.so:audio/libvorbis \
libxcb-image.so:x11/xcb-util-image
-BROKEN_FreeBSD_9= does not build
-
-USES= cmake dos2unix jpeg openal:al zip:infozip
+USES= cmake compiler:c++11-lang dos2unix jpeg openal:al zip:infozip
CMAKE_ARGS= -DSFML_INSTALL_PKGCONFIG_FILES=ON
DOS2UNIX_FILES= CMakeLists.txt
USE_XORG= x11 xcb