aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-06-08 21:45:18 +0800
committerswills <swills@FreeBSD.org>2014-06-08 21:45:18 +0800
commitb7c53721525eee1abc6da61f79b3d29c4da815a7 (patch)
tree27646e64b89ee332bbaefdd74a67b7b4a2d603f5 /devel
parent8efdf9b1fb855deffd4702ea39f0bcf10cc092a1 (diff)
downloadfreebsd-ports-gnome-b7c53721525eee1abc6da61f79b3d29c4da815a7.tar.gz
freebsd-ports-gnome-b7c53721525eee1abc6da61f79b3d29c4da815a7.tar.zst
freebsd-ports-gnome-b7c53721525eee1abc6da61f79b3d29c4da815a7.zip
- Fix bug which prevents chef-client to run when the terminal used to launch it
is closed. PR: 190068 Submitted by: Renaud Chaput <renchap@cocoa-x.com> Approved by: maintainer timeout (nickdewing@gmail.com, >2 weeks)
Diffstat (limited to 'devel')
-rw-r--r--devel/rubygem-mixlib-shellout/Makefile1
-rw-r--r--devel/rubygem-mixlib-shellout/files/patch-lib__mixlib__shellout__unix.rb11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/rubygem-mixlib-shellout/Makefile b/devel/rubygem-mixlib-shellout/Makefile
index a010ae1641d4..74c72798b4eb 100644
--- a/devel/rubygem-mixlib-shellout/Makefile
+++ b/devel/rubygem-mixlib-shellout/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mixlib-shellout
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-mixlib-shellout/files/patch-lib__mixlib__shellout__unix.rb b/devel/rubygem-mixlib-shellout/files/patch-lib__mixlib__shellout__unix.rb
new file mode 100644
index 000000000000..81cda3b94bb8
--- /dev/null
+++ b/devel/rubygem-mixlib-shellout/files/patch-lib__mixlib__shellout__unix.rb
@@ -0,0 +1,11 @@
+--- lib/mixlib/shellout/unix.rb.bak 2014-05-21 13:10:28.670548925 +0200
++++ lib/mixlib/shellout/unix.rb 2014-05-21 13:10:40.484660467 +0200
+@@ -222,7 +222,7 @@
+ # the ulimit based on platform.
+ def clean_parent_file_descriptors
+ # Don't clean $stdin, $stdout, $stderr, process_status_pipe.
+- 3.upto(256) do |n|
++ 9.upto(256) do |n|
+ # We are checking the fd for error pipe before attempting to
+ # create a file because error pipe will auto close when we
+ # try to create a file since it's set to CLOEXEC.