aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /devel
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'devel')
-rw-r--r--devel/imake/Makefile29
-rw-r--r--devel/imake/files/patch-imakemdep.h11
-rw-r--r--devel/imake/files/patch-xmkmf.cpp11
-rw-r--r--devel/xxgdb/Makefile14
4 files changed, 33 insertions, 32 deletions
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index a91239b35550..0303445688e8 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -3,28 +3,27 @@
PORTNAME= imake
PORTVERSION= 1.0.5
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MAINTAINER= x11@FreeBSD.org
COMMENT= Imake and other utilities from X.Org
+BUILD_DEPENDS= tradcpp:${PORTSDIR}/devel/tradcpp
RUN_DEPENDS= gccmakedep:${PORTSDIR}/devel/gccmakedep \
makedepend:${PORTSDIR}/devel/makedepend \
${LOCALBASE}/lib/X11/config/xorg.cf:${PORTSDIR}/x11/xorg-cf-files
-USE_PERL5= yes
+USES= shebangfix
+USE_PERL5_RUN= yes
+
+SHEBANG_FILES= mkhtmlindex.pl
XORG_CAT= util
USE_XORG= xproto
-# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
-# which is fatal for imake.
-CPPFLAGS+= -DDEFAULT_CC=\\\"gcc\\\"
-
-.ifdef USE_IMAKE
-.error You have `USE_IMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
+CONFIGURE_ENV= ac_cv_path_RAWCPP=tradcpp
MAN1= ccmakedep.1 \
cleanlinks.1 \
@@ -36,16 +35,4 @@ MAN1= ccmakedep.1 \
revpath.1 \
xmkmf.1
-post-patch:
- @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/mkhtmlindex.pl
- @${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' ${WRKSRC}/configure
-
-.include <bsd.port.pre.mk>
-
-# Attempt to force use of GNU cpp, if it is installed as /usr/bin/gcpp.
-.if (${OSVERSION} >= 900506 && ${OSVERSION} < 1000000) || \
- ${OSVERSION} >= 1000010
-CONFIGURE_ENV+= ac_cv_path_RAWCPP="gcpp"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/imake/files/patch-imakemdep.h b/devel/imake/files/patch-imakemdep.h
new file mode 100644
index 000000000000..87a8662f7587
--- /dev/null
+++ b/devel/imake/files/patch-imakemdep.h
@@ -0,0 +1,11 @@
+--- ./imakemdep.h.orig 2012-03-08 06:47:32.000000000 +0100
++++ ./imakemdep.h 2013-06-12 20:22:52.058999526 +0200
+@@ -380,7 +383,7 @@
+ defined(__GNUC__) || defined(__GLIBC__)
+ # ifdef __i386__
+ "-D__i386__",
+-# if defined(__GNUC__) && (__GNUC__ >= 3)
++# if defined(__GNUC__) && (__GNUC__ >= 3) && !defined(__FreeBSD__)
+ "-m32",
+ # endif
+ # endif
diff --git a/devel/imake/files/patch-xmkmf.cpp b/devel/imake/files/patch-xmkmf.cpp
index 94a238332a9f..75e496452af7 100644
--- a/devel/imake/files/patch-xmkmf.cpp
+++ b/devel/imake/files/patch-xmkmf.cpp
@@ -1,5 +1,14 @@
--- xmkmf.cpp.orig 2012-03-08 06:47:32.000000000 +0100
-+++ xmkmf.cpp 2013-03-17 22:53:14.000000000 +0100
++++ xmkmf.cpp 2013-06-28 11:55:04.174394058 +0200
+@@ -8,7 +8,7 @@
+ topdir=
+ curdir=.
+ do_all=
+-imake_defines=
++imake_defines="${IMAKECPPFLAGS}"
+
+ while [ $# -gt 0 ]
+ do
@@ -64,3 +64,12 @@
imake $imake_defines $args
;;
diff --git a/devel/xxgdb/Makefile b/devel/xxgdb/Makefile
index 7affdb25f8a1..c932ac9488c8 100644
--- a/devel/xxgdb/Makefile
+++ b/devel/xxgdb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xxgdb
-# Date created: 2 May 1995
-# Whom: jkh
-#
+# Created by: jkh
# $FreeBSD$
-#
PORTNAME= xxgdb
PORTVERSION= 1.12
@@ -13,14 +9,12 @@ MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= utilities
MAINTAINER= cy@FreeBSD.org
-COMMENT= An X window interface for gdb
+COMMENT= X window interface for gdb
-USE_IMAKE= yes
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xt
MAN1= xxgdb.1
-.include <bsd.port.pre.mk>
-
# This isn't included in the original Imakefile for some reason.
# Yes, I know this will recompile the program every time, but
# we have the cookie anyway and it's much easier this way
@@ -31,4 +25,4 @@ post-build:
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/xxgdbiowin ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>