aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>2010-02-28 15:59:51 +0800
committermax <max@FreeBSD.org>2010-02-28 15:59:51 +0800
commitbcb60f2a61924f2c3d97f3668e52a960fbc72d17 (patch)
treec4c4f18b1d94dd1314c4f41c161eec9bdb2e8f0d /devel
parent6bb390c25c21440fd9b7c0aee5ff878ef2f88c3d (diff)
downloadfreebsd-ports-gnome-bcb60f2a61924f2c3d97f3668e52a960fbc72d17.tar.gz
freebsd-ports-gnome-bcb60f2a61924f2c3d97f3668e52a960fbc72d17.tar.zst
freebsd-ports-gnome-bcb60f2a61924f2c3d97f3668e52a960fbc72d17.zip
Get rid of WITH_APACHE2. Now this port detects which version of Apache
is on the system and defines dependency on appropriate mod_perl. (If no Apache is installed, depends on mod_perl2.) While at it, minor cosmetic change was also made. Approved by: kuriyama Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Log-Dispatch/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
index 8c083dc50efd..44c942feae7a 100644
--- a/devel/p5-Log-Dispatch/Makefile
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -30,7 +30,7 @@ MAN3= Log::Dispatch.3 \
Log::Dispatch::File.3 \
Log::Dispatch::File::Locked.3 \
Log::Dispatch::Handle.3 \
- Log::Dispatch::Null.3 \
+ Log::Dispatch::Null.3 \
Log::Dispatch::Output.3 \
Log::Dispatch::Screen.3 \
Log::Dispatch::Syslog.3
@@ -50,13 +50,19 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
+.include <bsd.port.options.mk>
+
+.if defined(WITH_APACHELOG)
+USE_APACHE= 1.3+
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_APACHELOG)
-.if defined(WITH_APACHE2)
-RUN_DEPENDS+= mod_perl2>=2.0:${PORTSDIR}/www/mod_perl2
-.else
+.if ${APACHE_VERSION} == 13
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
+.else
+RUN_DEPENDS+= mod_perl2>=2.0:${PORTSDIR}/www/mod_perl2
.endif
.endif