aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-02-13 20:13:02 +0800
committerkoobs <koobs@FreeBSD.org>2015-02-13 20:13:02 +0800
commitbd19dbff376a297eabdc723e611f180cc9758ef9 (patch)
tree582932160834f9d65c1edf5652d31ad7c815a74a /devel
parent90c575a6d39f190656c284afd0ad507bec0072cc (diff)
downloadfreebsd-ports-gnome-bd19dbff376a297eabdc723e611f180cc9758ef9.tar.gz
freebsd-ports-gnome-bd19dbff376a297eabdc723e611f180cc9758ef9.tar.zst
freebsd-ports-gnome-bd19dbff376a297eabdc723e611f180cc9758ef9.zip
[NEW] devel/py-pytrie: Pure Python implementation of the trie data structure
A trie is an ordered tree data structure that is used to store a mapping where the keys are sequences, usually strings over an alphabet. In addition to implementing the mapping interface, tries allow finding the items for a given prefix, and vice versa, finding the items whose keys are prefixes of a given key. WWW: https://bitbucket.org/gsakkis/pytrie
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytrie/Makefile20
-rw-r--r--devel/py-pytrie/distinfo2
-rw-r--r--devel/py-pytrie/pkg-descr7
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6fb2df0d8958..d3ba6d946062 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3952,6 +3952,7 @@
SUBDIR += py-pytest-runner
SUBDIR += py-python-statsd
SUBDIR += py-pythonbrew
+ SUBDIR += py-pytrie
SUBDIR += py-pytz
SUBDIR += py-pyutil
SUBDIR += py-pyxml2obj
diff --git a/devel/py-pytrie/Makefile b/devel/py-pytrie/Makefile
new file mode 100644
index 000000000000..bb7d0265391e
--- /dev/null
+++ b/devel/py-pytrie/Makefile
@@ -0,0 +1,20 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pytrie
+PORTVERSION= 0.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyTrie-${PORTVERSION}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Pure Python implementation of the trie data structure
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytrie/distinfo b/devel/py-pytrie/distinfo
new file mode 100644
index 000000000000..915e5b08e670
--- /dev/null
+++ b/devel/py-pytrie/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PyTrie-0.2.tar.gz) = b272021351efadc6757591aac03ed4794bdfd091122204a4673e94bfb66cc500
+SIZE (PyTrie-0.2.tar.gz) = 96378
diff --git a/devel/py-pytrie/pkg-descr b/devel/py-pytrie/pkg-descr
new file mode 100644
index 000000000000..bea2c075aa40
--- /dev/null
+++ b/devel/py-pytrie/pkg-descr
@@ -0,0 +1,7 @@
+A trie is an ordered tree data structure that is used to store a mapping
+where the keys are sequences, usually strings over an alphabet. In
+addition to implementing the mapping interface, tries allow finding the
+items for a given prefix, and vice versa, finding the items whose keys
+are prefixes of a given key.
+
+WWW: https://bitbucket.org/gsakkis/pytrie