aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2008-09-08 17:20:56 +0800
committermat <mat@FreeBSD.org>2008-09-08 17:20:56 +0800
commitbe0d7e5e0bf77924c34bf6c2b94cca11a8e75001 (patch)
tree5b74ffb786295d51152732a546679a52c3327baf /devel
parentef43d2b827f71a3e56bba496842bff9c011642d3 (diff)
downloadfreebsd-ports-gnome-be0d7e5e0bf77924c34bf6c2b94cca11a8e75001.tar.gz
freebsd-ports-gnome-be0d7e5e0bf77924c34bf6c2b94cca11a8e75001.tar.zst
freebsd-ports-gnome-be0d7e5e0bf77924c34bf6c2b94cca11a8e75001.zip
Make it build on amd64.
Pointed out by: pav
Diffstat (limited to 'devel')
-rw-r--r--devel/libphk/Makefile1
-rw-r--r--devel/libphk/files/patch-phk__expr.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/devel/libphk/Makefile b/devel/libphk/Makefile
index cc54e61eff91..e0a5808159aa 100644
--- a/devel/libphk/Makefile
+++ b/devel/libphk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libphk
PORTVERSION= 0.3.20080902
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://phk.freebsd.dk/phkrel/ \
${MASTER_SITE_LOCAL}
diff --git a/devel/libphk/files/patch-phk__expr.c b/devel/libphk/files/patch-phk__expr.c
new file mode 100644
index 000000000000..1552f4182969
--- /dev/null
+++ b/devel/libphk/files/patch-phk__expr.c
@@ -0,0 +1,22 @@
+--- phk_expr.c~ 2008-04-29 18:50:56.000000000 +0000
++++ phk_expr.c 2008-09-08 09:17:19.205920000 +0000
+@@ -52,8 +52,8 @@
+ {
+ if (1)
+ return;
+- fprintf(stderr, "<%*.*s|", e->p - e->b, e->p - e->b, e->b);
+- fprintf(stderr, "%*.*s> %s\n", e->e - e->p, e->e - e->p, e->p, w);
++ fprintf(stderr, "<%*.*s|", (int)(e->p - e->b), (int)(e->p - e->b), e->b);
++ fprintf(stderr, "%*.*s> %s\n", (int)(e->e - e->p), (int)(e->e - e->p), e->p, w);
+ }
+
+ /*
+@@ -289,7 +289,7 @@
+ if (e->err != NULL) {
+ if (errs != NULL)
+ asprintf(errs, "Expression error:\n%s\n%*.*s^ %s\n",
+- e->b, e->p - e->b, e->p - e->b, "", e->err);
++ e->b, (int)(e->p - e->b), (int)(e->p - e->b), "", e->err);
+ return (NAN);
+ }
+ return (v);