aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrian <brian@FreeBSD.org>2008-05-29 02:15:24 +0800
committerbrian <brian@FreeBSD.org>2008-05-29 02:15:24 +0800
commitbe357bf6bf17a86201b1d86e2a13adb79bbcbc4a (patch)
tree3a8ed4461ae928e45d2f0e579a43fda359746ccd /devel
parentc3ebe2f8b408d5ed9520159ebe6577940f11a126 (diff)
downloadfreebsd-ports-gnome-be357bf6bf17a86201b1d86e2a13adb79bbcbc4a.tar.gz
freebsd-ports-gnome-be357bf6bf17a86201b1d86e2a13adb79bbcbc4a.tar.zst
freebsd-ports-gnome-be357bf6bf17a86201b1d86e2a13adb79bbcbc4a.zip
Add jsl - a javascript lint tool.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jsl/Makefile32
-rw-r--r--devel/jsl/distinfo3
-rw-r--r--devel/jsl/pkg-descr20
-rw-r--r--devel/jsl/pkg-plist1
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 692faefb9665..055b03587d71 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -529,6 +529,7 @@
SUBDIR += jline
SUBDIR += jrtplib
SUBDIR += jsap
+ SUBDIR += jsl
SUBDIR += jsmin
SUBDIR += json-c
SUBDIR += jtag
diff --git a/devel/jsl/Makefile b/devel/jsl/Makefile
new file mode 100644
index 000000000000..07b8b157fc26
--- /dev/null
+++ b/devel/jsl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pylint
+# Date created: 28 May 2004
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= jsl
+PORTVERSION= 0.3.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.Awfulhak.org/pub/jsl/ \
+ http://www.javascriptlint.com/download/
+EXTRACT_SUFX= -src.tar.gz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Analyzes javascript code looking for bugs and signs of poor quality
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_GMAKE= yes
+MAKEFILE= Makefile.ref
+
+.include <bsd.port.pre.mk>
+
+JSLCFG!= ${UNAME} -sr | ${SED} 's, ,,'
+
+post-patch:
+ ${LN} -s Linux_All.mk ${WRKSRC}/config/${JSLCFG}.mk
+
+do-install:
+ ${INSTALL} ${WRKSRC}/${JSLCFG}_DBG.OBJ/jsl ${PREFIX}/bin/jsl
+
+.include <bsd.port.post.mk>
diff --git a/devel/jsl/distinfo b/devel/jsl/distinfo
new file mode 100644
index 000000000000..f032a824712c
--- /dev/null
+++ b/devel/jsl/distinfo
@@ -0,0 +1,3 @@
+MD5 (jsl-0.3.0-src.tar.gz) = 2b94ffa4fab07acabe0c5e73cd49bcdf
+SHA256 (jsl-0.3.0-src.tar.gz) = 86f16792d71fc59b96f65eca65b1b7466dc046efe6d5ac04c6632f1315e83cfa
+SIZE (jsl-0.3.0-src.tar.gz) = 924756
diff --git a/devel/jsl/pkg-descr b/devel/jsl/pkg-descr
new file mode 100644
index 000000000000..ef1121a9261c
--- /dev/null
+++ b/devel/jsl/pkg-descr
@@ -0,0 +1,20 @@
+Many JavaScript implementations do not warn against questionable coding
+practices. Yes, that's nice for the site that "works best with Internet
+Explorer" (designed with templates, scripted with snippets copied from
+forums). But it's a nightmare when you actually want to write quality,
+maintainable code.
+
+That's where JavaScript Lint comes in. With JavaScript Lint, you can
+check all your JavaScript source code for common mistakes without actually
+running the script or opening the web page.
+
+JavaScript Lint holds an advantage over competing lints because it is
+based on the JavaScript engine for the Firefox browser. This provides
+a robust framework that can not only check JavaScript syntax but also
+examine the coding techniques used in the script and warn against
+questionable practices.
+
+WWW: http://www.javascriptlint.com/
+
+- Brian Somers
+brian@FreeBSD.org
diff --git a/devel/jsl/pkg-plist b/devel/jsl/pkg-plist
new file mode 100644
index 000000000000..a6e6f9e994a0
--- /dev/null
+++ b/devel/jsl/pkg-plist
@@ -0,0 +1 @@
+bin/jsl