aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2016-11-08 04:45:29 +0800
committerjoerg <joerg@FreeBSD.org>2016-11-08 04:45:29 +0800
commitbf5f70d54c3a9aa47ccee7ecb73a517a7ed363d4 (patch)
treebfcbcd4d4a057b1256a7d10509f3139130a806f4 /devel
parent3d4599ed801ac243f64d6f34a7d60c0c24cfb43c (diff)
downloadfreebsd-ports-gnome-bf5f70d54c3a9aa47ccee7ecb73a517a7ed363d4.tar.gz
freebsd-ports-gnome-bf5f70d54c3a9aa47ccee7ecb73a517a7ed363d4.tar.zst
freebsd-ports-gnome-bf5f70d54c3a9aa47ccee7ecb73a517a7ed363d4.zip
bcc only works in 32-bit mode, so force it.
Diffstat (limited to 'devel')
-rw-r--r--devel/bcc/Makefile1
-rw-r--r--devel/bcc/files/patch-as2
-rw-r--r--devel/bcc/files/patch-bcc2
-rw-r--r--devel/bcc/files/patch-ld2
4 files changed, 4 insertions, 3 deletions
diff --git a/devel/bcc/Makefile b/devel/bcc/Makefile
index ce184d7aab3f..f5b89090a9ef 100644
--- a/devel/bcc/Makefile
+++ b/devel/bcc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bcc
PORTVERSION= 1995.03.12
+PORTREVISION= 1
CATEGORIES= devel lang
DISTNAME= ${PORTNAME}
diff --git a/devel/bcc/files/patch-as b/devel/bcc/files/patch-as
index 95942d9d7fc1..9ec06c5334cc 100644
--- a/devel/bcc/files/patch-as
+++ b/devel/bcc/files/patch-as
@@ -5,7 +5,7 @@
+.include "../Makefile.inc"
+.PATH: ../ld
+
-+CFLAGS +=-Wall
++CFLAGS +=-Wall -m32
LDFLAGS =
-OBJS =as.o assemble.o error.o express.o \
diff --git a/devel/bcc/files/patch-bcc b/devel/bcc/files/patch-bcc
index 9d7af912e392..aa9293648891 100644
--- a/devel/bcc/files/patch-bcc
+++ b/devel/bcc/files/patch-bcc
@@ -4,7 +4,7 @@
-CFLAGS =-O -DNSIG=32
+.include "../Makefile.inc"
+
-+CFLAGS +=-DNSIG=32
++CFLAGS +=-DNSIG=32 -m32
+#CFLAGS +=-Wall # too many warnings
LDFLAGS =
diff --git a/devel/bcc/files/patch-ld b/devel/bcc/files/patch-ld
index 33312814ca2e..c243ff2faf31 100644
--- a/devel/bcc/files/patch-ld
+++ b/devel/bcc/files/patch-ld
@@ -7,7 +7,7 @@
-OBJS =dumps.o io.o ld.o readobj.o table.o typeconv.o writebin.o
+CFLAGS +=-DBSD_A_OUT -DSTANDARD_GNU_A_OUT
-+CFLAGS +=-Wall
++CFLAGS +=-Wall -m32
+LDFLAGS =
-ld: $(OBJS)