aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-04-22 19:06:18 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-04-22 19:06:18 +0800
commitc05eb4e41cace4caf3832c27c6ac878e294e7689 (patch)
tree9337dcfb392ba9568b177bc8fbcdb04ebfe4822c /devel
parenta7d4edf327e1bc212debf0b9b4025d5db9623674 (diff)
downloadfreebsd-ports-gnome-c05eb4e41cace4caf3832c27c6ac878e294e7689.tar.gz
freebsd-ports-gnome-c05eb4e41cace4caf3832c27c6ac878e294e7689.tar.zst
freebsd-ports-gnome-c05eb4e41cace4caf3832c27c6ac878e294e7689.zip
- Simplify MASTER_SITES
- Add LICENSE_FILE - Fix hidden dependency and optionize libftdi support PR: 195866 Approved by: maintainer timeout (joerg, 4 months)
Diffstat (limited to 'devel')
-rw-r--r--devel/avrdude/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/devel/avrdude/Makefile b/devel/avrdude/Makefile
index 2116c84109d3..a09a3fa4bf49 100644
--- a/devel/avrdude/Makefile
+++ b/devel/avrdude/Makefile
@@ -3,18 +3,32 @@
PORTNAME= avrdude
PORTVERSION= 6.1
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= avrdude
+MASTER_SITES= SAVANNAH/avrdude
MAINTAINER= joerg@FreeBSD.org
COMMENT= Program for programming the on-chip memory of Atmel AVR CPUs
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= FTDI
+OPTIONS_DEFAULT= FTDI
+FTDI_DESC= libftdi support
+FTDI_LIB_DEPENDS= libftdi1.so:${PORTSDIR}/devel/libftdi1
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lusb-1.0|-lusb|g' ${WRKSRC}/configure
+.if ! ${PORT_OPTIONS:MFTDI}
+ @${REINPLACE_CMD} -e '/LIBS=/ s|-lftdi1*|&-do-not-detect|' ${WRKSRC}/configure
+.endif
+
.include <bsd.port.mk>