aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-17 07:55:03 +0800
committerpav <pav@FreeBSD.org>2005-03-17 07:55:03 +0800
commitc0b60c2259544e50129897161f1353f05d54231d (patch)
tree0f9df6142d88d6ce6cb171833e5aa44204e73f88 /devel
parent39058b36f5ac45215dfbe1776ad9b4f437d04c3a (diff)
downloadfreebsd-ports-gnome-c0b60c2259544e50129897161f1353f05d54231d.tar.gz
freebsd-ports-gnome-c0b60c2259544e50129897161f1353f05d54231d.tar.zst
freebsd-ports-gnome-c0b60c2259544e50129897161f1353f05d54231d.zip
New port: devel/pear-Event_Dispatcher PEAR dispatch notifications using PHP callbacks
The Event_Dispatcher acts as a notification dispatch table. It is used to notify other objects of interesting things. This information is encapsulated in Event_Notification objects. Client objects register themselves with the Event_Dispatcher as observers of specific notifications posted by other objects. When an event occurs, an object posts an appropriate notification to the Event_Dispatcher. The Event_Dispatcher dispatches a message to each registered observer, passing the notification as the sole argument. PR: ports/78889 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-Event_Dispatcher/Makefile32
-rw-r--r--devel/pear-Event_Dispatcher/distinfo2
-rw-r--r--devel/pear-Event_Dispatcher/pkg-descr10
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5b51b3b4c294..3c158aa7b266 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1136,6 +1136,7 @@
SUBDIR += pear-Console_Getopt
SUBDIR += pear-Console_Table
SUBDIR += pear-Date
+ SUBDIR += pear-Event_Dispatcher
SUBDIR += pear-FSM
SUBDIR += pear-HTML_BBCodeParser
SUBDIR += pear-HTML_Common
diff --git a/devel/pear-Event_Dispatcher/Makefile b/devel/pear-Event_Dispatcher/Makefile
new file mode 100644
index 000000000000..9f0c1c51a52a
--- /dev/null
+++ b/devel/pear-Event_Dispatcher/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pear-Event_Dispatcher
+# Date created: 15 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Event_Dispatcher
+PORTVERSION= 0.9.1
+CATEGORIES= devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR dispatch notifications using PHP callbacks
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_REINPLACE= yes
+
+CATEGORY= Event
+FILES= Dispatcher.php Notification.php
+EXAMPLES= bubbling.php cancel.php notification-class.php object.php
+TESTS= Console_TestListener.php Dispatcher_testcase.php test.php
+
+post-extract:
+.for file in ${FILES}
+ @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|" ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Event_Dispatcher/distinfo b/devel/pear-Event_Dispatcher/distinfo
new file mode 100644
index 000000000000..f461a6b8a23b
--- /dev/null
+++ b/devel/pear-Event_Dispatcher/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Event_Dispatcher-0.9.1.tgz) = 975cab848349c5e190ff773b107796c0
+SIZE (PEAR/Event_Dispatcher-0.9.1.tgz) = 7898
diff --git a/devel/pear-Event_Dispatcher/pkg-descr b/devel/pear-Event_Dispatcher/pkg-descr
new file mode 100644
index 000000000000..7352be1a8f14
--- /dev/null
+++ b/devel/pear-Event_Dispatcher/pkg-descr
@@ -0,0 +1,10 @@
+The Event_Dispatcher acts as a notification dispatch table.
+It is used to notify other objects of interesting things. This
+information is encapsulated in Event_Notification objects. Client
+objects register themselves with the Event_Dispatcher as observers of
+specific notifications posted by other objects. When an event occurs,
+an object posts an appropriate notification to the Event_Dispatcher.
+The Event_Dispatcher dispatches a message to each registered
+observer, passing the notification as the sole argument.
+
+WWW: http://pear.php.net/package/Event_Dispatcher/