aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-05 22:07:22 +0800
committerwen <wen@FreeBSD.org>2010-03-05 22:07:22 +0800
commitc1127cd4cde8b19fa73995d10dceb54743abb966 (patch)
treeb9f08ac1f6643928ef1433f2453566c763b362d8 /devel
parentb50418c485c9df476797f9e86bd3d178b798c1fb (diff)
downloadfreebsd-ports-gnome-c1127cd4cde8b19fa73995d10dceb54743abb966.tar.gz
freebsd-ports-gnome-c1127cd4cde8b19fa73995d10dceb54743abb966.tar.zst
freebsd-ports-gnome-c1127cd4cde8b19fa73995d10dceb54743abb966.zip
autobox::CORE defines methods for core operations such as join,
print, most everything in perlfunc, some things from Scalar::Util and List::Util, and some Perl 5 versions of methods taken from Perl6. These methods expose as methods the built-in functions for minipulating numbers, strings, arrays, hashes, and code references. It can be handy to use built-in functions as methods to avoid messy dereferencing syntaxes and parentheses pile ups. WWW: http://search.cpan.org/dist/autobox-Core/ Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-autobox-Core/Makefile24
-rw-r--r--devel/p5-autobox-Core/distinfo3
-rw-r--r--devel/p5-autobox-Core/pkg-descr12
-rw-r--r--devel/p5-autobox-Core/pkg-plist5
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 460412f1d466..dbd7e6f2867e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2222,6 +2222,7 @@
SUBDIR += p5-accessors
SUBDIR += p5-aliased
SUBDIR += p5-autobox
+ SUBDIR += p5-autobox-Core
SUBDIR += p5-autodie
SUBDIR += p5-base
SUBDIR += p5-boolean
diff --git a/devel/p5-autobox-Core/Makefile b/devel/p5-autobox-Core/Makefile
new file mode 100644
index 000000000000..975869ed0863
--- /dev/null
+++ b/devel/p5-autobox-Core/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-autobox-Core
+# Date created: 5th March, 2010
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autobox-Core
+PORTVERSION= 0.7
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Core functions exposed as methods in primitive types
+
+BUILD_DEPENDS= p5-autobox>=0:${PORTSDIR}/devel/p5-autobox
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= autobox::Core.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-autobox-Core/distinfo b/devel/p5-autobox-Core/distinfo
new file mode 100644
index 000000000000..b1c3aecd3b56
--- /dev/null
+++ b/devel/p5-autobox-Core/distinfo
@@ -0,0 +1,3 @@
+MD5 (autobox-Core-0.7.tar.gz) = 418fa669c855031a9ec8ea156bfe687b
+SHA256 (autobox-Core-0.7.tar.gz) = 4face53df5ecf18765aa9379d1c7d8c81e6d5b42ad2f6d05be9a9354eaeb3d6b
+SIZE (autobox-Core-0.7.tar.gz) = 23962
diff --git a/devel/p5-autobox-Core/pkg-descr b/devel/p5-autobox-Core/pkg-descr
new file mode 100644
index 000000000000..f1faa5731245
--- /dev/null
+++ b/devel/p5-autobox-Core/pkg-descr
@@ -0,0 +1,12 @@
+autobox::CORE defines methods for core operations such as join,
+print, most everything in perlfunc, some things from Scalar::Util
+and List::Util, and some Perl 5 versions of methods taken from
+Perl6.
+
+These methods expose as methods the built-in functions for
+minipulating numbers, strings, arrays, hashes, and code references.
+
+It can be handy to use built-in functions as methods to avoid messy
+dereferencing syntaxes and parentheses pile ups.
+
+WWW: http://search.cpan.org/dist/autobox-Core/
diff --git a/devel/p5-autobox-Core/pkg-plist b/devel/p5-autobox-Core/pkg-plist
new file mode 100644
index 000000000000..9bfe8ffca63e
--- /dev/null
+++ b/devel/p5-autobox-Core/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/autobox/Core.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/autobox/Core/.packlist
+@dirrmtry %%SITE_PERL%%/autobox
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/autobox/Core
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/autobox