aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-06-23 03:42:06 +0800
committerlofi <lofi@FreeBSD.org>2004-06-23 03:42:06 +0800
commitc11712bb477a4a0a2f73720e60ae6bc59207c9e5 (patch)
tree3dddfbf92ebf32772b429c55b8fb695200b9a0f1 /devel
parent840401d0d2f82c8156e029e6ec55aadcd192f32c (diff)
downloadfreebsd-ports-gnome-c11712bb477a4a0a2f73720e60ae6bc59207c9e5.tar.gz
freebsd-ports-gnome-c11712bb477a4a0a2f73720e60ae6bc59207c9e5.tar.zst
freebsd-ports-gnome-c11712bb477a4a0a2f73720e60ae6bc59207c9e5.zip
Remove inclusion of Makefile.kde from all remaining ports not maintained
by kde@ Approved by: maintainer timeout
Diffstat (limited to 'devel')
-rw-r--r--devel/kscope/Makefile8
-rw-r--r--devel/kscope/files/patch-src_Makefile.in11
2 files changed, 14 insertions, 5 deletions
diff --git a/devel/kscope/Makefile b/devel/kscope/Makefile
index dbef57d5f591..521a894de677 100644
--- a/devel/kscope/Makefile
+++ b/devel/kscope/Makefile
@@ -28,9 +28,7 @@ MAKE_ENV= EXTRA_LIBRARIES="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--with-extra-includes=${LOCALBASE}/include \
--with-extra-libs=${LOCALBASE}/lib
-pre-build:
- ${REINPLACE_CMD} "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/kscope/files/patch-src_Makefile.in b/devel/kscope/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..269191c9ff37
--- /dev/null
+++ b/devel/kscope/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Tue Jun 22 17:58:35 2004
++++ src/Makefile.in Tue Jun 22 18:01:18 2004
+@@ -277,7 +277,7 @@
+ #>+ 1
+ kscope_SOURCES=main.cpp kscope.cpp calltreedlg.cpp calltreedlg.h cscopefrontend.cpp cscopefrontend.h ctagsfrontend.cpp ctagsfrontend.h ctagslist.cpp ctagslist.h dirscanner.cpp dirscanner.h editormanager.cpp editormanager.h editorpage.cpp editorpage.h editortabs.cpp editortabs.h filelist.cpp filelist.h frontend.cpp frontend.h kscopeconfig.cpp kscopeconfig.h kscope.h kscopepixmaps.cpp kscopepixmaps.h newprojectdlg.cpp newprojectdlg.h openprojectdlg.cpp openprojectdlg.h prefcolor.cpp prefcolor.h preferencesdlg.cpp preferencesdlg.h preffrontend.cpp preffrontend.h progressdlg.cpp progressdlg.h projectfilesdlg.cpp projectfilesdlg.h projectmanager.cpp projectmanager.h querypage.cpp querypage.h querywidget.cpp querywidget.h scanprogressdlg.cpp scanprogressdlg.h searchlist.cpp searchlist.h tabwidget.cpp tabbar.cpp cscopemsgdlg.cpp positionhistory.cpp positionhistorydlg.cpp calltreelayout.cpp newprojectlayout.cpp openprojectlayout.cpp prefcolorlayout.cpp preffrontendlayout.cpp projectfileslayout.cpp scanprogresslayout.cpp cscopemsglayout.cpp positionhistorylayout.cpp
+ kscope_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+-kscope_LDADD = -lktexteditor $(LIB_KDEUI)
++kscope_LDADD = -lktexteditor $(LIB_KDEUI) $(LIBPTHREAD)
+
+ # this is where the desktop file will go
+ shelldesktopdir = $(kde_appsdir)/Utilities