aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-24 06:09:02 +0800
committerkris <kris@FreeBSD.org>2004-02-24 06:09:02 +0800
commitc13b90d6007f10c1ec5b04bdd8e5916d07a50b33 (patch)
treeb3e28a2890a6a8904351dd47309faf9b52c180d2 /devel
parent86b4ec16f981bc08f711e9ccdbc31aedea79a58d (diff)
downloadfreebsd-ports-gnome-c13b90d6007f10c1ec5b04bdd8e5916d07a50b33.tar.gz
freebsd-ports-gnome-c13b90d6007f10c1ec5b04bdd8e5916d07a50b33.tar.zst
freebsd-ports-gnome-c13b90d6007f10c1ec5b04bdd8e5916d07a50b33.zip
BROKEN on !i386 and !ia64: Does not compile
Diffstat (limited to 'devel')
-rw-r--r--devel/mingw32-gcc/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index a70e7f420eb4..4eb954d11382 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -69,6 +69,12 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} GCC_TARG=${PKGNAMEPREFIX:S/-$//} \
BINARIES= gcc cpp g++ g77 gcov gcj gcjh jcf-dump jv-scan grepjar jar
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "ia64"
+BROKEN= "Does not compile on !i386 and !ia64"
+.endif
+
post-configure:
@${PERL} -pi.bak -e 's,^(TARGET_CONFIGDIRS\s*=\s*).+$$,\1libstdc++-v3 libf2c libobjc mingw,' ${WRKSRC}/Makefile
@${PERL} -pi.bak -e 's,^(install-info:),\1\ndonot-\1,' ${WRKSRC}/gcc/Makefile
@@ -80,4 +86,4 @@ post-install:
${PREFIX}/${PKGNAMEPREFIX:S/-$//}/bin/$F
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>