aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2015-05-16 18:55:28 +0800
committerjohans <johans@FreeBSD.org>2015-05-16 18:55:28 +0800
commitc21e360c0ee3617260a472590e5c46022cc093cd (patch)
treeed111184dbe1a70e878a5781b5f45e10de4c0ae8 /devel
parentdbdbb13c6fb8e6339930157a4a59cbd3f9e456a8 (diff)
downloadfreebsd-ports-gnome-c21e360c0ee3617260a472590e5c46022cc093cd.tar.gz
freebsd-ports-gnome-c21e360c0ee3617260a472590e5c46022cc093cd.tar.zst
freebsd-ports-gnome-c21e360c0ee3617260a472590e5c46022cc093cd.zip
- Update ocaml-lwt to 2.4.8, now from Github
- Disable react support (broken) - Adopt port
Diffstat (limited to 'devel')
-rw-r--r--devel/ocaml-lwt/Makefile36
-rw-r--r--devel/ocaml-lwt/distinfo4
-rw-r--r--devel/ocaml-lwt/files/patch-src_unix_lwt__unix.ml15
-rw-r--r--devel/ocaml-lwt/files/patch-src_unix_lwt__unix.mli15
4 files changed, 14 insertions, 56 deletions
diff --git a/devel/ocaml-lwt/Makefile b/devel/ocaml-lwt/Makefile
index f1cfd0a12570..4a904ee5901f 100644
--- a/devel/ocaml-lwt/Makefile
+++ b/devel/ocaml-lwt/Makefile
@@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= lwt
-PORTVERSION= 2.4.3
-PORTREVISION= 2
+PORTVERSION= 2.4.8
CATEGORIES= devel
-MASTER_SITES= http://ocsigen.org/download/
PKGNAMEPREFIX= ocaml-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@stack.nl
COMMENT= Cooperative threading library for OCaml
+USE_GITHUB= yes
+GH_ACCOUNT= ocsigen
+
LICENSE= LGPL21
-BUILD_DEPENDS= ${SA_DIR}/react/react.a:${PORTSDIR}/devel/ocaml-react \
- ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-RUN_DEPENDS= ${SA_DIR}/react/react.a:${PORTSDIR}/devel/ocaml-react \
- ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+BUILD_DEPENDS= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+RUN_DEPENDS= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
MAKE_JOBS_UNSAFE= yes
@@ -31,28 +30,17 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= --destdir "${STAGEDIR}" \
--prefix "${PREFIX}" \
--enable-ssl \
- --enable-react \
+ --disable-react \
--disable-libev \
--disable-glib
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
-OPTIONS_DEFINE= TOPLEVEL DOCS
-OPTIONS_DEFAULT= TOPLEVEL
-TOPLEVEL_DESC= Include enhanced OCaml toplevel
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MTOPLEVEL}
-CONFIGURE_ARGS+= --enable-toplevel --enable-text
-BUILD_DEPENDS+= ${SA_DIR}/text/text.a:${PORTSDIR}/textproc/ocaml-text
-RUN_DEPENDS+= ${SA_DIR}/text/text.a:${PORTSDIR}/textproc/ocaml-text
-PLIST_FILES= bin/lwt-toplevel
-.else
-CONFIGURE_ARGS+= --disable-toplevel --disable-text
-.endif
-
.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --enable-docs --docdir ${STAGEDIR}${DOCSDIR}
# For some reason, ocaml-text is needed when building documentation
@@ -67,15 +55,15 @@ post-patch:
${WRKSRC}/setup.ml
do-configure:
- (cd ${WRKSRC}; ocaml setup.ml -configure ${CONFIGURE_ARGS})
+ cd ${WRKSRC}; ocaml setup.ml -configure ${CONFIGURE_ARGS}
@${REINPLACE_CMD} -e 's%"-lev"%"-lev -L${PREFIX}/lib/ev -Wl,-R${PREFIX}/lib/ev"%' \
${WRKSRC}/setup.data
do-build:
- (cd ${WRKSRC}; ocaml setup.ml -build)
+ cd ${WRKSRC}; ocaml setup.ml -build
do-install:
${MKDIR} ${STAGEDIR}${SA_DIR}
- (cd ${WRKSRC}; ocaml setup.ml -install)
+ cd ${WRKSRC}; ocaml setup.ml -install
.include <bsd.port.mk>
diff --git a/devel/ocaml-lwt/distinfo b/devel/ocaml-lwt/distinfo
index 56ba3f1140af..1a0a3525d497 100644
--- a/devel/ocaml-lwt/distinfo
+++ b/devel/ocaml-lwt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lwt-2.4.3.tar.gz) = efee23937750290d6dee96eed6c0bbdb19817d5be6eefcba61ac5031fac10107
-SIZE (lwt-2.4.3.tar.gz) = 504000
+SHA256 (ocsigen-lwt-2.4.8_GH0.tar.gz) = cada92a1c7ce9c678adc67dfa0a8c51f582358e99bbe839ece2decd6866cfa38
+SIZE (ocsigen-lwt-2.4.8_GH0.tar.gz) = 262232
diff --git a/devel/ocaml-lwt/files/patch-src_unix_lwt__unix.ml b/devel/ocaml-lwt/files/patch-src_unix_lwt__unix.ml
deleted file mode 100644
index a73d0da95021..000000000000
--- a/devel/ocaml-lwt/files/patch-src_unix_lwt__unix.ml
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-src_unix_lwt_unix.ml,v 1.1 2013/11/01 10:50:03 jaapb Exp $
-
-Patch (from upstream git) to compile with ocaml 4.01
---- src/unix/lwt_unix.ml.orig 2012-12-27 12:29:57.000000000 +0000
-+++ src/unix/lwt_unix.ml
-@@ -596,6 +596,9 @@ type open_flag =
- #if ocaml_version >= (3, 13)
- | O_SHARE_DELETE
- #endif
-+#if ocaml_version >= (4, 01)
-+ | O_CLOEXEC
-+#endif
-
- #if windows
-
diff --git a/devel/ocaml-lwt/files/patch-src_unix_lwt__unix.mli b/devel/ocaml-lwt/files/patch-src_unix_lwt__unix.mli
deleted file mode 100644
index 1d87c89ced22..000000000000
--- a/devel/ocaml-lwt/files/patch-src_unix_lwt__unix.mli
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-src_unix_lwt_unix.mli,v 1.1 2013/11/01 10:50:03 jaapb Exp $
-
-Patch (from upstream git) to compile with ocaml 4.01
---- src/unix/lwt_unix.mli.orig 2012-12-27 12:29:57.000000000 +0000
-+++ src/unix/lwt_unix.mli
-@@ -315,6 +315,9 @@ type open_flag =
- #if ocaml_version >= (3, 13)
- | O_SHARE_DELETE
- #endif
-+#if ocaml_version >= (4, 01)
-+ | O_CLOEXEC
-+#endif
-
- val openfile : string -> open_flag list -> file_perm -> file_descr Lwt.t
- (** Wrapper for [Unix.openfile]. *)