aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-10-12 20:46:56 +0800
committerkrion <krion@FreeBSD.org>2004-10-12 20:46:56 +0800
commitc23a7b869f7de9b830d5744c11d5e7744f4ad1d7 (patch)
tree8ff9421c9c3cd316f391162f6c0f24145e431761 /devel
parent0a618dd516eded04ad007660eba3f7e3bb2a0e48 (diff)
downloadfreebsd-ports-gnome-c23a7b869f7de9b830d5744c11d5e7744f4ad1d7.tar.gz
freebsd-ports-gnome-c23a7b869f7de9b830d5744c11d5e7744f4ad1d7.tar.zst
freebsd-ports-gnome-c23a7b869f7de9b830d5744c11d5e7744f4ad1d7.zip
Update to version 3.8.2
PR: ports/72525 Submitted by: Ports Fury
Diffstat (limited to 'devel')
-rw-r--r--devel/codeworker/Makefile25
-rw-r--r--devel/codeworker/distinfo4
-rw-r--r--devel/codeworker/files/patch-DtaPatternScript.h10
-rw-r--r--devel/codeworker/files/patch-ScpStream.h11
4 files changed, 14 insertions, 36 deletions
diff --git a/devel/codeworker/Makefile b/devel/codeworker/Makefile
index e4cbc640746d..912de35277a0 100644
--- a/devel/codeworker/Makefile
+++ b/devel/codeworker/Makefile
@@ -7,22 +7,23 @@
#
PORTNAME= codeworker
-PORTVERSION= 3.3
-PORTREVISION= 1
+PORTVERSION= 3.8.2
CATEGORIES= devel
MASTER_SITES= http://codeworker.free.fr/downloads/
-DISTNAME= CodeWorker_SRC${PORTVERSION:S/./_/}
+DISTNAME= CodeWorker_SRC${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
COMMENT= A parsing tool and a source code generator
-PLIST_FILES= bin/codeworker
+EXTRACT_BEFORE_ARGS= -qo -aa
+
+WRKSRC= ${WRKDIR}/CodeWorker${PORTVERSION:S/./_/g}
+
USE_ZIP= yes
-USE_REINPLACE= yes
-NO_WRKSUBDIR= yes
-LDFLAGS+= -lcompat
USE_GMAKE= yes
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
+MAKE_ARGS= CC="${CXX}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" LFLAGS="-lm"
+
+PLIST_FILES= bin/codeworker
.include <bsd.port.pre.mk>
@@ -30,11 +31,9 @@ MAKE_ENV= LDFLAGS="${LDFLAGS}"
BROKEN= "Does not compile on !i386"
.endif
-post-patch:
- @${REINPLACE_CMD} -e "s|^CXXFLAGS|#CXXFLAGS|g" \
- -e s"|LFLAGS|LDFLAGS|" -e "s|^LDFLAGS|#LDFLAGS|" \
- -e "s|CC|CXX|g" -e "s|^CXX|#CXX|g" ${WRKSRC}/Makefile
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s| ||"
+.if ${OSVERSION} < 500035
+CFLAGS+= -fpermissive
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/codeworker ${PREFIX}/bin
diff --git a/devel/codeworker/distinfo b/devel/codeworker/distinfo
index 0c0538c0a09d..13c105a4be4d 100644
--- a/devel/codeworker/distinfo
+++ b/devel/codeworker/distinfo
@@ -1,2 +1,2 @@
-MD5 (CodeWorker_SRC3_3.zip) = 1a2d88de860652e46356ba37bf9ea341
-SIZE (CodeWorker_SRC3_3.zip) = 1982777
+MD5 (CodeWorker_SRC3_8_2.zip) = c7294abc279b3e4990e460770ff22698
+SIZE (CodeWorker_SRC3_8_2.zip) = 1659058
diff --git a/devel/codeworker/files/patch-DtaPatternScript.h b/devel/codeworker/files/patch-DtaPatternScript.h
deleted file mode 100644
index 700404749e3e..000000000000
--- a/devel/codeworker/files/patch-DtaPatternScript.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- DtaPatternScript.h.orig Sun Jan 25 21:36:50 2004
-+++ DtaPatternScript.h Sun Jan 25 21:40:17 2004
-@@ -24,6 +24,7 @@
-
- #include "DtaScript.h"
- #include <map>
-+#include <memory>
-
- namespace CodeWorker {
- #ifndef EXECUTE_FUNCTION_TYPE
diff --git a/devel/codeworker/files/patch-ScpStream.h b/devel/codeworker/files/patch-ScpStream.h
deleted file mode 100644
index 893bce5698b4..000000000000
--- a/devel/codeworker/files/patch-ScpStream.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ScpStream.h.orig Sun Jan 25 21:34:17 2004
-+++ ScpStream.h Sun Jan 25 21:34:40 2004
-@@ -34,6 +34,8 @@
- #include <map>
- #include <set>
-
-+#include <ctime>
-+
- namespace CodeWorker {
-
- #ifdef IN