aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-10 02:11:17 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-10 02:11:17 +0800
commitc2d27103a5fcdb799effb4414eace246cbf3f626 (patch)
treecadcd671cc34925b37fee27aed5282c51e84aa79 /devel
parent6cf018c408c7ac014aee8c8cc42ef50b88677020 (diff)
downloadfreebsd-ports-gnome-c2d27103a5fcdb799effb4414eace246cbf3f626.tar.gz
freebsd-ports-gnome-c2d27103a5fcdb799effb4414eace246cbf3f626.tar.zst
freebsd-ports-gnome-c2d27103a5fcdb799effb4414eace246cbf3f626.zip
New port: devel/py-pytest-pycodestyle: Pytest plugin to run pycodestyle
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-pycodestyle/Makefile23
-rw-r--r--devel/py-pytest-pycodestyle/distinfo3
-rw-r--r--devel/py-pytest-pycodestyle/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5b721ae3418c..4cbc78d28571 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4934,6 +4934,7 @@
SUBDIR += py-pytest-flakes
SUBDIR += py-pytest-localserver
SUBDIR += py-pytest-mock
+ SUBDIR += py-pytest-pycodestyle
SUBDIR += py-pytest-runner
SUBDIR += py-pytest-sugar
SUBDIR += py-pytest-timeout
diff --git a/devel/py-pytest-pycodestyle/Makefile b/devel/py-pytest-pycodestyle/Makefile
new file mode 100644
index 000000000000..e3217afe1a41
--- /dev/null
+++ b/devel/py-pytest-pycodestyle/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= pytest-pycodestyle
+DISTVERSION= 1.3.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pytest plugin to run pycodestyle
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py>=1.5:devel/py-py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycodestyle>=2.3:devel/py-pycodestyle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=3.0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-pycodestyle/distinfo b/devel/py-pytest-pycodestyle/distinfo
new file mode 100644
index 000000000000..18df04175b9d
--- /dev/null
+++ b/devel/py-pytest-pycodestyle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536516086
+SHA256 (pytest-pycodestyle-1.3.0.tar.gz) = ebaddf3e31f281ae7e7f45c30840b2d7fdf1aa7a058f2e29e4ba55460c407bec
+SIZE (pytest-pycodestyle-1.3.0.tar.gz) = 3788
diff --git a/devel/py-pytest-pycodestyle/pkg-descr b/devel/py-pytest-pycodestyle/pkg-descr
new file mode 100644
index 000000000000..771470f07807
--- /dev/null
+++ b/devel/py-pytest-pycodestyle/pkg-descr
@@ -0,0 +1,3 @@
+pytest plugin to run pycodestyle, Python style guide checker.
+
+WWW: https://github.com/henry0312/pytest-codestyle