aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-26 16:15:37 +0800
committerKris Kennaway <kris@FreeBSD.org>2004-02-26 16:15:37 +0800
commitc3b76a8c77468cf227da1c96cc28c699334be8d4 (patch)
tree6c3f2f44990b1a5f15a32fff781d1687351b655c /devel
parentfbf92c51dcca1209d1832d45bdd468ec2ed24980 (diff)
downloadfreebsd-ports-gnome-c3b76a8c77468cf227da1c96cc28c699334be8d4.tar.gz
freebsd-ports-gnome-c3b76a8c77468cf227da1c96cc28c699334be8d4.tar.zst
freebsd-ports-gnome-c3b76a8c77468cf227da1c96cc28c699334be8d4.zip
BROKEN on !i386: Does not compile
Diffstat (limited to 'devel')
-rw-r--r--devel/clanlib-devel/Makefile4
-rw-r--r--devel/erlslang/Makefile8
-rw-r--r--devel/esdl/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/devel/clanlib-devel/Makefile b/devel/clanlib-devel/Makefile
index d84c2f903f17..6b73db22b4a6 100644
--- a/devel/clanlib-devel/Makefile
+++ b/devel/clanlib-devel/Makefile
@@ -41,6 +41,10 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
.if ${OSVERSION} < 500032
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
diff --git a/devel/erlslang/Makefile b/devel/erlslang/Makefile
index 0e58bdcd51e5..88ecb2f43849 100644
--- a/devel/erlslang/Makefile
+++ b/devel/erlslang/Makefile
@@ -30,6 +30,12 @@ USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC=${WRKSRC}/config
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-build:
@${RM} -r ${WRKSRC}/*/CVS
@${RM} -r ${WRKSRC}/*/.cvsignore
@@ -46,4 +52,4 @@ do-install:
@${CP} -r ${WRKSRC}/src ${PREFIX}/lib/erlang/lib/${DISTNAME}/src
@${LN} -sf ${DISTNAME} ${PREFIX}/lib/erlang/lib/slang
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/esdl/Makefile b/devel/esdl/Makefile
index 44d31159c5b5..e1089cb562bc 100644
--- a/devel/esdl/Makefile
+++ b/devel/esdl/Makefile
@@ -28,7 +28,13 @@ USE_SIZE= yes
ALL_TARGET= target
PLIST_SUB= VERSION="${PORTVERSION}"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-install:
@${LN} -sf ${PORTNAME}-${PORTVERSION} ${PREFIX}/lib/erlang/lib/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>