aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-12 12:07:37 +0800
committeredwin <edwin@FreeBSD.org>2007-09-12 12:07:37 +0800
commitc4264a6193ac8551d484278b24b7fc634ca65dfc (patch)
treecad6a3b1d632ffba650fddb3c32626af562e14ff /devel
parentdb13b9134f92972cf6d2b66be92f759425911d52 (diff)
downloadfreebsd-ports-gnome-c4264a6193ac8551d484278b24b7fc634ca65dfc.tar.gz
freebsd-ports-gnome-c4264a6193ac8551d484278b24b7fc634ca65dfc.tar.zst
freebsd-ports-gnome-c4264a6193ac8551d484278b24b7fc634ca65dfc.zip
[patch] Have devel/libhid also install its python site-package
When devel/swig13 is installed, building of devel/libhid fails, due to my overlooking of the swig detection bits in the ports configure script. However, swig is used to build the python site-package of the port, so I've bumped the portrevision and turned these bits on by default (the additional patch-Makefile.in hunk is to suppress a warning). PR: ports/116076 Submitted by: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
Diffstat (limited to 'devel')
-rw-r--r--devel/libhid/Makefile8
-rw-r--r--devel/libhid/files/patch-Makefile.in9
-rw-r--r--devel/libhid/files/patch-configure14
-rw-r--r--devel/libhid/pkg-plist14
4 files changed, 43 insertions, 2 deletions
diff --git a/devel/libhid/Makefile b/devel/libhid/Makefile
index 4095536410bd..43568e1d1d7f 100644
--- a/devel/libhid/Makefile
+++ b/devel/libhid/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libhid
PORTVERSION= 0.2.16
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://alioth.debian.org/frs/download.php/1958/
@@ -16,12 +17,15 @@ COMMENT= A user-space HID access library written in C
MAN1= libhid-detach-device.1
MANCOMPRESSED= no
USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
- ${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl
+ ${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man --without-doxygen
.include <bsd.port.mk>
diff --git a/devel/libhid/files/patch-Makefile.in b/devel/libhid/files/patch-Makefile.in
index e11bb27241c6..cc2b4d0a5d0b 100644
--- a/devel/libhid/files/patch-Makefile.in
+++ b/devel/libhid/files/patch-Makefile.in
@@ -9,3 +9,12 @@
pkgconfig_DATA = pkgconfig/libhid.pc
dist_noinst_DATA = \
debian/changelog \
+@@ -293,7 +293,7 @@
+ README.licence
+
+ DEBIAN_VERSION = ${shell head -1 debian/changelog 2>/dev/null | sed -e '1s,.*(\([^)]*\)).*,\1,'}
+-DEBIAN_ARCH = $(shell test -x `which dpkg-architecture 2>/dev/null` && dpkg-architecture -qDEB_BUILD_ARCH 2>/dev/null || echo i386)
++DEBIAN_ARCH = i386
+ TARBALL = $(distdir).tar.gz
+ DEBDIR = .debian
+ STAMP = $(DEBDIR)/stamp
diff --git a/devel/libhid/files/patch-configure b/devel/libhid/files/patch-configure
new file mode 100644
index 000000000000..81885493c169
--- /dev/null
+++ b/devel/libhid/files/patch-configure
@@ -0,0 +1,14 @@
+--- configure.orig 2007-04-26 03:25:25.000000000 +0300
++++ configure 2007-09-04 11:10:38.000000000 +0300
+@@ -22784,8 +22784,9 @@
+ fi
+
+ PYTHON_LDFLAGS=`$PYTHON -c "from distutils.sysconfig import *; \
+- import os; \
+- print apply(os.path.join, get_config_vars('LIBPL', 'LDLIBRARY'))"`
++ import os; import re; from string import join; \
++ print join(get_config_vars('LDFLAGS')) + ' ' + \
++ re.sub('\.a$', '.so', apply(os.path.join, get_config_vars('LIBPL', 'LDLIBRARY')))"`
+ fi
+ { echo "$as_me:$LINENO: result: $PYTHON_LDFLAGS" >&5
+ echo "${ECHO_T}$PYTHON_LDFLAGS" >&6; }
diff --git a/devel/libhid/pkg-plist b/devel/libhid/pkg-plist
index 626bf1a08e60..ea1587e2cb19 100644
--- a/devel/libhid/pkg-plist
+++ b/devel/libhid/pkg-plist
@@ -7,3 +7,17 @@ lib/libhid.la
lib/libhid.so
lib/libhid.so.0
libdata/pkgconfig/libhid.pc
+%%PYTHON_SITELIBDIR%%/libhid/_hid.so.0
+%%PYTHON_SITELIBDIR%%/libhid/_hid.so
+%%PYTHON_SITELIBDIR%%/libhid/_hid.la
+%%PYTHON_SITELIBDIR%%/libhid/_hid.a
+%%PYTHON_SITELIBDIR%%/libhid/__init__.py
+%%PYTHON_SITELIBDIR%%/libhid/__init__.pyc
+%%PYTHON_SITELIBDIR%%/libhid/__init__.pyo
+%%PYTHON_SITELIBDIR%%/libhid/hid.py
+%%PYTHON_SITELIBDIR%%/libhid/hid.pyc
+%%PYTHON_SITELIBDIR%%/libhid/hid.pyo
+%%PYTHON_SITELIBDIR%%/libhid/hidwrap.py
+%%PYTHON_SITELIBDIR%%/libhid/hidwrap.pyc
+%%PYTHON_SITELIBDIR%%/libhid/hidwrap.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/libhid/