aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-14 22:04:29 +0800
committerpav <pav@FreeBSD.org>2005-09-14 22:04:29 +0800
commitc4c972746b7234f707265730322c8910d14a624c (patch)
tree345178774ec2d4f4fa3584b25582c8f65507d1ad /devel
parent6b7adf9096bfb9bbed9ccbca3bf10d268a8db4f2 (diff)
downloadfreebsd-ports-gnome-c4c972746b7234f707265730322c8910d14a624c.tar.gz
freebsd-ports-gnome-c4c972746b7234f707265730322c8910d14a624c.tar.zst
freebsd-ports-gnome-c4c972746b7234f707265730322c8910d14a624c.zip
PHPDoc is an attemt to adopt Javadoc to the PHP world.
PR: ports/84643 Submitted by: Gerrit Beine <tux@pinguru.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-PHPDoc/Makefile113
-rw-r--r--devel/pear-PHPDoc/distinfo2
-rw-r--r--devel/pear-PHPDoc/files/patch-phpdoc11
-rw-r--r--devel/pear-PHPDoc/pkg-descr3
5 files changed, 130 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4120639b7a77..f2969aa137e6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1221,6 +1221,7 @@
SUBDIR += pear-OLE
SUBDIR += pear-PEAR
SUBDIR += pear-PEAR_PackageFileManager
+ SUBDIR += pear-PHPDoc
SUBDIR += pear-PHPUnit
SUBDIR += pear-PHPUnit2
SUBDIR += pear-PHP_Beautifier
diff --git a/devel/pear-PHPDoc/Makefile b/devel/pear-PHPDoc/Makefile
new file mode 100644
index 000000000000..79beebed9ad7
--- /dev/null
+++ b/devel/pear-PHPDoc/Makefile
@@ -0,0 +1,113 @@
+# Ports collection makefile for: pear-PHPDoc
+# Date created: 22 July 2005
+# Whom: Gerrit Beine (<gerrit@beine-computer.de>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHPDoc
+PORTVERSION= 0.1.0
+CATEGORIES= devel www pear
+
+MAINTAINER= tux@pinguru.net
+COMMENT= Tool to generate documentation from the source
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= PHPDoc
+FILES= accessor/PhpdocAccessor.php \
+ accessor/PhpdocClassAccessor.php \
+ accessor/PhpdocDocumentAccessor.php \
+ accessor/PhpdocIndexAccessor.php \
+ accessor/PhpdocModuleAccessor.php \
+ accessor/PhpdocWarningAccessor.php \
+ analyser/PhpdocAnalyser.php \
+ analyser/PhpdocClassAnalyser.php \
+ analyser/PhpdocModuleAnalyser.php \
+ core/Phpdoc.php \
+ core/PhpdocArgvHandler.php \
+ core/PhpdocObject.php \
+ core/PhpdocSetupHandler.php \
+ exceptions/PhpdocError.php \
+ filehandler/PhpdocFileHandler.php \
+ indexer/PhpdocIndexer.php \
+ parser/PhpdocClassParser.php \
+ parser/PhpdocConstantParser.php \
+ parser/PhpdocFunctionParser.php \
+ parser/PhpdocModuleParser.php \
+ parser/PhpdocParser.php \
+ parser/PhpdocParserCore.php \
+ parser/PhpdocParserRegExp.php \
+ parser/PhpdocParserTags.php \
+ parser/PhpdocUseParser.php \
+ parser/PhpdocVariableParser.php \
+ redist/IT.php \
+ redist/ITX.php \
+ renderer/PhpdocRendererObject.php \
+ renderer/html/PhpdocHTMLClassRenderer.php \
+ renderer/html/PhpdocHTMLDocumentRenderer.php \
+ renderer/html/PhpdocHTMLIndexRenderer.php \
+ renderer/html/PhpdocHTMLModuleRenderer.php \
+ renderer/html/PhpdocHTMLRenderer.php \
+ renderer/html/PhpdocHTMLRendererManager.php \
+ renderer/html/PhpdocHTMLWarningRenderer.php \
+ renderer/html/templates.php \
+ warning/PhpdocWarning.php \
+ xmlexporter/PhpdocXMLClassExporter.php \
+ xmlexporter/PhpdocXMLDocumentExporter.php \
+ xmlexporter/PhpdocXMLExporter.php \
+ xmlexporter/PhpdocXMLIndexExporter.php \
+ xmlexporter/PhpdocXMLModuleExporter.php \
+ xmlexporter/PhpdocXMLWarningExporter.php \
+ xmlreader/PhpdocXMLReader.php \
+ xmlwriter/PhpdocXMLWriter.php \
+ prepend.php
+_DATADIR= .
+DATA= renderer/html/default/class.html \
+ renderer/html/default/classtree.html \
+ renderer/html/default/elementlist.html \
+ renderer/html/default/frame_packageelementlist.html \
+ renderer/html/default/frame_packagelist.html \
+ renderer/html/default/module.html \
+ renderer/html/default/modulegroup.html \
+ renderer/html/default/packagelist.html \
+ renderer/html/default/warnings.html \
+ renderer/html/default/xmlfiles.html \
+ renderer/html/default/static/empty.html \
+ renderer/html/default/static/index.html \
+ renderer/html/default/static/phpdoc.css \
+ renderer/html/default/static/phpdoc.dtd \
+ renderer/html/timmyg/bottom_nav.html \
+ renderer/html/timmyg/class.html \
+ renderer/html/timmyg/classtree.html \
+ renderer/html/timmyg/elementlist.html \
+ renderer/html/timmyg/frame_packageelementlist.html \
+ renderer/html/timmyg/frame_packagelist.html \
+ renderer/html/timmyg/module.html \
+ renderer/html/timmyg/modulegroup.html \
+ renderer/html/timmyg/packagelist.html \
+ renderer/html/timmyg/top_nav.html \
+ renderer/html/timmyg/warnings.html \
+ renderer/html/timmyg/xmlfiles.html \
+ renderer/html/timmyg/static/empty.html \
+ renderer/html/timmyg/static/index.html \
+ renderer/html/timmyg/static/phpdoc.css \
+ renderer/html/timmyg/static/phpdoc.dtd \
+ renderer/html/timmyg/static/phpdoc_warnings.html \
+ renderer/html/.empty \
+ renderer/.empty
+SCRIPTFILES= phpdoc
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,@php_dir@,${PEARDIR}," \
+ -e "s,@doc_dir@,${DOCSDIR}," \
+ -e "s,@data_dir@,${DATADIR}," ${WRKSRC}/phpdoc
+ @${MV} ${WRKSRC}/phpdoc ${WRKSRC}/pear-phpdoc
+ @${TOUCH} ${WRKSRC}/renderer/html/.empty
+ @${TOUCH} ${WRKSRC}/renderer/.empty
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PHPDoc/distinfo b/devel/pear-PHPDoc/distinfo
new file mode 100644
index 000000000000..4067377d4564
--- /dev/null
+++ b/devel/pear-PHPDoc/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/PHPDoc-0.1.0.tgz) = 7d7d939fb7faeb1fa18c924eba165173
+SIZE (PEAR/PHPDoc-0.1.0.tgz) = 88108
diff --git a/devel/pear-PHPDoc/files/patch-phpdoc b/devel/pear-PHPDoc/files/patch-phpdoc
new file mode 100644
index 000000000000..ef5566024fc9
--- /dev/null
+++ b/devel/pear-PHPDoc/files/patch-phpdoc
@@ -0,0 +1,11 @@
+--- phpdoc Fri Jul 26 16:49:39 2002
++++ phpdoc Sun Aug 7 15:37:40 2005
+@@ -17,7 +17,7 @@
+ // save the generated docs here:
+ $dest_apidoc_dir = '@doc_dir@';
+ // default template dir:
+-$template_dir = '@data_dir@/PHPDoc';
++$template_dir = '@data_dir@';
+ $template = 'default';
+ // force the deletion of the target apidocs directory
+ $dest_apidoc_delete = false;
diff --git a/devel/pear-PHPDoc/pkg-descr b/devel/pear-PHPDoc/pkg-descr
new file mode 100644
index 000000000000..de02a9100f52
--- /dev/null
+++ b/devel/pear-PHPDoc/pkg-descr
@@ -0,0 +1,3 @@
+PHPDoc is an attemt to adopt Javadoc to the PHP world.
+
+WWW: http://pear.php.net/package/PHPDoc/