aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2008-04-07 10:09:39 +0800
committermnag <mnag@FreeBSD.org>2008-04-07 10:09:39 +0800
commitc64592959f8e4743a47d37a8e183d0a6b3948da5 (patch)
tree42385b35e57e4aabd0f9b1a72b10f78a2e48de47 /devel
parentd5d8d157e0b5546d0fb94392eec2d4c25098d826 (diff)
downloadfreebsd-ports-gnome-c64592959f8e4743a47d37a8e183d0a6b3948da5.tar.gz
freebsd-ports-gnome-c64592959f8e4743a47d37a8e183d0a6b3948da5.tar.zst
freebsd-ports-gnome-c64592959f8e4743a47d37a8e183d0a6b3948da5.zip
- Use pkg-config to determine if sqlite3 are compiled with threads
- Add USE_GNOME=pkgconfig - portlint(1) Reported by: pav
Diffstat (limited to 'devel')
-rw-r--r--devel/cvstrac/Makefile4
-rw-r--r--devel/cvstrac/files/patch-Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/devel/cvstrac/Makefile b/devel/cvstrac/Makefile
index 121e832bcdf9..f1dc2bf5919a 100644
--- a/devel/cvstrac/Makefile
+++ b/devel/cvstrac/Makefile
@@ -11,12 +11,12 @@ CATEGORIES= devel
MASTER_SITES= http://www.cvstrac.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Web-Based Bug And Patch-Set Tracking System For CVS
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_SQLITE= yes
-
+USE_GNOME= pkgconfig
USE_GMAKE= yes
MAKE_ARGS= SRCDIR=${WRKSRC} PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
diff --git a/devel/cvstrac/files/patch-Makefile b/devel/cvstrac/files/patch-Makefile
index 860af30ceb9f..1e40f2f7ab18 100644
--- a/devel/cvstrac/files/patch-Makefile
+++ b/devel/cvstrac/files/patch-Makefile
@@ -25,7 +25,7 @@
+
+#### Extra arguments for linking against SQLite
+#
-+LIBSQLITE = -L$(LOCALBASE)/lib -lsqlite3 -lcrypt
++LIBSQLITE = -L$(LOCALBASE)/lib `pkg-config --static --libs sqlite3` -lcrypt
+
+#### Installation directory
+#