aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-07 07:46:17 +0800
committerkris <kris@FreeBSD.org>2004-03-07 07:46:17 +0800
commitc6c7245b2d838b19fb3a5a25fc33ede9b55b8cac (patch)
treee24e205bf7b1fe0391e23b34ccb1fd90be3a8c29 /devel
parent00c8bcea167eee2d87ec081838b930e438dc0fc9 (diff)
downloadfreebsd-ports-gnome-c6c7245b2d838b19fb3a5a25fc33ede9b55b8cac.tar.gz
freebsd-ports-gnome-c6c7245b2d838b19fb3a5a25fc33ede9b55b8cac.tar.zst
freebsd-ports-gnome-c6c7245b2d838b19fb3a5a25fc33ede9b55b8cac.zip
BROKEN on !i386 and !alpha: Does not compile
Diffstat (limited to 'devel')
-rw-r--r--devel/gdb53-act/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/gdb53-act/Makefile b/devel/gdb53-act/Makefile
index 12dad4216f9e..bb8212aaefc2 100644
--- a/devel/gdb53-act/Makefile
+++ b/devel/gdb53-act/Makefile
@@ -28,6 +28,13 @@ DIST_SUBDIR= ${PKGNAME}
CVS_CMD?= cvs -z3 -qR
CVSROOT= :pserver:anoncvs@libre.act-europe.fr:/anoncvs
STAMPFILE= ${DISTDIR}/${DIST_SUBDIR}/.timestamp
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Does not compile on !i386 and !alpha"
+.endif
+
do-fetch:
@if [ ! -e ${WRKDIR}/.extract_done ] ; then \
if [ ! -e ${STAMPFILE} ] ; then \
@@ -71,4 +78,4 @@ pre-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/gdbada
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>