aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-12-27 18:02:05 +0800
committertobez <tobez@FreeBSD.org>2005-12-27 18:02:05 +0800
commitc71fa7df7da28da0d4578771009c8064dfef3b96 (patch)
treeec35b89a3186039ce9414740d92ebb8b263e361b /devel
parent0ab8873205929efc2dd2004f331ed5f60f7557ec (diff)
downloadfreebsd-ports-gnome-c71fa7df7da28da0d4578771009c8064dfef3b96.tar.gz
freebsd-ports-gnome-c71fa7df7da28da0d4578771009c8064dfef3b96.tar.zst
freebsd-ports-gnome-c71fa7df7da28da0d4578771009c8064dfef3b96.zip
Add devel/p5-File-ShareDir 0.02, a Perl module to locate
per-distribution and per-module shared files location.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-ShareDir/Makefile34
-rw-r--r--devel/p5-File-ShareDir/distinfo3
-rw-r--r--devel/p5-File-ShareDir/pkg-descr18
-rw-r--r--devel/p5-File-ShareDir/pkg-plist5
5 files changed, 61 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 32c74a240a30..fe2afde1bd9c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -929,6 +929,7 @@
SUBDIR += p5-File-Random
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
+ SUBDIR += p5-File-ShareDir
SUBDIR += p5-File-Slurp
SUBDIR += p5-File-Sync
SUBDIR += p5-File-Tail
diff --git a/devel/p5-File-ShareDir/Makefile b/devel/p5-File-ShareDir/Makefile
new file mode 100644
index 000000000000..15b9aeb5769d
--- /dev/null
+++ b/devel/p5-File-ShareDir/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: devel/p5-File-ShareDir
+# Date created: 27 Dec 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-ShareDir
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= File::ShareDir - Locate per-dist and per-module shared files
+
+BUILD_DEPENDS= \
+ p5-Params-Util>=0.07:${PORTSDIR}/devel/p5-Params-Util \
+ p5-Class-Inspector>=1.12:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::ShareDir.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-ShareDir/distinfo b/devel/p5-File-ShareDir/distinfo
new file mode 100644
index 000000000000..88a425cab8f3
--- /dev/null
+++ b/devel/p5-File-ShareDir/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-ShareDir-0.02.tar.gz) = b9b38e715733d5be97f9f4c40b7b83dd
+SHA256 (File-ShareDir-0.02.tar.gz) = 22f7d75ecd381be382ed3da8a195c423bb6effad2d2a5b4ef8d94629f6869605
+SIZE (File-ShareDir-0.02.tar.gz) = 27142
diff --git a/devel/p5-File-ShareDir/pkg-descr b/devel/p5-File-ShareDir/pkg-descr
new file mode 100644
index 000000000000..1d3c98d4c470
--- /dev/null
+++ b/devel/p5-File-ShareDir/pkg-descr
@@ -0,0 +1,18 @@
+The intent of File::ShareDir is to provide a companion to
+Class::Inspector and File::HomeDir, modules that take a process that is
+well-known by advanced Perl developers but gets a little tricky, and
+make it more available to the larger Perl community.
+
+Quite often you want or need your Perl module (CPAN or otherwise) to
+have access to a large amount of read-only data that is stored on the
+file-system at run-time.
+
+On a linux-like system, this would be in a place such as /usr/share,
+however Perl runs on a wide variety of different systems, and so the use
+of any one location is unreliable.
+
+Perl provides a little-known method for doing this, but almost nobody is
+aware that it exists. As a result, module authors often go through some
+very strange ways to make the data available to their code.
+
+WWW: http://search.cpan.org/dist/File-ShareDir/
diff --git a/devel/p5-File-ShareDir/pkg-plist b/devel/p5-File-ShareDir/pkg-plist
new file mode 100644
index 000000000000..8aad79be470a
--- /dev/null
+++ b/devel/p5-File-ShareDir/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ShareDir/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ShareDir/sample.txt
+%%SITE_PERL%%/%%PERL_ARCH%%/File/ShareDir.pm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ShareDir 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true